Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Diesel Owners / Enthusiasts

BMW Diesel Owners / Enthusiasts
Do you own a diesel powered BMW? Maybe a 335d or a BMW x35d? Come and talk about what makes your car great!

Reply
 
Thread Tools Display Modes
  #1  
Old 10-17-2010, 02:58 PM
bballfreak bballfreak is offline
Officially Welcomed to the 'Fest
Location: San antonio, TX
 
Join Date: Jul 2010
Posts: 227
Mein Auto: 2009 335d
Service Engine Soon light question on 335d

My 2009 335d while I was driving from San Antonio to Houston, I got this light
saying Service Engine Soon. I took it to the BMW dealer in Houston, and they said it
light was due to dirty or clogged SCR metering valve.
The car was running fine prior to this. Was getting close to 42mpg at 75mph.
They cleaned the SCR valve and the light is gone.
Did anyone else have this problem?
I have always put Shell or Chevron diesel fuel.
Reply With Quote
Advertisement
  #2  
Old 10-17-2010, 03:21 PM
tlak77 tlak77 is offline
Officially Welcomed to the 'Fest
Location: Marion, IA
 
Join Date: Aug 2009
Posts: 591
Mein Auto: F30 335i
Please do search. SCR has not much to do with fuel you are using; and problem you have starts to be fairly common.
__________________
T

2013 335i F30

B45, LCSW, ZMM, ZDH, ZPP, ZTP, 337, 2TV, 428, 494, 688, 6AA, 6AB, 6VA
2010 335d E90 - Gone
300, LCAD, ZPP, ZSP, 2XA, 302, 465, 494, 4B9, 609, 655, 677, 6FL, 6NF
Flickr
Reply With Quote
  #3  
Old 10-17-2010, 04:59 PM
Philm35 Philm35 is offline
Human
Location: Cincinnati, OH USA
 
Join Date: Aug 2010
Posts: 252
Mein Auto: 2011 BMW 335d
I had exactly the same problem with only 1000 miles on my d.

--Phil
__________________

2011 BMW 335d, Space Grey/Black, Sport, Premium, Cold Weather, Convenience, Nav, Harman Kardon/Sat, iPod
2010 Audi A4 2.0 Quattro P+ 6MT (Wife's car)
2004 BMW R1150RA
Reply With Quote
  #4  
Old 10-17-2010, 06:01 PM
bballfreak bballfreak is offline
Officially Welcomed to the 'Fest
Location: San antonio, TX
 
Join Date: Jul 2010
Posts: 227
Mein Auto: 2009 335d
SCR light in 335d

Sorry, I should have done a search. It appears that this SCR is a common issue with 335d.
It was the first time in my 2009 335d with 10K miles.
Hopefully does not come back any time soon.
I was a bit surprised that I was getting 41 mpg on the hwy.
Reply With Quote
  #5  
Old 10-17-2010, 06:04 PM
Philm35 Philm35 is offline
Human
Location: Cincinnati, OH USA
 
Join Date: Aug 2010
Posts: 252
Mein Auto: 2011 BMW 335d
41 MPG is not bad, but not unusual from what I read around here. My most recent long freeway trip yielded 38 MPG, and that included having a lot of fun with torque.

Has your mileage changed since you had the repair done?

--Phil
__________________

2011 BMW 335d, Space Grey/Black, Sport, Premium, Cold Weather, Convenience, Nav, Harman Kardon/Sat, iPod
2010 Audi A4 2.0 Quattro P+ 6MT (Wife's car)
2004 BMW R1150RA
Reply With Quote
  #6  
Old 10-17-2010, 06:11 PM
bballfreak bballfreak is offline
Officially Welcomed to the 'Fest
Location: San antonio, TX
 
Join Date: Jul 2010
Posts: 227
Mein Auto: 2009 335d
Mileage after repair

The mileage dropped to like 39mpg as I was driving in the city.
Reply With Quote
  #7  
Old 11-15-2010, 12:17 AM
johnson12345 johnson12345 is offline
Registered User
Location: CA
 
Join Date: Nov 2010
Posts: 3
Mein Auto: BMW 335d
Is this the 4D35 fault code? I have had this problem three times already with less than 5000 miles.... Is there a fix?
Reply With Quote
  #8  
Old 11-15-2010, 06:26 AM
F32Fleet F32Fleet is offline
Officially Welcomed to the 'Fest
Location: SE United States
 
Join Date: Jul 2010
Posts: 1,332
Mein Auto: 435i, 335d sold.
It's not a common issue, but it's common for those few who get the SES light.
__________________
Current: 435i, M-sport, MPPK, 8SP
Previous : e90 335d, e90 330i, e46 330 zhp.
Reply With Quote
  #9  
Old 03-12-2011, 08:48 AM
Moxie Moxie is offline
Registered User
Location: Stuttgart
 
Join Date: Jul 2010
Posts: 33
Mein Auto: 10 M3, 10 335d, 97 320i
I have less than 2K miles on our 2010. The SES light came on again after the software update. Going back to the dealer this week.
Reply With Quote
  #10  
Old 03-12-2011, 09:46 AM
335devil 335devil is offline
Registered User
Location: California
 
Join Date: Nov 2010
Posts: 10
Mein Auto: '11 335d, M-Sport/Premium
Mine just came on three days after my first servicing (11k), so it is at the shop awaiting diagnostics. I get 33-34 mpg, but that is because 80% of my commute is freeway and the operant speed out here is 80mph--if you go slower you get passed! My bud at the dealer said it may be the O2 sensor, but will report back.

Still lovin' it!
__________________
2011 335d / E90/ LeMans Blue / Dakota Black Leather / MSport Package / Premium Package / Navigation/ iDrive / Xenon
Reply With Quote
  #11  
Old 03-15-2011, 09:15 PM
335devil 335devil is offline
Registered User
Location: California
 
Join Date: Nov 2010
Posts: 10
Mein Auto: '11 335d, M-Sport/Premium
See my answer in the 4D35 thread
__________________
2011 335d / E90/ LeMans Blue / Dakota Black Leather / MSport Package / Premium Package / Navigation/ iDrive / Xenon

Last edited by 335devil; 03-15-2011 at 09:33 PM. Reason: noob mistake
Reply With Quote
  #12  
Old 03-21-2011, 07:18 PM
AZDrPhil AZDrPhil is offline
Registered User
Location: Arizona
 
Join Date: Mar 2011
Posts: 29
Mein Auto: 335d now gone
8 days & seeing Service Engine Soon

2011 335d, have had the car 8 days & have 300 miles on it. Service Engine Soon light comes on while driving today. What a crock! Called dealer and they said check your gas cap...make sure it clicks when tightening it. Noticed though that my 335d gas cap doesn't click at all like my 328i did, hope that's normal. Dealer also said if it was a gas cap issue it would clear itself out after a handful of engine start/stops.

Don't feel good about this after reading everyone's comments here........
Reply With Quote
  #13  
Old 03-21-2011, 07:37 PM
bimmerdiesel's Avatar
bimmerdiesel bimmerdiesel is offline
Officially Welcomed to the 'Fest
Location: Bedford MA
 
Join Date: Jul 2010
Posts: 839
Mein Auto: 335d
Quote:
Originally Posted by AZDrPhil View Post
2011 335d, have had the car 8 days & have 300 miles on it. Service Engine Soon light comes on while driving today. What a crock! Called dealer and they said check your gas cap...make sure it clicks when tightening it. Noticed though that my 335d gas cap doesn't click at all like my 328i did, hope that's normal. Dealer also said if it was a gas cap issue it would clear itself out after a handful of engine start/stops.

Don't feel good about this after reading everyone's comments here........
I know seeing SES on brand new car does bother but dont worry. Gas cap is usual cause. If it doesnt go then dealer might have missed some step in their prep of car. If it drives normal should be very small issue. DEF is not at all issue so dont let it bother you.
__________________

335d Black Sapphire/Biege/Premium/Sport/Cold/Nav/CA/PDC/iPod

Reply With Quote
  #14  
Old 03-21-2011, 08:10 PM
rmorin49's Avatar
rmorin49 rmorin49 is online now
Officially Welcomed to the 'Fest
Location: Hagerstown, MD,
 
Join Date: Jan 2007
Posts: 4,209
Mein Auto: 2011 335d
I am just about to pull the trigger on an ED for a 335d. Is the issue in this thread a new one or one that has been around for a while? How common is it? The nearest dealer is about an hour drive from me so I'm not looking forward to dealing with an issue that repeats itself as this car will be my DD and needs to be reliable. Appreciate any insight and guidance. Thanks.
__________________

Colonel (Ret) US Army / Hagerstown, MD
1985 M635 Euro Alpine White/Pacific Blue (Fun Car)FOR SALE(see ad on BMWCCA website)
2010 Z4 s30i Alpine White/Beige
2013 Audi A6 Ibis White/Nougat (Daily Driver)
2013 Audi A4(Ret)
2011 335d (Ret)
2009 335i vert (Ret)/PCD
2007 335i vert (Ret) ED 04-13-10/PCD
2000 740iL (Ret)
1998 328iC (Ret)
1990 535i (Ret)
1988 635CSi (Ret)

https://plus.google.com/photos/10999...COHGu-rlyIrrLg
Reply With Quote
  #15  
Old 03-22-2011, 07:44 AM
Snipe656 Snipe656 is offline
Officially Welcomed to the 'Fest
Location: Humble, Tx
 
Join Date: Oct 2009
Posts: 4,032
Mein Auto: 2009 335d
Quote:
Originally Posted by rmorin49 View Post
I am just about to pull the trigger on an ED for a 335d. Is the issue in this thread a new one or one that has been around for a while? How common is it? The nearest dealer is about an hour drive from me so I'm not looking forward to dealing with an issue that repeats itself as this car will be my DD and needs to be reliable. Appreciate any insight and guidance. Thanks.
I'd not worry about it, I have not had an SES in around a year now on my 2009. When I did have mine it was for a failed sensor then the dealer botched the job of replacing it, so the light continued until things were sorted out. Personally, I'd worry more about whether your dealer knows how to work on the diesel models or not. But I am willing to bet after three model years, they probably have a good idea and that is not even something to worry about.
__________________
--Admiral Aaron Rouse
Reply With Quote
  #16  
Old 03-22-2011, 04:49 PM
ZQQM ZQQM is offline
Registered User
Location: Burr Ridge, Ill
 
Join Date: Aug 2010
Posts: 70
Mein Auto: 335d
Quote:
Originally Posted by bimmerdiesel View Post
I know seeing SES on brand new car does bother but dont worry. Gas cap is usual cause. If it doesnt go then dealer might have missed some step in their prep of car. If it drives normal should be very small issue. DEF is not at all issue so dont let it bother you.
I agree with this statement. I've had the SES light go on 3/4 times since I bought it in September 2010 ( used w/ 2035 miles on it ). Its usually the gas cap or in my case the TPMS when it was getting below 10 degrees ( nitrogen fill solved this ). My advise to any new owner if the SES light shows up, check the fuel cap, and then just drive it for a few days, it will probably go out.

I also had a turn signal light outwarning symbol go on a month ago. Two days later the dash warning light went out.

I think the OBC and all the sensors are just very sensitive.
__________________
2014 328xd, Glacier Silver / Black

2008 Lotus Exige S240 in Storm Titanium, Track, Touring, LSD - with many speed, safety and carbon fiber parts added.

2009 335d, Black/Black, Premium, Cold - Gone
Reply With Quote
  #17  
Old 03-22-2011, 05:04 PM
Snipe656 Snipe656 is offline
Officially Welcomed to the 'Fest
Location: Humble, Tx
 
Join Date: Oct 2009
Posts: 4,032
Mein Auto: 2009 335d
Your SES light turns on for low tire pressure? Mine doesn't, my triangle warning light does instead.
__________________
--Admiral Aaron Rouse
Reply With Quote
  #18  
Old 03-22-2011, 05:27 PM
ZQQM ZQQM is offline
Registered User
Location: Burr Ridge, Ill
 
Join Date: Aug 2010
Posts: 70
Mein Auto: 335d
Quote:
Originally Posted by Snipe656 View Post
Your SES light turns on for low tire pressure? Mine doesn't, my triangle warning light does instead.
I stand corrected on which light turns on for TPMS warning.

Probably since I haven't seen it for a while.
__________________
2014 328xd, Glacier Silver / Black

2008 Lotus Exige S240 in Storm Titanium, Track, Touring, LSD - with many speed, safety and carbon fiber parts added.

2009 335d, Black/Black, Premium, Cold - Gone
Reply With Quote
  #19  
Old 03-22-2011, 05:27 PM
KarlB KarlB is offline
Officially Welcomed to the 'Fest
Location: Crockett,tx
 
Join Date: Nov 2004
Posts: 881
Mein Auto: 11 335d,08 K12GT,10 S1000
over 14k miles on our 2011 335d and no problemss at all to date
__________________
11 335d
2010 S1000RR
08 K1200GT
08 WR250R
Reply With Quote
  #20  
Old 03-22-2011, 05:45 PM
Snipe656 Snipe656 is offline
Officially Welcomed to the 'Fest
Location: Humble, Tx
 
Join Date: Oct 2009
Posts: 4,032
Mein Auto: 2009 335d
Quote:
Originally Posted by ZQQM View Post
I stand corrected on which light turns on for TPMS warning.

Probably since I haven't seen it for a while.
Mine goes off with major changes in outside temps. So a handful of times each winter. So I am just too familiar with it.
__________________
--Admiral Aaron Rouse
Reply With Quote
  #21  
Old 03-23-2011, 08:38 AM
ZQQM ZQQM is offline
Registered User
Location: Burr Ridge, Ill
 
Join Date: Aug 2010
Posts: 70
Mein Auto: 335d
Quote:
Originally Posted by Snipe656 View Post
Mine goes off with major changes in outside temps. So a handful of times each winter. So I am just too familiar with it.
Luckily I have access to a nitrogen tank at work. So I purged out the O2 and refilled with the nitrogen. And after the past 4 months, with some pretty cold days this season, I haven't had the warning light show up since.
__________________
2014 328xd, Glacier Silver / Black

2008 Lotus Exige S240 in Storm Titanium, Track, Touring, LSD - with many speed, safety and carbon fiber parts added.

2009 335d, Black/Black, Premium, Cold - Gone
Reply With Quote
  #22  
Old 03-23-2011, 08:44 AM
Snipe656 Snipe656 is offline
Officially Welcomed to the 'Fest
Location: Humble, Tx
 
Join Date: Oct 2009
Posts: 4,032
Mein Auto: 2009 335d
Quote:
Originally Posted by ZQQM View Post
Luckily I have access to a nitrogen tank at work. So I purged out the O2 and refilled with the nitrogen. And after the past 4 months, with some pretty cold days this season, I haven't had the warning light show up since.
I just have O2 in my tires and have been wonder how well nitrogen holds up to the drastic temp changes. That would be the only reason I'd bother paying to go to nitrogen.
__________________
--Admiral Aaron Rouse
Reply With Quote
  #23  
Old 03-25-2011, 01:57 PM
AZDrPhil AZDrPhil is offline
Registered User
Location: Arizona
 
Join Date: Mar 2011
Posts: 29
Mein Auto: 335d now gone
Update on my SES light.

SA says a problem with a vacuum something-or-other triggered the light. Replacement part isn't available in US so they need to order from Germany!

When I get my 'd' back I will have driven the 328 loaner 1.5-2x as long as my new 'd'.
Reply With Quote
  #24  
Old 03-25-2011, 02:23 PM
Snipe656 Snipe656 is offline
Officially Welcomed to the 'Fest
Location: Humble, Tx
 
Join Date: Oct 2009
Posts: 4,032
Mein Auto: 2009 335d
The things my car has needed, all had to come from the father land. Makes me wonder what, if anything, is stored in the states.
__________________
--Admiral Aaron Rouse
Reply With Quote
  #25  
Old 03-25-2011, 05:32 PM
railroader railroader is offline
Officially Welcomed to the 'Fest
Location: Southern Calif., USA
 
Join Date: Apr 2010
Posts: 159
Mein Auto: 2014 535d M-Sport
Quote:
Originally Posted by AZDrPhil View Post
Update on my SES light.

SA says a problem with a vacuum something-or-other triggered the light. Replacement part isn't available in US so they need to order from Germany!

When I get my 'd' back I will have driven the 328 loaner 1.5-2x as long as my new 'd'.
Sorry to read that, AZDrPhil-- and with that low of mileage, too. These are really sensitive cars in their various "warning systems." Especially the orange exclamation triangle...mine has been going on quite a bit lately in the past couple of weeks. After the "official" N/C oil change last week, I got the triangle and a "soft" warning -- saying the car has "detected a low oil condition." So right on the fwy, I had to stop and investigate. The dipstick was only "wet" at the very end at the red ball area! Man, am I glad our cars are one of the few late model BMW's that still boast the lowly dipstick! All agree?

I CARRY OIL in the trunk- a holdover from my early days driving wrecks and junkers; served me well in this case! The car was a full 1.5 quarts LOW. After I topped off, the triangle went promptly OUT. My local Center was aghast and quickly comped me two fresh quarts of the Castrol 5W-30 SLX. Turns out there were two other 335d's the same week with the same problem- one of the cars is owned by a tech at the shop. Apparently they are putting in 7 qts. and it needs closer to 8? But as I said- the protective systems are very sensitive and AZDoc- you'll have a fine car once they get your issue sorted out. Bit disconcerting though- that early in the going!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Diesel Owners / Enthusiasts
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 05:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms