Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #26  
Old 10-20-2010, 09:14 AM
53K 53K is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2010
Posts: 128
Mein Auto: 2011 335i
My car makes ticking noise from inside of the center console (around the shifter/idrive knob), from day 1, when the accelerator is depressed or sometimes braking. It is very annoying and I am scheduled to bring it in next Tue. I am hoping that this is an easy fix and this is not the start of many issues...
Since I was aware of pretty much all X5 issues from this board before my purchase (never heard of the ticking noise issue that I have now though), I am not overly shocked and will not say "vehicle this expensive shoudn't do that, etc..". It's just disappointing that it is happening from day 1 and I am starting to doubt the build quality of my X5. I really prayed I would get one of the good ones

Last edited by 53K; 10-20-2010 at 09:26 AM.
Reply With Quote
  #27  
Old 10-20-2010, 05:22 PM
RaleighX5 RaleighX5 is offline
Registered User
Location: Raleigh, NC
 
Join Date: Jul 2010
Posts: 24
Mein Auto: 2011 X5 35i Premium
Quote:
Originally Posted by 53K View Post
My car makes ticking noise from inside of the center console (around the shifter/idrive knob), from day 1, when the accelerator is depressed or sometimes braking. It is very annoying and I am scheduled to bring it in next Tue. I am hoping that this is an easy fix and this is not the start of many issues...
Since I was aware of pretty much all X5 issues from this board before my purchase (never heard of the ticking noise issue that I have now though), I am not overly shocked and will not say "vehicle this expensive shoudn't do that, etc..". It's just disappointing that it is happening from day 1 and I am starting to doubt the build quality of my X5. I really prayed I would get one of the good ones
I share your apprehension. The check engine light went on in my 2 and 1/2 month old 2011 35i and my heart sank. Took it in (with barely 3K on the odometer) and found that the emissions programming had totally been dropped and they had to re-program it. This didn't give me a warm and fuzzy feeling to be sure. I'm sure they'll get your issue figured out too and you'll soon be back on the road with a noise-free car!
Reply With Quote
  #28  
Old 10-21-2010, 06:02 AM
Marlbro's Avatar
Marlbro Marlbro is offline
UK (ex-Pat)
Location: Limburg, Belgium
 
Join Date: May 2010
Posts: 336
Mein Auto: 2010 X5 3.0d M pack
Quote:
Originally Posted by UncleJ View Post
Unfortunately every marque out there can develop the "UAW Friday Afternoon Option" (some would also extend that to Monday Morning as well) in that you can find a lot of lemons that don't grow on trees. Granted some more than others but anyone can put a bad one out there every now and then, not just the oft maligned domestics. And yes, even the europeans can have the problem.

True, but the items I listed are being experienced by quite a few of this Forum's members.
It's also fair to say that the are as many that say they do not have problems.
if we take this Forums' members to be a represenatative cross section, that would mean that there are far too many out here with these complaints, on a vehicle of this price class, it is inexcusable that BMW cost cut to the extent we are seeing.

The wheel hubs, and brake calipers should not be rusting on cars within the first year.
Even they should not rust period. It is easily technically possible to treat them as per Porsche Turbos, Lamborghini, Mercedes etc. The cost is not tha high, & I dare to say, the cost saving is not that significant either.

Part of an M Sport equiped vehicle could be to have uprated brakes (painted) so as not to see the corrosion through such open wheel designs (everyone would win)
__________________

2010 X5 30d M Sport pack on 20 inch
In Space Grey, Panoramic roof, auto tailgate,
Privacy Glass, Comfort seats in Black?
Rear view camera
Reply With Quote
  #29  
Old 10-21-2010, 04:09 PM
quackbury's Avatar
quackbury quackbury is offline
///Monkeyazz Duck
Location: Not In Kansas Any More
 
Join Date: Dec 2005
Posts: 4,278
Mein Auto: 535iX M Sport; 328i Wagon
Quote:
Originally Posted by 53K View Post
My car makes ticking noise from inside of the center console (around the shifter/idrive knob), from day 1, when the accelerator is depressed or sometimes braking. It is very annoying and I am scheduled to bring it in next Tue. I am hoping that this is an easy fix and this is not the start of many issues...
Since I was aware of pretty much all X5 issues from this board before my purchase (never heard of the ticking noise issue that I have now though), I am not overly shocked and will not say "vehicle this expensive shoudn't do that, etc..". It's just disappointing that it is happening from day 1 and I am starting to doubt the build quality of my X5. I really prayed I would get one of the good ones
Is the "ticking" sound similar to the sound when you move your shifter from D to S and vice versa? My wife's 2008 just started making that sound, with 38,000 miles on the odo. Never heard it before on that car or on our 2007, and have never seen it reposted on this board.

The transmission does NOT shift from D to S or back again by itself, but the sound is identical.
__________________


Current BMW's:
2014 328i Sport Wagon, Glacier / Black, ZSL, ZD2, ZD3, ZDH, ZLP, ZPP, ZTP, and H-K
2011 535xi M Sport TiAg / Black, ZPP, ZP2, ZCV, ZCW, ZDA, 2TB, 6NR, 465, 5DL, and a Partridge in a Pear Tree

Prior BMW's
2011 X5 35D
2008 ///M3 Vert
2008 X5 3.0
2007 X5 3.0
2006 X5 3.0
2006 550iA SP
2003 540iA M-Sport
Reply With Quote
  #30  
Old 10-21-2010, 04:50 PM
53K 53K is offline
Officially Welcomed to the 'Fest
Location: CA
 
Join Date: Apr 2010
Posts: 128
Mein Auto: 2011 335i
Quote:
Originally Posted by quackbury View Post
Is the "ticking" sound similar to the sound when you move your shifter from D to S and vice versa? My wife's 2008 just started making that sound, with 38,000 miles on the odo. Never heard it before on that car or on our 2007, and have never seen it reposted on this board.

The transmission does NOT shift from D to S or back again by itself, but the sound is identical.
I assume you meant D to DS. It doesn't really make any sound when I move shifter from D to DS, so I don't think it's that sound in my case. Mine sounds like a small loose part hitting onto a wall. At first I thought there was a loose hard plastic cap or something inside the center console, but since it happens with accelerator modulation, not so much with gravity/momentum, I am guessing it could be from some kind of linkage related with transmission. It's not terribly annoying, but loud enough that I can hear through music at modest/loud volume. I can't wait to get this thing fixed. I will let you know what I find out from next Tue.
Reply With Quote
  #31  
Old 10-22-2010, 09:35 PM
davahad davahad is offline
Registered User
Location: San Jose, CA
 
Join Date: Aug 2009
Posts: 3
Mein Auto: X5 Diesel
Quote:
Originally Posted by quackbury View Post
Is the "ticking" sound similar to the sound when you move your shifter from D to S and vice versa? My wife's 2008 just started making that sound, with 38,000 miles on the odo. Never heard it before on that car or on our 2007, and have never seen it reposted on this board.

The transmission does NOT shift from D to S or back again by itself, but the sound is identical.
My 2009 has 24,000 miles and I have the exact same rattle. It just started about 2 months ago and has been getting worse. To the point now where it is easily re creatable which is what I have been waiting for. If I put my hand in the ash tray and pull towards the shifter the sound almost goes away completely. I can also tap on the shifter as well as the side of console and make the noise.

This is in addition to the rattling I have on a rear speaker, tailgate window, passenger area around the door, etc. etc.

I love driving this car but I really don't think I would buy another as the rattles really take away from my enjoyment.
Reply With Quote
  #32  
Old 10-25-2010, 08:21 AM
Havelcek Havelcek is offline
Casual Fan
Location: New Jersey
 
Join Date: Oct 2007
Posts: 132
Mein Auto: 2011 X5
Quote:
Originally Posted by davahad View Post
My 2009 has 24,000 miles and I have the exact same rattle. It just started about 2 months ago and has been getting worse. To the point now where it is easily re creatable which is what I have been waiting for. If I put my hand in the ash tray and pull towards the shifter the sound almost goes away completely. I can also tap on the shifter as well as the side of console and make the noise.

This is in addition to the rattling I have on a rear speaker, tailgate window, passenger area around the door, etc. etc.

I love driving this car but I really don't think I would buy another as the rattles really take away from my enjoyment.
The tailgate on my '08 X3 rattles enough that you think its going to pop open. I have it "adjusted" nearly every dealer trip. Simply poor tolerance design.
Reply With Quote
  #33  
Old 11-01-2010, 11:06 PM
ttl2000 ttl2000 is offline
Registered User
Location: California
 
Join Date: Oct 2005
Posts: 3
Mein Auto: 2008 X5 3.0si, 2001 530iA
Quote:
Originally Posted by 53K View Post
My car makes ticking noise from inside of the center console (around the shifter/idrive knob), from day 1, when the accelerator is depressed or sometimes braking. It is very annoying and I am scheduled to bring it in next Tue. I am hoping that this is an easy fix and this is not the start of many issues...
Since I was aware of pretty much all X5 issues from this board before my purchase (never heard of the ticking noise issue that I have now though), I am not overly shocked and will not say "vehicle this expensive shoudn't do that, etc..". It's just disappointing that it is happening from day 1 and I am starting to doubt the build quality of my X5. I really prayed I would get one of the good ones
MY 2008 3.0si started making this noise couple weeks ago at ~21K miles....the same clicking noise when you press the left button on the stick to move to D from P position....somekind of interlock.... Scanned the car tonight and got a "A833 GWS Button, Deblocking, Jammed" fault code...does not look like the system can store more than 3 incidents....since the car seems to be running fine, plan to take care of it on the next visit...the clicking noise has not come come back for couple weeks now.....
Reply With Quote
  #34  
Old 11-03-2010, 07:02 PM
CapeAnn CapeAnn is offline
Registered User
Location: MA
 
Join Date: Nov 2010
Posts: 1
Mein Auto: X5
Do I have a lemon?

I own an 09 X5 35d that i bought new. I now have 18k miles on it. Since i bought it, I have had at least 10 warranty visits for the following:

Replaced steering wheel since heater would not work. That took 3 visits to correct.

The powered rear lift gate stopped working. 4 visits. They replaced the motor and controller, but finally determined that the wires leading from the roof to the top of the gate were chafing, thus shorting out. They codged an insulation solution that made news at BMW USA.

The large sunroof got stuck in the vent position. Took one 5-day visit to replace the tracks or rails for the roof.

Nav system would no longer read the DVD. Replaced the DVD system for the Nav as part of the sunroof visit.

That's all the major stuff i can remember. All covered under warranty, thank god. Now, should I trade it for another X5, or they just unreliable? I love the car otherwise.
Reply With Quote
  #35  
Old 11-03-2010, 09:36 PM
rattmann rattmann is offline
Officially Welcomed to the 'Fest
Location: Chicago
 
Join Date: Sep 2010
Posts: 241
Mein Auto: 2011 TURBO X5 35i
My 3 Month old 35i Premium Loaded.
Just drop the car at the dealer to check the FREEZING I drive and NAvigation system.
The first 30mins after initial start, all seems to work fine, but then all electronics freezes and crashed in reboot in 180 seconds.
I.E.
Navigation system, Radio, SOS, CD, DVD, Phone, PDC, Cameras, settings like turn signal and day time lights.
The crash cycles continues every 4-7 minutes on words.
Only way to stop is cycle is to take the key out and shut off for 10 minutes.
I tried with I phone, Blackberry, and no phones.

I think it is hardware related because of 30 minutes delay for onset.
Reply With Quote
  #36  
Old 11-03-2010, 11:03 PM
Daneandjake1 Daneandjake1 is offline
Registered User
Location: Greensboro
 
Join Date: Sep 2010
Posts: 58
Mein Auto: 2004 X3 2.5i
What year is your X5?
Reply With Quote
  #37  
Old 11-04-2010, 01:33 AM
Marlbro's Avatar
Marlbro Marlbro is offline
UK (ex-Pat)
Location: Limburg, Belgium
 
Join Date: May 2010
Posts: 336
Mein Auto: 2010 X5 3.0d M pack
Quote:
Originally Posted by rattmann View Post
My 3 Month old 35i Premium Loaded.
Just drop the car at the dealer to check the FREEZING I drive and NAvigation system.
The first 30mins after initial start, all seems to work fine, but then all electronics freezes and crashed in reboot in 180 seconds.
I.E.
Navigation system, Radio, SOS, CD, DVD, Phone, PDC, Cameras, settings like turn signal and day time lights.
The crash cycles continues every 4-7 minutes on words.
Only way to stop is cycle is to take the key out and shut off for 10 minutes.
I tried with I phone, Blackberry, and no phones.

I think it is hardware related because of 30 minutes delay for onset.
A new C.E.M and software reflash should take care of that (a 1 day visit) things like this happen, not just to BMW, it's down to the suppliers Quality checks at the end of their line.
__________________

2010 X5 30d M Sport pack on 20 inch
In Space Grey, Panoramic roof, auto tailgate,
Privacy Glass, Comfort seats in Black?
Rear view camera
Reply With Quote
  #38  
Old 11-06-2010, 12:28 AM
cablue's Avatar
cablue cablue is offline
Officially Welcomed to the 'Fest
Location: Sierra foothills, California
 
Join Date: Apr 2007
Posts: 206
Mein Auto: '10 X5 diesel
Wow! I'm sorry to hear all the problems so many of you are having. I've got around 24,000 mi. on mine now coming up on its year anniversary. It has been awesome! No rattles, no problems at all. I do wish I upgraded the stereo. Mine is poor sounding at a loud volume. The nav is iffy. I think it works well within a city, but for long-distance guidance, it has given me some very odd ways of getting to where I want to go, way out-of-the-way routes. This is my 4th BMW, first X5. I'm very happy with my purchase All our BMWs have had good quality.
Reply With Quote
  #39  
Old 11-06-2010, 12:58 AM
z2g z2g is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Oct 2009
Posts: 178
Mein Auto: X5
I have a 2010 which I took possession last December. I currently have about 8k miles on the car. Knock on wood.....I haven't had any problems whatsoever.

As far as the navigation, I don't think it's as bad as what ppl make it out to be. It's definitely not as good as a Garmin because the routing isn't as good. However, I'd say the routing as a good as other factory navigation systems out there and other low to moderate end GPS units which don't utilize the same map and routing software as the Garmins, which I'd say are the best on the market.
Reply With Quote
  #40  
Old 11-06-2010, 05:12 AM
bobamoo's Avatar
bobamoo bobamoo is offline
Officially Welcomed to the 'Fest
Location: Greensboro, NC
 
Join Date: Sep 2010
Posts: 387
Mein Auto: 2011 X5 35i
Quote:
Originally Posted by z2g View Post
I have a 2010 which I took possession last December. I currently have about 8k miles on the car. Knock on wood.....I haven't had any problems whatsoever.

As far as the navigation, I don't think it's as bad as what ppl make it out to be. It's definitely not as good as a Garmin because the routing isn't as good. However, I'd say the routing as a good as other factory navigation systems out there and other low to moderate end GPS units which don't utilize the same map and routing software as the Garmins, which I'd say are the best on the market.
Absolutely. I think my Garmin Nuvi does a better job and is easier to predict, maybe I just need to get used to this system? Had my X5 for 2 weeks now, only issue is strange light streaks in iDrive display. Not visible at night, I'm thinking it's a reflection of some sort, but I can't figure out from where. Anyone else notice this?
Reply With Quote
  #41  
Old 11-06-2010, 07:11 AM
Lunablue Lunablue is offline
Registered User
Location: Ct
 
Join Date: Aug 2010
Posts: 85
Mein Auto: 2011 X5d, 2008 135 conv
If you can plan ahead, I think the best way for programming routes is on your computer with google maps. Then send the route to your car. No streaking here. Have 7500 miles since July with no issues...major or minor.
__________________
2011 X5 35d. Sparkling Bronze/Sand, tech,sport,premium,
OEM towing package
2008 135 convertible. Sparkling Graphite/Pale Lemon, loaded
2009 MINI Clubman S Astro Black/Tan

Reply With Quote
  #42  
Old 11-06-2010, 11:41 AM
z2g z2g is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Oct 2009
Posts: 178
Mein Auto: X5
Quote:
Originally Posted by bobamoo View Post
Absolutely. I think my Garmin Nuvi does a better job and is easier to predict, maybe I just need to get used to this system? Had my X5 for 2 weeks now, only issue is strange light streaks in iDrive display. Not visible at night, I'm thinking it's a reflection of some sort, but I can't figure out from where. Anyone else notice this?
What I do love about the X5 navigation system is the Garmin-like Lane Assist feature. However, it's even better than Garmin's system because, at least in my area, the Lane Assist feature pops up at every turn. With my Garmin 755t unit, it rarely pops up.

Also, I really like the fact that you can zoom in and out on the map at a flick of the wrist. With portable GPS units, you have to reach over and touch the screen.
Reply With Quote
  #43  
Old 11-07-2010, 05:40 AM
bobamoo's Avatar
bobamoo bobamoo is offline
Officially Welcomed to the 'Fest
Location: Greensboro, NC
 
Join Date: Sep 2010
Posts: 387
Mein Auto: 2011 X5 35i
Quote:
Originally Posted by z2g View Post
What I do love about the X5 navigation system is the Garmin-like Lane Assist feature. However, it's even better than Garmin's system because, at least in my area, the Lane Assist feature pops up at every turn. With my Garmin 755t unit, it rarely pops up.

Also, I really like the fact that you can zoom in and out on the map at a flick of the wrist. With portable GPS units, you have to reach over and touch the screen.
I think I need to get out the owners manual again and fiddle with the nav. Dealer set it for a "3D" view, looks like you are seeing down the horizon, but I do not see much more info. Maybe the standard views have this? I'll try it today.
Reply With Quote
  #44  
Old 11-07-2010, 10:47 AM
z2g z2g is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Oct 2009
Posts: 178
Mein Auto: X5
Quote:
Originally Posted by bobamoo View Post
I think I need to get out the owners manual again and fiddle with the nav. Dealer set it for a "3D" view, looks like you are seeing down the horizon, but I do not see much more info. Maybe the standard views have this? I'll try it today.
I think the Lane Assist feature pops up when you select split screen. I also have it on 3D view too.
Reply With Quote
  #45  
Old 11-07-2010, 02:27 PM
bobamoo's Avatar
bobamoo bobamoo is offline
Officially Welcomed to the 'Fest
Location: Greensboro, NC
 
Join Date: Sep 2010
Posts: 387
Mein Auto: 2011 X5 35i
Thanks, that was it. Fiddled around with it today, used split screen and entered a destination. On the small screen to the right are the street names and upcoming turn info, just like on my Nuvi. There is so much I still have to learn with this car, I think there are more settings within iDrive that there are grains of sand on the beach! Now if I can just figure out how to change the nav system's voice......
Reply With Quote
  #46  
Old 11-08-2010, 02:13 AM
Marlbro's Avatar
Marlbro Marlbro is offline
UK (ex-Pat)
Location: Limburg, Belgium
 
Join Date: May 2010
Posts: 336
Mein Auto: 2010 X5 3.0d M pack
Thumbs down

Quote:
Originally Posted by z2g View Post
Also, I really like the fact that you can zoom in and out on the map at a flick of the wrist. With portable GPS units, you have to reach over and touch the screen.
WOW !! so for you 3 grand Nav option on your 60 grand car the zoom mode is it !!!!!!
10 x the price for the flick of the wrist
__________________

2010 X5 30d M Sport pack on 20 inch
In Space Grey, Panoramic roof, auto tailgate,
Privacy Glass, Comfort seats in Black?
Rear view camera
Reply With Quote
  #47  
Old 11-08-2010, 05:20 AM
Penguin Penguin is offline
Officially Welcomed to the 'Fest
Location: Illinois
 
Join Date: Aug 2003
Posts: 1,915
Mein Auto: Z4 and X5 Diesel
Quote:
Originally Posted by Lunablue View Post
If you can plan ahead, I think the best way for programming routes is on your computer with google maps. Then send the route to your car.

Can you send routes from Google to the Nav? On my 2010 X35d the only thing I have figured-out is how to send destination points to the nav, but I haven't been able to send routes.

How do you send routes from Google to the Nav system?
Reply With Quote
  #48  
Old 11-08-2010, 06:27 AM
adgrant adgrant is offline
Officially Welcomed to the 'Fest
Location: New York, NY
 
Join Date: Aug 2003
Posts: 2,155
Mein Auto: 2011 X5 5.0
Quote:
Originally Posted by bobamoo View Post
Absolutely. I think my Garmin Nuvi does a better job and is easier to predict, maybe I just need to get used to this system? Had my X5 for 2 weeks now, only issue is strange light streaks in iDrive display. Not visible at night, I'm thinking it's a reflection of some sort, but I can't figure out from where. Anyone else notice this?
I have a Garmin Nuvi and the current iDrive Nav and think the opposite. I find the BMW unit works a lot better generally (aside from some odd routing suggestions).
Reply With Quote
  #49  
Old 11-08-2010, 07:47 AM
Penguin Penguin is offline
Officially Welcomed to the 'Fest
Location: Illinois
 
Join Date: Aug 2003
Posts: 1,915
Mein Auto: Z4 and X5 Diesel
Quote:
Originally Posted by adgrant View Post
I have a Garmin Nuvi and the current iDrive Nav and think the opposite. I find the BMW unit works a lot better generally (aside from some odd routing suggestions).
Perhaps BMW has improved things over the 2010 version, but the database in mine is vastly inferior to the Garmin database. I would say that 10-15% of the time the BMW Nav gets the city wrong with addresses when I am on a trip. Several times on a trip it has told me to turn onto a cowtrail off a main highway while traveling in Utah and Idaho.

The database does not have any of the Wisconsin state parks in it, but it has the city parks.

Etc.
Reply With Quote
  #50  
Old 11-08-2010, 07:56 AM
mucityx5 mucityx5 is offline
Registered User
Location: nashville
 
Join Date: Oct 2010
Posts: 18
Mein Auto: 2011 X5 35D
Quote:
Originally Posted by Penguin View Post
Can you send routes from Google to the Nav? On my 2010 X35d the only thing I have figured-out is how to send destination points to the nav, but I haven't been able to send routes.

How do you send routes from Google to the Nav system?
You cannot send routes, only the destination address. The message is picked up under 'messages' under 'office' and you set this as your destination, the nav does the rest.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms