Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-27-2010, 01:46 AM
sender sender is offline
Registered User
Location: Jersey CI
 
Join Date: Oct 2010
Posts: 21
Mein Auto: 05 E46, 05 E53
E53 Heater fan issue - really annoying!

hi all this is my first post on here, i currently own a 05 E46 and an 05 E53.

now our E43 is a bit of a problem child had it for two years now and have had five faults with it already.
but its lastest problem is getting annoying and with winter creaping in fast getting worse by the day.

suddenly the fans for the heaters stopped working we get heat out of the vents but it seeps out and is not being propelled by the fans.

you can hear the motor for the fans trying to function but the fans dont do bugger all, this includes the windscreen de-fogger which means we have to drive with a window slightly open to keep the windscreen from fogging.

i have checked all the fuses not faults there, and cleaned the pollen filter and still not fans

anyone know what could be the problem?

thanks
Reply With Quote
Advertisement
  #2  
Old 10-28-2010, 09:39 AM
x5ian x5ian is offline
Officially Welcomed to the 'Fest
Location: Atlanta, GA
 
Join Date: May 2010
Posts: 102
Mein Auto: 2001 X5 4.4i, 2009 335iCV
Fan regulator / capacitor could be bad. It was replaced on my old 2001 X5 at 110K. Not too expensive if that is the issue.
__________________
2011 X5 XDrive 5.0, Space Gray/Oyster, Sport Pkg. w/20" Premium Pkg, ColdW Pkg, RearC Pkg, Tech Pkg. HUD, Running Board, 3rd Row Seat.
2009 335i Convertable, Black/Saddle, Sport Pkg, Premium Pkg, Conv. Pkg, NAV, Ipod Adapter, Comfort Access
--Retired: 2006 750i White/Tan
--Retired: 2001 X5 4.4 Sport Black/Tan
Reply With Quote
  #3  
Old 10-29-2010, 06:41 AM
sender sender is offline
Registered User
Location: Jersey CI
 
Join Date: Oct 2010
Posts: 21
Mein Auto: 05 E46, 05 E53
our X5 hasnt even broken 30K yet

we've purchased a final stage resistor for it yesterday gona replace it at the weekend, apparant comman fault with the X5.

hopefully this sorts the problem not 100% but might aswell start from there and work from it

Last edited by sender; 11-03-2010 at 01:20 AM.
Reply With Quote
  #4  
Old 11-03-2010, 01:24 AM
sender sender is offline
Registered User
Location: Jersey CI
 
Join Date: Oct 2010
Posts: 21
Mein Auto: 05 E46, 05 E53
well i thought i'd up date the thread.

i changed the FSR on saturday while the OH was at work cause he would only get in my way if he tried to help.

getting to the unit is abit of a pest in the UK X5, was hindered by the brake pedal alittle LOL

once the new FSR was installed, turned the car on and checked the fans and everything worked fine
Reply With Quote
  #5  
Old 11-03-2010, 01:32 PM
admranger admranger is offline
Registered Troublemaker
Location: Las Vegas
 
Join Date: Dec 2005
Posts: 169
Mein Auto: 2002 M3
Quote:
Originally Posted by sender View Post
well i thought i'd up date the thread.

i changed the FSR on saturday while the OH was at work cause he would only get in my way if he tried to help.

getting to the unit is abit of a pest in the UK X5, was hindered by the brake pedal alittle LOL

once the new FSR was installed, turned the car on and checked the fans and everything worked fine
Nice work! Glad you were able to solve the problem. Thanks for following up.
__________________
Kirk
Las Vegas

2005 E53 X5 4.4i, Imola Red over black, Sport, Premium, Cold, Hybrid Audio Technology Imagine 6.5's

2011 E90 M3, Melbourne Red Metallic, Fox Red/Black, 6-speed, Premium 2, Heated seats, iPod/USB, Technic harness, JL 6/600
Reply With Quote
  #6  
Old 11-04-2010, 12:54 AM
sender sender is offline
Registered User
Location: Jersey CI
 
Join Date: Oct 2010
Posts: 21
Mein Auto: 05 E46, 05 E53
Quote:
Originally Posted by admranger View Post
Nice work! Glad you were able to solve the problem. Thanks for following up.
sorting the heaters out has been a gods send recently getting cold quickly over here LOL
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms