Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-09-2010, 09:26 AM
stigst3r's Avatar
stigst3r stigst3r is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jun 2009
Posts: 745
Mein Auto: e39
2001 e53, 3.0 climate control does not function

Hi Fellas,

i been trying to figure out why this X5 that im with the climate control does not work.

before it failed it seemed like the blower motor would turn on by it self from time to time. i have replaced the final stage resistor thinking that might fix it. but still no heat in the car =\

any suggestions how to fix this?
__________________

RIP: 1998 540i sport 6spd | daily: 1999 528 m-sport 5spd
Reply With Quote
Ads by Google
  #2  
Old 11-09-2010, 01:45 PM
Jetblackstreak Jetblackstreak is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: Jul 2005
Posts: 120
Mein Auto: 2001 X5, 1996 328is
when you say no heat you mean no air flow at all? Are there any other symptoms/issues with the vehicle?
Reply With Quote
  #3  
Old 11-10-2010, 10:30 AM
stigst3r's Avatar
stigst3r stigst3r is offline
Officially Welcomed to the 'Fest
Location: NYC
 
Join Date: Jun 2009
Posts: 745
Mein Auto: e39
yes, no heat, no ac, the blower that should blow air into the cabin does not work at all. the car also has a oil leak somewhere i been trying to trouble shoot that as well, on top of that before there use to be an after market alarm and sound system on that car that looked like it was wired up by kids, there was a good amount of exposed wires danging around behind the panels and im sure some of the wires might have been shorting out. also the battery cracked/exploded with acid in the trunk taking out the head unit radio module.


any suggestions how to get this to work again ?
__________________

RIP: 1998 540i sport 6spd | daily: 1999 528 m-sport 5spd
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms