Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-20-2014, 08:59 AM
troublemaker troublemaker is offline
Registered User
Location: Azerbaijan
 
Join Date: Feb 2014
Posts: 17
Send a message via Skype™ to troublemaker
Mein Auto: BMW E46 325
Unhappy E39 3.5l 2000 -Mass Flow Meter Sensor problem

Hi everyone !!!

i have a problem with my BMW E39 3.5L 2000 make.

It was chip tuning recently and power up.
After a while (like 25 days since purchase) i started to have a problem with Mass Flow Meter Sensor,i replaced one and it lasted 25 days, next one 15 days, and i've chaged 4 of em . maximum wor duration is 15-25 days then it dies. Now i'm about to go and purchase 5th one. Problem mainly occurs when i step on the pedal to the flor (kick down). Anybody has any ideas what is causing its malfunctioning? and what actions are prefferably to make?
Reply With Quote
Ads by Google
  #2  
Old 02-20-2014, 09:12 AM
edjack edjack is online now
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 8,846
Mein Auto: '97 540i 6 speed
Any stored codes? Some aftermarket MAF sensors have proven to be of poor quality.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #3  
Old 02-20-2014, 09:21 AM
troublemaker troublemaker is offline
Registered User
Location: Azerbaijan
 
Join Date: Feb 2014
Posts: 17
Send a message via Skype™ to troublemaker
Mein Auto: BMW E46 325
Quote:
Originally Posted by edjack View Post
Any stored codes? Some aftermarket MAF sensors have proven to be of poor quality.
not at all,after replacement all was erased. i tried duplicates, original staff, doesn't work. same situation.
Reply With Quote
  #4  
Old 02-20-2014, 09:35 AM
edjack edjack is online now
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 8,846
Mein Auto: '97 540i 6 speed
It was chip tuning recently and power up.

Have you considered that this might be the problem?
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #5  
Old 02-20-2014, 09:39 AM
troublemaker troublemaker is offline
Registered User
Location: Azerbaijan
 
Join Date: Feb 2014
Posts: 17
Send a message via Skype™ to troublemaker
Mein Auto: BMW E46 325
Quote:
Originally Posted by edjack View Post
It was chip tuning recently and power up.

Have you considered that this might be the problem?
just guessing, suspecting, im not the only one who made chip tuning, never heared such problems, but also i know that chip tuning vehicle is problematic than the one without.
Reply With Quote
  #6  
Old 02-20-2014, 09:57 AM
troublemaker troublemaker is offline
Registered User
Location: Azerbaijan
 
Join Date: Feb 2014
Posts: 17
Send a message via Skype™ to troublemaker
Mein Auto: BMW E46 325
ANY Ideas PPL?
Reply With Quote
  #7  
Old 02-20-2014, 01:32 PM
Flightmedic Flightmedic is offline
Officially Welcomed to the 'Fest
Location: Mohave Desert
 
Join Date: Nov 2012
Posts: 219
Mein Auto: 525i
Question: What is telling you the MAF is bad?
The computer wiring of sensors nearly always provide a constant voltage to one terminal, and it is up to the sensor to modulate this into a usable signal. I can't imagine that a) this voltage is altered with changes in the computer mapping.
b) that you have encountered 5+ "bad" MAFs.
Chances are, something related is showing as a bad MAF. That is almost always a crack in a rubber boot or hose allowing unmetered air to enter the system around the MAF. Self diagnostics assume that no leaks exist.
So, disassemble the tract between airbox and manifold and physically inspect all components for cracks or other deterioration before buying more sensors. Look also at Crankcase Ventilation system for cracked hoses, along with the smallest hidden vac hoses.


Sent from BimmerApp mobile app
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms