Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 11-28-2010, 09:49 AM
king_julien king_julien is offline
Registered User
Location: London, UK
 
Join Date: Nov 2010
Posts: 1
Mein Auto: BMW E60 2005
BMW 2005 525d misfiring on idle with check engine light!!! help please....

Hi guys, I need some advise and hope somebody here can help me.

I have a BMW 2005 525d, whilst driving back home one day, I realized the car started to judder slightly and when I was parking up my car, the 'Engine Light' came ON.

And now, everytime I start the car up, it started to judder after 1 minutes starting the engine with 'check engine' light on. I have so far;

- replaced the 02 sensor,
- taken/cleaned the inlet manifold,
- cleaned the EGR,
- cleaned the MAF,
- replaced air filter,
- replaced glow plugs,
- replaced the oil separator diaphragm,
- checked the swirl flap and there are OK.
- disconnected the injector plugs, one at a time, while the engine was running to determined whether the injector are faulty but there all indicates as being OK.
- disconnected the MAF connector and it didn't make any difference, condition remains the same.
- checked for vacuum leaks and it was OK too.

I have connected it to my MaxiDiag EU702 diagnostic tool and scan the vehicle. It came out:

- 4212
- 3FF0
- 41BA
- 480A
- 481A

Can somebody please de-code the fault codes for me since my tool doesn't tell me everything, and advise me where else for me to look. Very frustrated and the old wallet is starting to get thinner every day.
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms