Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 01-03-2011, 07:37 PM
Bigmax Bigmax is offline
Registered User
Location: Portage, MI
 
Join Date: Jan 2011
Posts: 26
Mein Auto: '95 740i
'95 740i - Instrument Panel Issues (not pixels)

I have a '95 740i that every once in a while all the needles will go crazy (ie speedo may jump to 120, tach may jump to 5K, then the needles all fall to zero, etc.). Then all of the sudden they will return to normal and function correctly.

When the gauges are going crazy, the BC button on the MID is not functional but when the gauges return to normal then the BC button functions normal as well.

Any ideas? Don't want to send the dash in to be rebuilt if that's not the problem.

Thanks for any help!

Chad
Reply With Quote
Advertisement
  #2  
Old 01-03-2011, 07:46 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 766
Mein Auto: 97 740iL
I don't think it is the cluster that is the problem. If it was, the BC button (which I think stands for "On-Board Computer") should still work.

The first thing I would do is check the charging system (battery, alternator) to make sure that it is putting out enough voltage. If the ECU doesn't get a steady 12 volts, crazy electrical issues can pop up.
Reply With Quote
  #3  
Old 01-04-2011, 05:29 AM
Bigmax Bigmax is offline
Registered User
Location: Portage, MI
 
Join Date: Jan 2011
Posts: 26
Mein Auto: '95 740i
I'll check that and see what I come up with. Would the lower voltage also cause the clock to lose time occassionally? I've noticed that the clock loses time but it seems to be sporadic and I'm wondering if it loses time constantly or only when the gauges wig out.
Reply With Quote
  #4  
Old 01-04-2011, 02:07 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 766
Mein Auto: 97 740iL
I would think that it could cause issues with any electrical system that the ECU controls. So far, I've heard of transmissions shifting problematically, headlights and tail-lights cutting on and off, interior lights dimming, random switches not working, and the motor running too rich or too lean, all from bad charging systems causing low voltage at the ECU. I had a Cadillac Fleetwood Brougham that had a bad connection on the alternator causing the headers to glow red hot because the motor was dumping raw gas into the combustion chamber while the electrical systems were going crazy.

This may not be the problem with your car, but it would be the first thing I would check for.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 07:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms