Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-05-2011, 11:48 AM
michaelyorke michaelyorke is offline
Registered User
Location: maidstone
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw x5
Help x5 2005 power loss every day ?

hi i have a x5 3.0d year 2005 42000 miels it has had its first interim service and since then we have had a progresive problem which has got worse and that is , the car will start fine every mornig but will be absoulte flat on power you can floor it and it just does not pick up 2 miels later its fine ? may i add no faults on the dash
it has been into h/c bmw and had the codes read they said it was coming up on low boost presssure they had the car 2 days and said they had changed the turo seal and unblocked the pipes ect ,
picked up the car all was fine until the next morning done the exact same fault they now say it could be air mass meter or turbo ?? when will this end
now im not silly sureley a turbo will work or not work ??
any help would be appreciated
regards andy
Reply With Quote
Ads by Google
  #2  
Old 02-08-2011, 12:39 PM
michaelyorke michaelyorke is offline
Registered User
Location: maidstone
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw x5
hi gave the car a decent run over the weekend and was fine , has started fine the last three mornings
had the codes read again today to check and its now saying air mass , boost pressure and edg ~???
dealer thinks the car is getting to much boost pressure for what is req ?
any suggestions would be greatful,as they are now saying it could be turbo @1300.00

l going to try it for a week see what happens
Reply With Quote
  #3  
Old 02-09-2011, 02:52 AM
Speedo6 Speedo6 is offline
Registered User
Location: New Zealand
 
Join Date: Jul 2010
Posts: 60
Mein Auto: X3 2007 3.0d
I would take your X5 to a turbo specialist. It could be the turbo boost pressure needs adjustment. The mechanical linkage arm on the turbo can stretch and this causes the waste gate to become floppy and open at very low pressure causing a loss in power.
Reply With Quote
  #4  
Old 02-09-2011, 12:12 PM
michaelyorke michaelyorke is offline
Registered User
Location: maidstone
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw x5
thanks for the reply when i say loss of power i mean the car goes in to lymp mode and has not done this for 6 days now? could it be air mass meter or edg ?
the dealer said it comes up boost pressure ie it is producing more boost than req hence throwing a fault ie car req 1000 and boost 1100
could this be down to the air mass meter

any help would be appreciated
Reply With Quote
  #5  
Old 02-15-2011, 12:26 PM
michaelyorke michaelyorke is offline
Registered User
Location: maidstone
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw x5
up again
car has still not gone into lmp mode since its long run now 11 days i did have a tinca under the bonnet didnt realy now what i was looking at but found the air mass meter as one said it could be this that was causing the problem , i telephoned the dealer today to let him now car was fine he said it may have just been choked up ? as it does only get used on short runs ,
anyone else had these sort of problems x5 3.0 d sport 2005
regards mick
Reply With Quote
  #6  
Old 02-19-2011, 10:19 AM
michaelyorke michaelyorke is offline
Registered User
Location: maidstone
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw x5
HELP
car has been fine for two weeks but thismorning it went into lymp mode on first start then for about a mile then all ok can anyone help
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms