Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 06-05-2010, 12:59 PM
Shadowwind Shadowwind is offline
Registered User
Location: California
 
Join Date: Jun 2010
Posts: 1
Mein Auto: X5
Central locking system and Hazard warning flashers problems

Suddenly have these problems in my 2003 X5:

1. Central locking system doesn't work (cannot lock and unlock any door). It essentially shows no response when I push the button. cannot lock and unlock.
2. The Hazard warning flasher also doesn't show any response when I push the button.

But the remote control can lock and unlock all doors as usual.

What's problem? Please advise.
Reply With Quote
Advertisement
  #2  
Old 06-10-2010, 01:05 AM
Imola 4.6's Avatar
Imola 4.6 Imola 4.6 is offline
Imola 4.6
Location: Glendale, CA
 
Join Date: Nov 2009
Posts: 340
Mein Auto: e34 530i
well i had that problem too on my 2003 4.6 but my key couldnt lock or unlock with the buttons too. along with your problem... i took it to the dealer along with other bigger mechanical problems, they said they fixed that locking problem for free because it was something very small along with other electrics..

check the fuse. if not then it still shouldnt be a big problem, even thought some mechanics say that they need hours of diagnostics... hope this helps thats all i got.
Reply With Quote
  #3  
Old 10-13-2010, 02:09 AM
scottjoh scottjoh is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: May 2006
Posts: 375
Mein Auto: 1999 323i
Shadowwind, your problem is most likely the back of the central locking/hazard button has broken off. Once you pull it out you'll see what I mean. A new switch will run about $50 at getbmwparts.com or about $70 from your local dealer. Some people have glued the back of the switch back on with some success.
Reply With Quote
  #4  
Old 10-13-2010, 08:26 AM
Scott ZHP's Avatar
Scott ZHP Scott ZHP is offline
We want the Lion!
Location: PA, USA
 
Join Date: Jul 2003
Posts: 7,623
Mein Auto: 03 ZHP, 01 X5, 73 MGB
+1 on the broken tabs. Common issue with the switch.

Just epoxy it back together with some JB Weld and it'll be fine.
__________________


Quote:
Originally Posted by Fast Bob View Post
JUST...LOOK...UNDER...THE...CAR....for Chrissakes....it`s like checking to see if a dog is male or female....
Quote:
Originally Posted by smolck View Post
A bimmer with forced induction should have a proper manual gearbox. Anything less is like french kissing your sister.
Reply With Quote
  #5  
Old 02-20-2011, 04:28 PM
dtgvr01 dtgvr01 is offline
Registered User
Location: Michigan
 
Join Date: Feb 2011
Posts: 1
Mein Auto: US
How does one take this assembly out? Is there a clip holding it somewhere - I can't really tell from the pictures of the part (OES-P3030-174949). I have the same problem: it feels like the lock button has no spring to hold the button up.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms