Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 02-22-2011, 01:34 PM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
95 740i - Stalling problem

I having problems woth my 95' bmw 740i. The car starts but a few minutes into driving it stalls. Car starts back up immediatly but then stalls again. Can someone please help!! I had a mechanic look at the car and he said it could be the Idle Air Control Valve. Is it possible or could it be something else?
Reply With Quote
Ads by Google
  #2  
Old 02-22-2011, 08:41 PM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Check engine on? if yes, pull out the codes. check the net for pedal stomp test. Actually , in the past I post on one of the threads the procedure. I don't remember which one.
Pull out the codes and go from there.
Reply With Quote
  #3  
Old 02-23-2011, 06:18 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
the check engine light isn't on.
Reply With Quote
  #4  
Old 02-23-2011, 06:22 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
you might have ac ode pending. Anyway , I would say is worth to check it.here is the procedure and the codes.
Attached Files
File Type: pdf bmw code defaut.pdf (305.0 KB, 150 views)

Last edited by joyism5; 02-23-2011 at 06:23 AM.
Reply With Quote
  #5  
Old 02-23-2011, 06:30 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
if you don't have check engine ON could be related to fuel delivery. Bad fuel pressure regulator,Clogged fuel filter, Clogged fuel pump or not enough voltage on your fuel pump makes it weak.

Have you ever changed the fuel filter? it only costs $20

Last edited by joyism5; 02-23-2011 at 06:32 AM. Reason: spelling check
Reply With Quote
  #6  
Old 02-23-2011, 06:36 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
yeah I've changed the fuel filter and fuel pump. A mechanic I had look at it said it could be the Idle Air Control Valve, he said it gets stuck. And that could be why it's stalling. I didnt have any problems with the car until after I had the oil changed.
Reply With Quote
  #7  
Old 02-23-2011, 06:44 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Yeah there is a great possibility to be the ICV. To diagnose that there is a separate test. Is your car running ok if you accelerate ? and when it comes to idling it just stalls?
Reply With Quote
  #8  
Old 02-23-2011, 07:20 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
yes stalls at idle
Reply With Quote
  #9  
Old 02-23-2011, 07:25 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
i just went out and started it it took five tries to start it once it stared itran for too min and shut down
Reply With Quote
  #10  
Old 02-23-2011, 07:43 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
That makes me believe that your problem is due to a bad throtle valve switch. #12 in the picture. If you have a bad ICV (idle control valve) # 23 in the pic. engine should start imediatley if you push the gas. This are just thought dough...

You could take the icv down and soak it in brake cleaner for a couple good hour. It could be only clogged.

http://www.realoem.com/bmw/showparts...37&hg=13&fg=15

If you want to test them yourself there is a procedure to follow with an ohmmeter. Check the pdf. (is for another engine but test should be similar).
Reply With Quote
  #11  
Old 02-23-2011, 09:11 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
is ther a relly fuse that need to b changed
Reply With Quote
  #12  
Old 02-23-2011, 09:18 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
cant figure ot the poblem
Reply With Quote
  #13  
Old 02-23-2011, 09:27 AM
mujjuman mujjuman is offline
tappa tappa toit
Location: NY
 
Join Date: Feb 2009
Posts: 4,687
Mein Auto: hoopty
Camshaft position sensor
Get the car scanned or we won't know for sure.
__________________
mujjuman
Reply With Quote
  #14  
Old 02-23-2011, 10:18 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
i just drove the car it trove fine for 5 min then started to bog down did not ut off untel
i stoped at a light didnt start up untel 5 tries
Reply With Quote
  #15  
Old 02-23-2011, 12:05 PM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
does anyone know where i can find a bmw mechanic in the barstow,ca area?
Reply With Quote
  #16  
Old 02-23-2011, 12:15 PM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
i don't mean to be a bother, but i really really like this car. my wife wants me to get rid of it, but I love it I can't. when starting the car in the morning it takes five tries before it will start. drives for about 5 mins and starts to jerk like t wants to cut off, but it doesnt cut off unless i stop at a light. I'll turn the key 2 times and it will start again. Even when sitting at idle it will jerk and cut off.It has no check engine light, no error codes or no leaks. I just wana know what the problem before I invest even more money on parts and then come to find out the ICV wasn't the problem. Or if anyone knows how to change the ICV and tell me how, I can do it myself. All response are greatly appreciated.
Reply With Quote
  #17  
Old 02-28-2011, 10:39 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
ok. i checked the fuel pump by disconnecting the hose that goes to the fuel pump motor and turn the key to see if any gas was comming out of the fuel pump hose. no gas was comming out. could it be that the fuel pump is bad.
Reply With Quote
  #18  
Old 02-28-2011, 01:47 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
Was the fuel pump cutting on when you were turning on the key? If it was not making any noise at all, then either your fuel pump or fuel pump relay need to be replaced. It is more than likely your fuel pump though, and you should replace the filter when replacing the pump.
Reply With Quote
  #19  
Old 03-01-2011, 07:06 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
i took the fule pump out and hucked it up to the batery and it came on i cheked the relays and thay all work so i put the old fule pumpback in an it did not pump
Reply With Quote
  #20  
Old 03-02-2011, 08:59 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Do you get 12 V at the pump connection?
If you have the 12 V supplying the fuel pump, it could be a clogged fuel filter (you stated that was changed but check if it was installed correctly-watch for those arrows in and out)
or a bad/clogged fuel pressure regulator.

You can disconnect the fuel rail behind the engine on the passenger side to the firewall using a screwdriver, put the hose in a bottle and turn the key. Watch for fuel coming out when you turn on ignition and when you actually turn the key. You might have fuel coming out with the ignition on but not when you turn the key.
Reply With Quote
  #21  
Old 03-02-2011, 09:26 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
i checked all f that and i checkto se it was getting a spark fro the sparkplug and no spark so now in canging the cank shaft sensors do you thin thats the problem
Reply With Quote
  #22  
Old 03-02-2011, 09:28 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
fule pump is in right pump not geting power
Reply With Quote
  #23  
Old 03-02-2011, 09:31 AM
alexdykes68 alexdykes68 is offline
Registered User
Location: barstow,ca
 
Join Date: Feb 2011
Posts: 27
Mein Auto: 1995 bmw 740i
fuel filter is i right
Reply With Quote
  #24  
Old 03-02-2011, 12:20 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 758
Mein Auto: 97 740iL
So there is no power going to the fuel pump now, and there is no spark at the plugs, but the car runs for five minutes at a time? Do I have this right?
Reply With Quote
  #25  
Old 03-02-2011, 12:32 PM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
@ Balance : I am lost too.

fuel pump = NO power?

Spark plug = NO spark?

Fuel filter is right.

You are changing crankshaft sensor?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 07:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms