Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 02-26-2011, 06:39 PM
84bmw533i 84bmw533i is offline
Registered User
Location: sylmar
 
Join Date: Feb 2011
Posts: 14
Mein Auto: 1984 533i
84 533i CL special now i need help asap!please..

So i got a CL special on a 84 533i for $500 im the 3rd owner it had clean title pink slips registered till september 2011 nice body interior could use some work.. So the guy i got it from stated that all it needs is either an alternator or battery so i tested battery it doesnt hold charge so i have to test alternator now..But i was able to drive it home fine it worked great however the brakes were super stiff then the following day i was driving and all of a sudden it wont go past 20mph like its stuck in first so i tried to pull over asap but before i did smoke came out of tranny its automatic but when i shift manually its ok then when i finally parked there was no brake pressure at all looked under car to notice transmission fluid leaking please any advice would be appreciated thanks
Reply With Quote
Ads by Google
  #2  
Old 02-26-2011, 10:10 PM
catso's Avatar
catso catso is offline
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,925
Mein Auto: 2000 323i, 1988 528e
Quote:
Originally Posted by 84bmw533i View Post
So i got a CL special on a 84 533i for $500 im the 3rd owner it had clean title pink slips registered till september 2011 nice body interior could use some work.. So the guy i got it from stated that all it needs is either an alternator or battery so i tested battery it doesnt hold charge so i have to test alternator now..But i was able to drive it home fine it worked great however the brakes were super stiff then the following day i was driving and all of a sudden it wont go past 20mph like its stuck in first so i tried to pull over asap but before i did smoke came out of tranny its automatic but when i shift manually its ok then when i finally parked there was no brake pressure at all looked under car to notice transmission fluid leaking please any advice would be appreciated thanks
Is it leaking from the trans? Check the level with the dipstick. Your model has the power steering and brake booster sharing the same fluid reservoir which, by the way, is Dexron ATF. You need to get a repair manual or at least an owner's manual so you can identify what fluids to check and where. If there's smoke coming out of the trans, that's not good.
Reply With Quote
  #3  
Old 02-27-2011, 10:34 AM
84bmw533i 84bmw533i is offline
Registered User
Location: sylmar
 
Join Date: Feb 2011
Posts: 14
Mein Auto: 1984 533i
thanks does this mean i must bleed the brakes?
Reply With Quote
  #4  
Old 02-27-2011, 11:11 AM
catso's Avatar
catso catso is offline
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,925
Mein Auto: 2000 323i, 1988 528e
Quote:
Originally Posted by 84bmw533i View Post
thanks does this mean i must bleed the brakes?
I don't think the brake hydaulics are your problem. The brake booster receives pressure from the power steering pump to lessen braking effort. you need to check ALL the fluid levels first; engine oil, transmission fluid, power steering fluid, brake fluid, engine coolant, etc. to begin to figure out what the problem is. Also check the condition of the belts and confirm there's the proper amount of tension on them particularly the alternator belt. Look over the batter connections. You mave want to remove them and clean them very carefully. If you have a voltmeter check the voltage at the battery before you start the car and after it's running. You can get a cheap battery at an Interstate Battery Factory outlet store. I bought one for $23.

Last edited by catso; 02-27-2011 at 11:12 AM.
Reply With Quote
  #5  
Old 02-27-2011, 05:38 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 715
Mein Auto: 535i 1989
If you had no brake pressure i would guess that either one of your hydrolic lines let go, your brake bomb just died, or your brake master died. I can help you with the brake bomb or the master for 50 each. If it is one of your lines you can get those at a stealership or you can get them remade at a go shop.

Andy
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms