Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-05-2011, 11:09 AM
auerman auerman is offline
Registered User
Location: Alabama
 
Join Date: Feb 2011
Posts: 3
Mein Auto: Z3
Injector Problems

I have a 2002 Z3 roadster 3.0L Picked it on Friday the following Friday I started getting a check engine code. Bank 2 lean. I inspected the engine compartment and found a vacuum leak in the mass air flow boot. Taped it up and ordered a replacement. The next day it started skipping. Found #4 cylinder injector does not appear to be working. No ticking with a screw driver test. Any suggestions on where to go with this. When I pulled the codes there were about 5 sensors that did not report. Thinking maybe a DME module.
Reply With Quote
Ads by Google
  #2  
Old 03-05-2011, 05:14 PM
SUNZOUT SUNZOUT is offline
Officially Welcomed to the 'Fest
Location: Bataiva, IL
 
Join Date: Jan 2007
Posts: 1,575
Mein Auto: '00 M Roadster
When you get into the multiple code issues you really need to take it to a good independent BMW shop.

A lot of these codes related to lean or misfire can be related to one or two problems.

If you have a crack in the intake boot, get that fixed first, clean the MAF. try swapping injectors if you feel there is an issue but all in all you maybe better getting it looked at with better computer than just a code reader.
__________________

TC Kline S/A Coilovers | Sharked | Turner Slotted Rotors | Axxis Ultimate Pads | SS Front Strut | IE Subframe Bushings | IE Rear Toe/Camber Kit
Whalen Shift Machine | Stygar Clutch Pedal | CDV Delete | LeatherZ Armrest | Whalen seat bushings | Z3Solutions Windblocker | Shift Pin fix
Reply With Quote
  #3  
Old 03-08-2011, 01:36 PM
auerman auerman is offline
Registered User
Location: Alabama
 
Join Date: Feb 2011
Posts: 3
Mein Auto: Z3
Installed the boot, swapped the injector with the cylinder next to it and the problem stayed. Although I noticed the injector did fire until the misfire code reappeared. Then the injector stopped firing. Swapped the coil with the cylinder next to it and the problem moved. Going to pick up a new coil. This should fix it. will let you know
Reply With Quote
  #4  
Old 03-08-2011, 03:44 PM
auerman auerman is offline
Registered User
Location: Alabama
 
Join Date: Feb 2011
Posts: 3
Mein Auto: Z3
New coil pack did the trick....puring like a kitten
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms