Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 04-02-2011, 03:03 PM
LEOT LEOT is offline
Registered User
Location: Pa
 
Join Date: Mar 2007
Posts: 13
Mein Auto: x-3
Passenger side mirror

My passenger side mirrror stopped working, won't tilt on reverse, can't adjust with switch, and doesn't defrost. I checked fuses and didn't find anything. Any ideas. 2007 X-3
thanks
Reply With Quote
Ads by Google
  #2  
Old 04-02-2011, 05:36 PM
vern vern is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Apr 2002
Posts: 4,718
Send a message via AIM to vern
Mein Auto: 01 330ci 05 530i 06 X3
Quote:
Originally Posted by LEOT View Post
My passenger side mirrror stopped working, won't tilt on reverse, can't adjust with switch, and doesn't defrost. I checked fuses and didn't find anything. Any ideas. 2007 X-3
thanks
Try moving it around by hand and then try to adjust it. Good luck
cheers
vern
__________________
2012 335iA Blk. Sapphire- Sport-Blk. Dakota Leather/Red-Brushed Alum.Trim-DAP-PP-CWP Rear View Camera-BMW Asst w/Enhanced BT&USB-High Gloss Blk.Trim Hghight-PSP-Speed Limit Info-Tech. Pkg-PDC-Rear Manual Sun Shades-SAT-Variable Sport Steering-Wheel Locks- Rubber Mats-Euro Del 5/14/12-Redelivery 7/16/12 2006 X3 3.0iA 4/6 Silver Gray Metallic-Black Leather-Nav-PP-SP-Xenon Headlights-PDC-Heated Front Seats-Privacy Glass-Servotronic Steering-Premium Sound System-R R R- Wheel Locks- Rubber Mats
Reply With Quote
  #3  
Old 04-03-2011, 08:08 AM
UncleJ UncleJ is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: May 2006
Posts: 6,512
Mein Auto: '06 X3
Mine works like it has a mind of its own. One day it works fine, the next, nada. Sometimes moving the L-R switch back and forth triggers a response, but somethimes nothing. I don't like it enough to do anything about it. If I need the mirror to point down, then I will point it down with the manual directional switch.
Reply With Quote
  #4  
Old 04-03-2011, 11:03 AM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,068
Mein Auto: 2004 X3 2.5i
Quote:
Originally Posted by LEOT View Post
... and doesn't defrost.
How did you confirm it doesn't defrost?

I think they switch on only when the ambient temp. as measured by the sensor is below 45F or something.

If it definitely isn't heating up the glass, then you have something more than a sticky tilt mechanism wrong.
A few people have had to have a new window/mirror switch, which somehow seems to control the heating ribbon as well as the expected mechanical functions.
Reply With Quote
  #5  
Old 11-14-2011, 01:40 PM
LEOT LEOT is offline
Registered User
Location: Pa
 
Join Date: Mar 2007
Posts: 13
Mein Auto: x-3
When it was cold and frosty it didn't defrost like the driver side. Any test I can do to see if its the switch. Also forgot to mention when I use the "fold mirror in" switch, the drivers side mirror folds in but not the passenger side. Seems like all mirror functions dop not work on that side

Last edited by LEOT; 11-14-2011 at 01:51 PM.
Reply With Quote
  #6  
Old 11-14-2011, 05:01 PM
littleengin littleengin is offline
Registered User
Location: Vermont
 
Join Date: Apr 2011
Posts: 59
Mein Auto: 2006 X3 M-Sport
I had this same issue. It was fixed at the dealership. I believe they changed the motor.

Sent from my ADR6300 using Bimmer
Reply With Quote
  #7  
Old 11-16-2011, 07:07 AM
X3 Skier's Avatar
X3 Skier X3 Skier is offline
Powder Days
Location: Ohio and Colorado
 
Join Date: Aug 2005
Posts: 1,947
Mein Auto: 2005 X3 2.5i (ED 2004)
Mine stuck once. I pushed it by hand and it has been fine ever since.

Cheers
__________________
Just Some Consultant

"I never understood the dread term "terminal illness" until I saw Heathrow for myself." Dennis Hopper
Reply With Quote
  #8  
Old 11-16-2011, 06:51 PM
bluskye bluskye is offline
Officially Welcomed to the 'Fest
Location: chicago
 
Join Date: Jul 2002
Posts: 786
Mein Auto: 2006 330i / 2007 X3
BMW mirrors snap into the motor that moves them up/down/right left. There is another electrical connection to the mirror itself that performs the defrost. Essentially, the mirror is coated with a resistor like material that heats up the surface when electricity is applied. You can safely remove the mirror itself by simply pulling it away (toward rear of car) and it will snap out of the motor/actuator. Yeah, its that easy.

If the mirror is just not defrosting ... simply replace mirror. If the motor is busted, it requires taking off the interior door panel to gain access to the bolts that hold the mirror assembly on. Ive done it on my old E46. Not fun, but not impossible.

Sounds like you have another problem if both motor and defrost are not working as they are separate systems.

Last edited by bluskye; 11-16-2011 at 06:57 PM.
Reply With Quote
  #9  
Old 11-21-2011, 08:22 AM
LEOT LEOT is offline
Registered User
Location: Pa
 
Join Date: Mar 2007
Posts: 13
Mein Auto: x-3
Yes..the mirror adjustment doesn't work..just on passenger side, the fold in switch works since it folds the driverside but not passenger side, and of course the defrost doesn't work, only on 1 side. Could be it as simple as a ground wire in the mirror? since all functions do not work..
Reply With Quote
  #10  
Old 12-29-2011, 08:00 AM
LEOT LEOT is offline
Registered User
Location: Pa
 
Join Date: Mar 2007
Posts: 13
Mein Auto: x-3
Just trying to bump this up to see if anyone has found a solution.
Reply With Quote
  #11  
Old 12-29-2011, 08:31 AM
Dominic49's Avatar
Dominic49 Dominic49 is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Sep 2011
Posts: 245
Mein Auto: Bmw
8 months later and you still haven pulled the cover off to expose the wires?
Reply With Quote
  #12  
Old 12-29-2011, 09:13 AM
LEOT LEOT is offline
Registered User
Location: Pa
 
Join Date: Mar 2007
Posts: 13
Mein Auto: x-3
I did but there is a "ribbon" wire, similar to a computer connection to a hard drive. Not a lot I can do with that. Doesn't seem possible to check voltage etc.
Reply With Quote
  #13  
Old 12-29-2011, 09:15 AM
Dominic49's Avatar
Dominic49 Dominic49 is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Sep 2011
Posts: 245
Mein Auto: Bmw
you need to check it at the mirror connection and at the module. you want to check for continuity not voltage.

furthermore please inform us of everything else you have tried.
Reply With Quote
  #15  
Old 12-29-2011, 09:37 AM
madurodave's Avatar
madurodave madurodave is offline
BMW Enthusiast!
Location: NH
 
Join Date: Oct 2008
Posts: 5,571
Mein Auto: 2007 Z4+X3, 2006 530Xi
Sounds like the mirror motor to me. But since you lost defrost too, who knows.
__________________
Madurodave

My garage: 2007 BMW Z4 3.0si Manual, 2007 BMW X3, 2006 BMW 530xi

Retired: 1998 BMW Z3

Member of BMWCCA!
Reply With Quote
  #16  
Old 09-30-2012, 04:32 AM
BMWNL BMWNL is offline
Registered User
Location: Newfoundland
 
Join Date: Sep 2012
Posts: 1
Mein Auto: 2006 325XI
Want to remove folding mirror feature

My mirrors fold all the way out automatically every time I get in the car and I have to fold them to the correct position by hand. Drives me nuts. I tried hitting switch, moving them in and out by hand etc but they still keep folding all the way out every time I push key fob to get in the car. Dealer wants $700 for a new mirror car is not in warranty. Seems there should be a limit switch or little mechanical connector to fix without replacing whole mirror but after spending hours on this site I can not find a fix. I am happy to just disconnect a wire to remove fold in and out feature - if anyone can tell me how this will be appreciated - do you know if this will show and error on instrument cluster?
Reply With Quote
  #17  
Old 10-05-2012, 09:02 AM
sjladopoulos sjladopoulos is offline
BMW to the bone
Location: Toronto
 
Join Date: Jan 2012
Posts: 244
Mein Auto: 2007 BMW X3 3.0si
look here:
http://www.bimmerfest.com/forums/sho...d.php?t=624838
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms