Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E21 (1975 - 1983)

E21 (1975 - 1983)

Reply
 
Thread Tools Display Modes
  #1  
Old 01-13-2013, 09:11 AM
kavu kavu is offline
Registered User
Location: Montana
 
Join Date: Jan 2013
Posts: 2
Mein Auto: 1978 320i
Bimmer newcomer

I purchased a 1978 320I and just had it towed to my house. Battery is dead, charged it up, car turns over very slow, I will check and see if I have a bad battery.

I noticed that the clutch slave cylinder is leaking, one more thing to replace. Working outside when it's below 10 degrees sucks.

I will post a picture of my restoration as it goes along.

Last edited by kavu; 01-18-2013 at 12:02 PM.
Reply With Quote
Ads by Google
  #2  
Old 01-21-2013, 09:34 AM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,171
Mein Auto: E23;E30;E38;E32;E34 +
If it is that cold battery is probably dead. Check cables, terminals and connections as well; once it is warm enough! We have 35c here at the moment - read 90f. My batteries are fine......
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #3  
Old 01-22-2013, 08:05 AM
kavu kavu is offline
Registered User
Location: Montana
 
Join Date: Jan 2013
Posts: 2
Mein Auto: 1978 320i
It appears as if I may have a fuel problem, troubleshooting this now if it warms up to 20, still very cold out. I pulled a few fuels lines off and there is no pressure at them, need to take a look at the fuel pump. I noticed that there is no fuel relay in the electrical panel under the hood?
Thanks
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E21 (1975 - 1983)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms