Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)

E46 M3 (2001-2006)

Reply
 
Thread Tools Display Modes
  #1  
Old 06-16-2011, 10:44 PM
RKSS RKSS is offline
Rice Eater
Location: Calgary Alberta Canada
 
Join Date: Jun 2008
Posts: 45
Mein Auto: 2002 BMW M3
Signal lights wont work

So my signal lights and hazards wont work......sometimes...Usually when I first start the car when its been sitting for a while they will work fine, but sometimes ( usually when I restart without it sitting for a hour or two) they wont work. The head lights will blink, and I cant change any headlight settings. When I disconnect the battery for 10 minutes or so the problem goes away ( most of the time ). Anyone have that happen to them? I thank you in advance for any information.
__________________
Reply With Quote
Advertisement
  #2  
Old 06-23-2011, 12:26 AM
anderson20 anderson20 is offline
Banned
Location: Bangladesh
 
Join Date: Jun 2011
Posts: 1
Mein Auto: toyota yaris
The head lights will blink, and I cant change any headlight settings. When I disconnect the battery for 10 minutes or so the problem goes away ( mos
Reply With Quote
  #3  
Old 06-23-2011, 01:47 AM
RKSS RKSS is offline
Rice Eater
Location: Calgary Alberta Canada
 
Join Date: Jun 2008
Posts: 45
Mein Auto: 2002 BMW M3
yes the problem goes away till I turn the car off again. I noticed that it happens most often when its hot out......I hope this can be solved for less money then I spent on tires.
__________________
Reply With Quote
  #4  
Old 08-04-2011, 12:09 AM
RKSS RKSS is offline
Rice Eater
Location: Calgary Alberta Canada
 
Join Date: Jun 2008
Posts: 45
Mein Auto: 2002 BMW M3
Sorry to bring up an old thread, but I still have the same issues. I brought the car to my mechanic and he told me it must be a grounding issue. I bought a new battery and checked all the ground connections I found on the car, still the problem remains. He also told me it could be my Angel eyes causing the problem, so I disconnected them and it still does the same.

I noticed it happens only when the car is hot. When I start it up in the garage in the morning they work fine. Is there a relay for signals in the M3 or is it all controlled by the LCM?

Please help, I have only put 400 km on it this summer because of this.

Thank you
__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms