Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 07-10-2011, 11:08 AM
ssi19 ssi19 is offline
Registered User
Location: nyc
 
Join Date: Jul 2011
Posts: 22
Mein Auto: bmw
DSC error and transmission quirkiness

Hi once in a while recently I have gotten the DSC error on the dash (the "4x4" with the arched arrow above it). Even pressing the dsc on/off button didn't clear it. Then yesterday it came on and then I got a strange written message below the odom. I can't recall the exact wording but it was something about the transmission going into a special protective mode. Shortly after that, it was shifting weird and when I went into reverse the car kind of jumped into gear and the car lurched a little. I rested it overnight and it's 100 pct fine today. No DSC error, no automatic shifting problems. Any idea what's going on here? I am off warranty so I am apprehensive about the cost of taking it to the dealer if not needed, but of course will if this is the indication of something majorly bad. Thanks for any advice! Ps. 2006 X5 4.4i, 41k miles.

Last edited by ssi19; 07-10-2011 at 11:09 AM.
Reply With Quote
Ads by Google
  #2  
Old 07-12-2011, 07:47 AM
marco328 marco328 is offline
Registered User
Location: San Dimas, CA
 
Join Date: Nov 2004
Posts: 53
Mein Auto: 99' 328i (E46)
My wife told me that the same light has come up twice in the last few days on her 2006 X5 3.0. However, it's didn't remain on for more than a few seconds. She hasn't notice any shifting issues. I thought maybe the reservior was a little low. I topped it off last night. I hope (crossing fingers) that's all it was. If it comes on again I'll take it to my mechanic to check it out. I just bought it a little more than a week ago. If you find something out let me know. I'll do the same.
Reply With Quote
  #3  
Old 07-12-2011, 11:05 AM
Mark@EAC Mark@EAC is offline
Past Sponsor
Location: NW Indiana USA
 
Join Date: Nov 2008
Posts: 2,563
Send a message via AIM to Mark@EAC
Mein Auto: e39 5
sounds like it could potentially be a wheel speed sensor issue. Maybe one of the sensor's wiring is damaged and making intermittent contact so the problem comes and goes.
Reply With Quote
  #4  
Old 07-15-2011, 07:59 AM
ssi19 ssi19 is offline
Registered User
Location: nyc
 
Join Date: Jul 2011
Posts: 22
Mein Auto: bmw
Quick update to my original post..... My radio has been going in and out (the sound) since this DSC error happened as well. I think I may have an electrical issue? Anyone know the connection between DSC/transmission and the radio sound? thanks again.....
Reply With Quote
  #5  
Old 07-15-2011, 10:57 PM
marco328 marco328 is offline
Registered User
Location: San Dimas, CA
 
Join Date: Nov 2004
Posts: 53
Mein Auto: 99' 328i (E46)
Had my mechanic do a complete check of the entire car and checked for any DTC codes and nothing. There was one code for a drop in electrical current but he cleared it and nothing. So not more than an hour after leaving my mechanic while driving on the freeway the damn DSC 4x4 light came on again. I hit the DSC button and nothing. Car seem to be running fine though but still a mystery. Good idea to check the wheel speed sensor. I'll take a look at that in the morning.
Reply With Quote
  #6  
Old 07-17-2011, 09:15 AM
ssi19 ssi19 is offline
Registered User
Location: nyc
 
Join Date: Jul 2011
Posts: 22
Mein Auto: bmw
I called BMW and described the situation. They said it sounds like alternator and battery may be failing. $2200 to fix ouch! Kinda odd for a car with 41k mikes. Anyway I'm gonna take it in to BMW this week and pay for an official diagnosis and then decide what to do. Maybe get an aftermarket/independent guy to fix cheaper depending on what they say is wrong.
Reply With Quote
  #7  
Old 07-20-2011, 12:24 PM
ssi19 ssi19 is offline
Registered User
Location: nyc
 
Join Date: Jul 2011
Posts: 22
Mein Auto: bmw
bmw confirmed alternator is bad. said it can happen around 40k miles for sure. getting alternator replaced at a local german garage.
Reply With Quote
  #8  
Old 07-20-2011, 12:56 PM
marco328 marco328 is offline
Registered User
Location: San Dimas, CA
 
Join Date: Nov 2004
Posts: 53
Mein Auto: 99' 328i (E46)
I"ve replaced the alternator on my 328i and the X5 doesn't seem to be too much different. New/refurbished alternator cost me less than $200. Time to replace the alternator about an hour. I've taken it out so many times now because of other repairs I can do it blind folded. It can be a DIY. No way would I pay the dealer $2,000. Good Luck
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms