Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 08-10-2011, 01:09 PM
Jersey C.I X5 Jersey C.I X5 is offline
Registered User
Location: Jersey CI
 
Join Date: Aug 2011
Posts: 2
Mein Auto: United Kingdom
battery drain and Hi from new member from Jersey Channel Islands!

Hello, I wonder if anyone can help with this?......2004 X5 4.4i model, Love the car and have a few BM's over the years, I have a problem with the battery draining over the course of 7-10 when being used?, my mechanic has replaced the battery and checked the alternator and says its fine, I'm guessing there is a 'drain' on the battery from somewhere and its not charging up when driving, it started with the radio going off for a few seconds and culminates in the car going into 'trans safe mode' and limping home with a flat battery? HELP! thanks.
Reply With Quote
Advertisement
  #2  
Old 08-10-2011, 01:19 PM
BimmerNutX5 BimmerNutX5 is offline
Registered User
Location: Michigan
 
Join Date: Aug 2011
Posts: 33
Mein Auto: 2002 X5, 1995 525i
Sounds like your mechanic has misdiagnosed the alternator. If your driving and it is not charging then for some reason the alternator is not charging the battery.
__________________
Cheers

1981 320i (sold)
1986 635csi (sold)
1995 525i (Daughter's car)
2002 X5 3.0i (Wifes Car)
2006 Jeep Grand Cherokee Limited, 5.7L Hemi, Quadradrive II, KYB Suspension, Magnaflow exhaust, Cold Air Intake. This is my current vehicle.
Reply With Quote
  #3  
Old 08-12-2011, 12:53 PM
Milesoffshore Milesoffshore is offline
Registered User
Location: MAryland
 
Join Date: Jun 2011
Posts: 26
Mein Auto: BMW X5
Put a volt meter on your battery while it is running. A working alternator should give you a voltage reading anywhere between 13 and 14.5. I think if it is over 15, there is something wrong w battery. No mechanic here, just passing info told to me.....
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms