Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 08-14-2011, 02:14 PM
stewthebassman's Avatar
stewthebassman stewthebassman is offline
Officially Welcomed to the 'Fest
Location: Hudson, Quebec
 
Join Date: Nov 2004
Posts: 852
Mein Auto: 07 E61 530xiT 2004 E53 X5
POOF!!!!!!!!! Coolant all over the place....

So our 2004 X5 has 180,000kms, and it is off CPO warranty. We decided to save a money and go to a well-known and respected local mechanic who only fixes BMWs. He did some work on fan belts and binders, all the squealing went away, fine.

After we got the truck back however, the AC quit. It didn't peter out, it just quit.
The yesterday, after trailering our horse 60 kms out and back, and after I put the trailer away, the engine went POOF and coolant steam erupted out of the engine bay! Fortunately, I was in the driveway of the barn, waiting for my wife to come out. Me and my daughter hustled out of the truck, and once the steam had died down, I opened the engine bay to have a look. Coolant everywhere.

Fast forward to today, I went to look at the truck. In the engine bay there are two connectors that are UNCONNECTED (see photos). One of them goes to the radiator fan? and the other is maybe a sensor? I don't know.

Fellow 'festers, can you help? I emailed these photos to the mechanic and am curious to see if he takes responsibility. The ends of the connectors are super clean, like they have spent 180,000kms being....well....connected....
Attached Thumbnails
Click image for larger version

Name:	photo 3.jpg
Views:	102
Size:	48.0 KB
ID:	289153   Click image for larger version

Name:	photo 2.jpg
Views:	92
Size:	44.3 KB
ID:	289154   Click image for larger version

Name:	photo 1.jpg
Views:	97
Size:	50.7 KB
ID:	289155  
Reply With Quote
Advertisement
  #2  
Old 08-14-2011, 06:45 PM
stewthebassman's Avatar
stewthebassman stewthebassman is offline
Officially Welcomed to the 'Fest
Location: Hudson, Quebec
 
Join Date: Nov 2004
Posts: 852
Mein Auto: 07 E61 530xiT 2004 E53 X5
I think one of them is the AUC sensor? For the recirculating AC...
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms