Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-18-2011, 06:46 PM
Clarkey Clarkey is offline
Registered User
Location: Florida USA
 
Join Date: Aug 2010
Posts: 21
Mein Auto: Z4
Z4 Amp needed

So after a water in the trunk episode, does anybody have an amp available that is compatible with a 2003 Z4? It is the DSP version and the car is non-navigation. The amp has the small coax connection in addition to the loom connection.

The part number on the fried one is Carver 65126932417 and it is completely ruined before anybody suggests repair - that was my first hope also!

Thanks

Last edited by Clarkey; 08-18-2011 at 07:14 PM.
Reply With Quote
Advertisement
  #2  
Old 08-29-2011, 10:31 AM
Clarkey Clarkey is offline
Registered User
Location: Florida USA
 
Join Date: Aug 2010
Posts: 21
Mein Auto: Z4
Bump

Still looking for a used Z4 amplifier if anyone knows of one at a good price? The one I removed has a p/n of 65126932417, but the following should also be compatible:

65126974231
65126963304
65126936087
65126936952
65126938189
65126946727
65129125751
65129138102
Reply With Quote
  #3  
Old 08-30-2011, 03:09 AM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 423
Mein Auto: BMW Z4 3.0
I saw one for sale on e-bay last week. Good luck.
Reply With Quote
  #4  
Old 08-30-2011, 07:17 AM
s0n1c s0n1c is offline
Registered User
Location: Arlington VA
 
Join Date: Feb 2010
Posts: 43
Mein Auto: 03 Z4 2.5i
I need to look at what I have, but I pulled my amp out when I replaced the entire sound system. If I have one, I'll let you know.
Reply With Quote
  #5  
Old 08-30-2011, 06:56 PM
Clarkey Clarkey is offline
Registered User
Location: Florida USA
 
Join Date: Aug 2010
Posts: 21
Mein Auto: Z4
Thanks s0n1c - send me a PM if you have one, I really appreciate it!

Mikey48 - there are none on ebay right now unfortunately... I found out someone else from Bimmerfest was bidding on the one last week as well, so I stopped because it seemed silly to get into a bidding war with a fellow forum member (and he was looking before I was!)

Thanks again guys, am sure one will come up soon.
Reply With Quote
  #6  
Old 08-30-2011, 07:14 PM
s0n1c s0n1c is offline
Registered User
Location: Arlington VA
 
Join Date: Feb 2010
Posts: 43
Mein Auto: 03 Z4 2.5i
PM sent with my amp part number.
Reply With Quote
  #7  
Old 09-03-2011, 07:31 PM
Clarkey Clarkey is offline
Registered User
Location: Florida USA
 
Join Date: Aug 2010
Posts: 21
Mein Auto: Z4
Thanks s0n1c!!

I purchased s0n1c's amplifier from him and everything worked out great! If anyone on here ever has reason to deal with s0n1c, please do not hesitate, he is an absolute gentleman to deal with.
Reply With Quote
  #8  
Old 09-15-2011, 09:38 AM
love_my_Z4 love_my_Z4 is offline
Registered User
Location: Princeton, NJ
 
Join Date: Sep 2011
Posts: 6
Mein Auto: 2003 Z4
Hello all...I need one too. Same issue with water in the trunk.
Thanks.
Reply With Quote
  #9  
Old 09-15-2011, 10:22 AM
ECSTuning's Avatar
ECSTuning ECSTuning is offline
Instructor of the Stig™
Location: Wadsworth, Ohio
 
Join Date: Feb 2009
Posts: 4,044
Mein Auto: Hover Car on Wheels
We have the New OEM Amplifier available here. They are the updated versions which are compatible with the part number listed in the original post.

If you have any questions feel free to PM or EMail me,
James
__________________

Have questions? Need answers? Live Chat us! 8:30am to 12:00am Midnight EST
sales@ecstuning.com | customerservice@ecstuning.com
Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 | OEM BMW Part Number Search
Do you love surveys? Click HERE to take our Customer Satisfaction Survey!
Reply With Quote
  #10  
Old 09-15-2011, 11:41 AM
love_my_Z4 love_my_Z4 is offline
Registered User
Location: Princeton, NJ
 
Join Date: Sep 2011
Posts: 6
Mein Auto: 2003 Z4
Thanks ECS. Doesn't appear to be a match though. I just removed the amp...the part number is 65126930046...slightly different than the others listed above.
Reply With Quote
  #11  
Old 09-15-2011, 11:56 AM
ECSTuning's Avatar
ECSTuning ECSTuning is offline
Instructor of the Stig™
Location: Wadsworth, Ohio
 
Join Date: Feb 2009
Posts: 4,044
Mein Auto: Hover Car on Wheels
According to my information that part number is superseded to the one I linked.

James
__________________

Have questions? Need answers? Live Chat us! 8:30am to 12:00am Midnight EST
sales@ecstuning.com | customerservice@ecstuning.com
Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 | OEM BMW Part Number Search
Do you love surveys? Click HERE to take our Customer Satisfaction Survey!
Reply With Quote
  #12  
Old 10-03-2011, 04:25 PM
STR8VI STR8VI is offline
Registered User
Location: Birmingham, Al
 
Join Date: Oct 2011
Posts: 7
Send a message via Skype™ to STR8VI
Mein Auto: Z4
Hey! I'm looking for a new amplifier... part #65126938189. Absolutely gutted about my leaky battery compartment.
Reply With Quote
  #13  
Old 10-03-2011, 04:25 PM
STR8VI STR8VI is offline
Registered User
Location: Birmingham, Al
 
Join Date: Oct 2011
Posts: 7
Send a message via Skype™ to STR8VI
Mein Auto: Z4
Thanks all!
Reply With Quote
  #14  
Old 10-04-2011, 07:28 AM
BIMMER_Z4_FAN BIMMER_Z4_FAN is offline
Registered User
Location: Atlanta, GA
 
Join Date: Oct 2011
Posts: 1
Mein Auto: BMW Z4 3.0 2003
I also need an amp for my 2003 Z4 3.0 as the same thing happened to mine..... water in the trunk. p/n 65126930046 It was DSP but I really am not too concerned about the DSP working. Please let me know if you have one available or similar. The search has not been an easy one for sure! thank you!
Reply With Quote
  #15  
Old 10-04-2011, 07:33 AM
ECSTuning's Avatar
ECSTuning ECSTuning is offline
Instructor of the Stig™
Location: Wadsworth, Ohio
 
Join Date: Feb 2009
Posts: 4,044
Mein Auto: Hover Car on Wheels
StR8VI and BIMMER Z4 Fan

The new OEM Amplifiers for your car are available here. They are the updated versions which are compatible with the part number you both posted.

If you have any questions feel free to send me a PM

ECS Tuning
__________________

Have questions? Need answers? Live Chat us! 8:30am to 12:00am Midnight EST
sales@ecstuning.com | customerservice@ecstuning.com
Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 | OEM BMW Part Number Search
Do you love surveys? Click HERE to take our Customer Satisfaction Survey!

Last edited by ECSTuning; 10-04-2011 at 12:08 PM.
Reply With Quote
  #16  
Old 10-04-2011, 12:03 PM
STR8VI STR8VI is offline
Registered User
Location: Birmingham, Al
 
Join Date: Oct 2011
Posts: 7
Send a message via Skype™ to STR8VI
Mein Auto: Z4
It seems this is a very common problem. Has anyone tried or had any luck pursuing BMW to fix this problem without having to foot the $1500 bill?
Reply With Quote
  #17  
Old 10-04-2011, 12:18 PM
chickdr chickdr is offline
Officially Welcomed to the 'Fest
Location: Atlanta, GA
 
Join Date: Mar 2009
Posts: 1,059
Mein Auto: '06 M Roadster Imola/Blk
Is this the leak from the cracked 3rd brake light?
Reply With Quote
  #18  
Old 10-04-2011, 12:32 PM
STR8VI STR8VI is offline
Registered User
Location: Birmingham, Al
 
Join Date: Oct 2011
Posts: 7
Send a message via Skype™ to STR8VI
Mein Auto: Z4
Hey chickdr.....no. Water comes in through a rubber grommet that feeds the main battery cable to the front of the car. Usually when you drive through a puddle!
Reply With Quote
  #19  
Old 11-14-2011, 02:27 PM
STR8VI STR8VI is offline
Registered User
Location: Birmingham, Al
 
Join Date: Oct 2011
Posts: 7
Send a message via Skype™ to STR8VI
Mein Auto: Z4
It turns out my insurance company is gonna pay for a replacement part since flooding is covered under my policy. They're paying $1092.00. I'm with statefarm and it did take a little persistence but well worth the effort. This has been a major pain for me and after much research, absolutely the best option. Better still, they don't deal directly with the service center so they're making the check payable to me. I don't know why i didn't think insurance to begin with, thank God for older brothers. Remember, with insurance company's never volunteer your interpretation of how it happened, it's not your job. All I know is my **** got flooded!

Can't wait to get my tunes back!

Hope this was helpful :o)
Reply With Quote
  #20  
Old 01-03-2012, 07:21 AM
macsnjets macsnjets is offline
Registered User
Location: New Jersey
 
Join Date: Jan 2012
Posts: 5
Mein Auto: 2003 z4
another water victim here

I too need an amplifier for my wife's 03 z4 pn: 65126929689. If anyone has one let me know. She won't drive it without music so the car has just been sitting.
Thanks
Reply With Quote
  #21  
Old 02-04-2012, 08:18 AM
71trigirl 71trigirl is offline
Registered User
Location: Louisiana
 
Join Date: Sep 2010
Posts: 11
Mein Auto: 2004 Z4 3.0i Roadster
My '04 Z4 has a blown amp. It was working when I dropped the car off for a transmission repair, which led to a battery replacement, which "in my opinion" led to the shorting out of my amp. Has anyone heard of a battery replacement situation that caused the amp to blow? The repair shop pointed out that there was corrosion on the amp from moisture - so they deny any responsibility for it. I bought the car used over a year ago and it worked up until I picked it up from them... I have not had water in the trunk since I've had the car.

Just wondering if anyone else had a similar experience. My part number is 65126963304 if anyone has one they want to get off their hands. I'm a frugal shopper, so I'm not very willing to give up $900+ for a new one.

Thanks all.
Reply With Quote
  #22  
Old 02-06-2012, 07:21 AM
ECSTuning's Avatar
ECSTuning ECSTuning is offline
Instructor of the Stig™
Location: Wadsworth, Ohio
 
Join Date: Feb 2009
Posts: 4,044
Mein Auto: Hover Car on Wheels
Quote:
Originally Posted by 71trigirl View Post
My '04 Z4 has a blown amp. It was working when I dropped the car off for a transmission repair, which led to a battery replacement, which "in my opinion" led to the shorting out of my amp. Has anyone heard of a battery replacement situation that caused the amp to blow? The repair shop pointed out that there was corrosion on the amp from moisture - so they deny any responsibility for it. I bought the car used over a year ago and it worked up until I picked it up from them... I have not had water in the trunk since I've had the car.

Just wondering if anyone else had a similar experience. My part number is 65126963304 if anyone has one they want to get off their hands. I'm a frugal shopper, so I'm not very willing to give up $900+ for a new one.

Thanks all.
Hopefully you can find one used. If not HERE is a link to the new one to save you some searching.




Quote:
Originally Posted by macsnjets View Post
I too need an amplifier for my wife's 03 z4 pn: 65126929689. If anyone has one let me know. She won't drive it without music so the car has just been sitting.
Thanks
I'm not seeing that part number in our system.
If the car has the base HiFi system the amp found HERE is the one used.
If the car has the DSP sound system the amp found HERE is the one needed.


ECS Tuning
__________________

Have questions? Need answers? Live Chat us! 8:30am to 12:00am Midnight EST
sales@ecstuning.com | customerservice@ecstuning.com
Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 | OEM BMW Part Number Search
Do you love surveys? Click HERE to take our Customer Satisfaction Survey!

Last edited by ECSTuning; 02-06-2012 at 07:26 AM.
Reply With Quote
  #23  
Old 02-26-2012, 08:43 AM
BU Z4 BU Z4 is offline
JUVENTUS
Location: Dallas
 
Join Date: Jun 2008
Posts: 24
Mein Auto: Z
SOLD

I have the top hifi dsp amplifier for sale. $550

SOLD

Last edited by BU Z4; 03-07-2012 at 09:58 PM.
Reply With Quote
  #24  
Old 02-27-2012, 06:54 AM
love_my_Z4 love_my_Z4 is offline
Registered User
Location: Princeton, NJ
 
Join Date: Sep 2011
Posts: 6
Mein Auto: 2003 Z4
Thank you ECS(James) for the AMP. It's installed and up and running once again...hurray!!!

Apparently water in the trunk is quite the common occurrence. One additional step that I've taken is to drill (4) @ 1/4" holes in the bottom of the battery/amp well to prevent accumulation of water from happening again.
Reply With Quote
  #25  
Old 02-27-2012, 07:26 AM
ECSTuning's Avatar
ECSTuning ECSTuning is offline
Instructor of the Stig™
Location: Wadsworth, Ohio
 
Join Date: Feb 2009
Posts: 4,044
Mein Auto: Hover Car on Wheels
Glad I could be of help!

James with ECS
__________________

Have questions? Need answers? Live Chat us! 8:30am to 12:00am Midnight EST
sales@ecstuning.com | customerservice@ecstuning.com
Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 | OEM BMW Part Number Search
Do you love surveys? Click HERE to take our Customer Satisfaction Survey!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms