Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #26  
Old 03-04-2012, 10:17 AM
DHHathaway DHHathaway is offline
Registered User
Location: Huntsville, Alabama, USA
 
Join Date: Nov 2007
Posts: 4
Mein Auto: 2003 Z4 3.0i
I have the original Carver Amp from my 03 Z4 but the sub-woofer channels are dead (the original sub-woofers are a joke anyway - I replaced mine with JL Audio 6W3v3s and added a 300 watt amp to drive them). I'd be willing to part with the amp for a dime on the dollar plus shipping.
Reply With Quote
  #27  
Old 06-27-2012, 06:29 PM
71trigirl 71trigirl is offline
Registered User
Location: Louisiana
 
Join Date: Sep 2010
Posts: 11
Mein Auto: 2004 Z4 3.0i Roadster
DHHathaway - would you still have that amp? I am interested. Thanks.
Reply With Quote
  #28  
Old 01-29-2013, 02:09 PM
ShellShock ShellShock is offline
Registered User
Location: Stamford CT
 
Join Date: Jan 2013
Posts: 2
Mein Auto: 2003 BMW Z4
Need 2003 BMW Z4 Amp

Hi all, I'm new to the forums but am also searching for the hard to find BMW Z4 Amp. Same water problems via the break light. If anyone has one or knows of a new solution please inform!
Reply With Quote
  #29  
Old 09-19-2013, 05:34 AM
Cgroh360 Cgroh360 is offline
Registered User
Location: Kansas
 
Join Date: Aug 2013
Posts: 4
Mein Auto: Roadster z4
I also have the amp problem and need to find fix. Should I try and find stock amp or change it to an after market amp
Reply With Quote
  #30  
Old 09-19-2013, 09:04 AM
71trigirl 71trigirl is offline
Registered User
Location: Louisiana
 
Join Date: Sep 2010
Posts: 11
Mein Auto: 2004 Z4 3.0i Roadster
I have found no fix

My brother is an electrical engineer. He has done numerous tests of the circuits and has it narrowed down but not going to be easy to fix - if at all. I'm going to opt for a new/ used factory amp for simplicity. I don't listen to hi-def anything, mostly news... so that will work for me. Problem is, I haven't found one within my budget. Guess I'll be increasing the budget!
Reply With Quote
  #31  
Old 10-26-2013, 11:37 AM
ShellShock ShellShock is offline
Registered User
Location: Stamford CT
 
Join Date: Jan 2013
Posts: 2
Mein Auto: 2003 BMW Z4
Hey apologies if this is too late!

I found my replacement amp on Ebay (it was used) and ran around 500 bucks if I remember correctly.

They aren't easy to find, but be careful you get the same serial number or are sure it is the correct amp as there are a few different models.

Best of luck!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms