Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #51  
Old 07-07-2014, 03:16 PM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,224
Mein Auto: '03 745Li
Quote:
Originally Posted by Harmztl View Post
I just pulled my amp to mail out but the caps all look fine. My left side speakers sound like crap and no bass, jus popping sound. Is there any harm in driving the car without the amp? Anything I should be careful of?


Sent from BimmerApp mobile app

No harm but don't expect anything else to work since the loop will be broken. You have get a lollipop from the dealer to close the loop and other devices should function.


Sent from BimmerApp mobile app
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )

For those like that love INK checkout join
Myinkedspace.com with my referral code and enjoy

http://myinkedspace.com/?ref=REF65900
Reply With Quote
  #52  
Old 07-16-2014, 09:34 AM
525iT_Feen 525iT_Feen is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Apr 2004
Posts: 197
Mein Auto: 750i Sport
I just had John fix my logic7.
Rear speakers sounded like they had bad voice coils and the subs gave out shortly after.
His customer service is some of the best i've encountered in recent years.

He turned the amp around in 24hrs and I just put it in now. Sounds better then it ever did as far as I can tell.
__________________
Reply With Quote
  #53  
Old 08-28-2014, 08:29 AM
Hoya_loya Hoya_loya is offline
Registered User
Location: maryland
 
Join Date: Mar 2014
Posts: 8
Mein Auto: 750Li
This is an great thread. Much appreciation for those that have offered advice.

Relatively new owner of a 2008 750Li. I too notice that my speakers sounded muffled at times (but not all the time). I used the fader and balance to isolate that the problem seemed to be the left side of the car.
Seemed like distortion, no base, bad muffling. It did not always do this so I figured electrical and it was good enough to not pour money into YET.
Now its clearly both sides. I never drive the car, so it was odd to me that now It was occurring out the blue on the left and right. Seems like no bass at all.

Clearly there is likely an L7 amp problem, seems to be the major cause here. My question is how can I tell if i also have a problem with my ASK unit? Is there certain speakers I can isolate to check? or a certain sound to listen for? I prefer not to pull that unit out if I dont have to. Any advice is helpful. Ive emailed John and perhaps he will guide me but figured it throw it out there here as well since you guys are so helpful.

Thanks.
__________________
2008 750Li

Reply With Quote
  #54  
Old 08-28-2014, 10:29 AM
Hoya_loya Hoya_loya is offline
Registered User
Location: maryland
 
Join Date: Mar 2014
Posts: 8
Mein Auto: 750Li
John is good....emailed me back literally in 10 mins from a cold email from me.

250 + 15 for shipping.

called a local shop who is supposedly an expert in audio....they want to replace the L7 for 1200.00 smh

feel bad for people who get taken simply because they dont do some research or on this forum.
__________________
2008 750Li

Reply With Quote
  #55  
Old 09-08-2014, 09:01 PM
crzbf crzbf is offline
Registered User
 
Join Date: Apr 2014
Posts: 8
Mein Auto:
Does john repair the ask unit also ??
Ty in advance !!


Sent from BimmerApp mobile app
Reply With Quote
  #56  
Old 09-08-2014, 09:05 PM
Hoya_loya Hoya_loya is offline
Registered User
Location: maryland
 
Join Date: Mar 2014
Posts: 8
Mein Auto: 750Li
I assume he fixes it all. He replied quickly to my email so I would just shoot him one and get a sure answer.
__________________
2008 750Li

Reply With Quote
  #57  
Old 09-08-2014, 09:07 PM
crzbf crzbf is offline
Registered User
 
Join Date: Apr 2014
Posts: 8
Mein Auto:
Yea I sent him one right now hope he answers
I know the logic 7 is shot but I think the ask is also
I only have the center dash speaker working all others don't or crack
The chime sound goes on for a few seconds when car is cold but then that's it only that one speaker works
It sucks


Sent from BimmerApp mobile app
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms