Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-31-2011, 04:48 PM
protosport protosport is offline
Registered User
Location: South Lyon
 
Join Date: Aug 2011
Posts: 2
Mein Auto: 1985 524td
Radio won't hold presets

Hi all, I recently purchased a 1985 524 td it is in great shap, runs excellent, but the radio will not hold the preset stations after I shut the car off. Any ideas?
Reply With Quote
Ads by Google
  #2  
Old 08-31-2011, 07:10 PM
catso's Avatar
catso catso is online now
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,932
Mein Auto: 2000 323i, 1988 528e
Quote:
Originally Posted by protosport View Post
Hi all, I recently purchased a 1985 524 td it is in great shap, runs excellent, but the radio will not hold the preset stations after I shut the car off. Any ideas?
There are two fuses for the radio: #5 and #12. Make sure they aren't cracked and are making good contact. Another possibilty is the wiring to the radio or the accessory wiring coming off the battery.
__________________
Don't be gormless; get some gorm!
![/I][/FONT]
Reply With Quote
  #3  
Old 09-01-2011, 01:24 PM
protosport protosport is offline
Registered User
Location: South Lyon
 
Join Date: Aug 2011
Posts: 2
Mein Auto: 1985 524td
Thanks Catso for the infomation I will give a try.
Reply With Quote
  #4  
Old 09-04-2011, 08:34 AM
Ataglance Ataglance is offline
Registered User
Location: Michigan
 
Join Date: Dec 2010
Posts: 34
Mein Auto: 1988 528
On mine it was the yellow wire on the radio that went to the memory which is where the presets are stored (if I remember correctly). Maybe there is a fault in the connection to the yellow wire?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 06:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms