Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)

E60 / E61 (2004 - 2010)
BMW 5-Series E60 Sedan was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E61 wagon followed shortly there after. The E60/E61 5 series is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 03-20-2015, 05:58 PM
osam24 osam24 is offline
Registered User
Location: orlando
 
Join Date: Mar 2015
Posts: 2
Mein Auto: 530i
E60 Drive control System light on after control arm replacement

Hi All,

I have read about this control system light in a number of threads.
My issue is a little different. Here is the information:

2004 530i. Replaced both driver and passenger lower control arms. From the passenger side (dont know the name) their is what looks like a stabilizer link with a sensor on it. I unplugged it to replace the passenger control arm.

Since I replaced the lower control arms the light went on and stayed on. To make the car steer straight you have to keep the steering wheel to the right.

I highly suspect that the alignment is off seeing as the steering wheel has to be turned to the right to keep the car straight and this is likely the reason for the light coming on? Or perhaps I didn't plug it in back properly. I never had a problem with this light before (2 hours before I started)


is my suspicion correct?

Need some expert advise here before I take it for a wheel alignment. I heard someone corrected their problem with a wheel alignment?

thanks in advance
Reply With Quote
Advertisement
  #2  
Old 03-25-2015, 05:14 AM
nateloffe nateloffe is offline
Registered User
Location: Pittsburgh
 
Join Date: Mar 2015
Posts: 36
Mein Auto: 535xi
It's not uncommon to re-assemble the linkage to that sensor(ride height sensor for active steering?) when you have the control arm off. For example, when you removed it, the arm was at say 9 o'clock. After assembly, it's now at 3 o'clock. If you have active steering, that could be what it is. Also, replacing your lower control arms shouldn't effect you alignment enough for you to notice. I don't know... It's early... I'm still on my first cup of coffee...LOL. Good luck!!!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 / E61 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms