Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 09-16-2011, 10:59 AM
mscamp's Avatar
mscamp mscamp is offline
Bimmer Dreamer
Location: Central Illinois
 
Join Date: Jan 2005
Posts: 510
Mein Auto: 2011 X3
Instrument Cluster Reset

Had the battery drain down while having windows tinted. Jump start was fine except that now all the gauges are messed up. Dealer explains that they will do a cluster reset and battery check. 2006 X3 w/ 65k miles. Probably time for a battery anyway.

Best car we have ever owned.
__________________
2011 X3 - Purchased BMW of Peoria, IL October 6, 2012 - Deep Sea Blue/Oyster/Sienna - CWP1, CWP2, TP, PP, CP, PDC.
2006 X3 - Purchased BMW of Peoria, IL September 10, 2007 - Black/Black
2006 330i Purchased BMW of Peoria, IL October 12, 2005 Arctic Met/Beige
Reply With Quote
Advertisement
  #2  
Old 09-18-2011, 11:51 AM
mscamp's Avatar
mscamp mscamp is offline
Bimmer Dreamer
Location: Central Illinois
 
Join Date: Jan 2005
Posts: 510
Mein Auto: 2011 X3
Seems to be healing itself. Everything is pretty much back to normal.
__________________
2011 X3 - Purchased BMW of Peoria, IL October 6, 2012 - Deep Sea Blue/Oyster/Sienna - CWP1, CWP2, TP, PP, CP, PDC.
2006 X3 - Purchased BMW of Peoria, IL September 10, 2007 - Black/Black
2006 330i Purchased BMW of Peoria, IL October 12, 2005 Arctic Met/Beige
Reply With Quote
  #3  
Old 08-12-2012, 05:03 PM
cybercord cybercord is offline
Registered User
Location: Lawrenceville
 
Join Date: Aug 2012
Posts: 1
Mein Auto: M Roadster
Thumbs up Cluster reset

Had the same problem today. The cluster was not showing anything. But the radio and memroy settings still worked. I looked into the fuses as possible. Removed the 3 that are releated to the display, 5, 34, and 43. After pulling and replacing 43 I heard some sounds inside the car. Put the key into the car , then to pos 2 and had a mess. But cluster lights are on. Drove a little and then all things started to come back. Cheaper than taking to the dealer.

Good Luck
Al
Reply With Quote
  #4  
Old 08-13-2012, 09:57 AM
littleengin littleengin is offline
Registered User
Location: Vermont
 
Join Date: Apr 2011
Posts: 59
Mein Auto: 2006 X3 M-Sport
Had the same symptoms after replacing the battery. Checked the fuses and I had one blown. Replaced it and everything is back to normal.
Reply With Quote
  #5  
Old 11-06-2013, 10:17 AM
sgt118 sgt118 is offline
Registered User
Location: Jonesborough, Tn
 
Join Date: Oct 2013
Posts: 7
Mein Auto: 2001 BMW 330I
cluster messed up...

I had a battery and alternator changed out yesterday. Went to drive the car and some of the gauges don't go back to starting all the way and trip resets all the time and clock does the same, any info will be very thankfull.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms