Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Welcome to Bimmerfest > New Member Introductions

New Member Introductions
Welcome to Bimmerfest! Whether you are a current BMW owner or just interested in BMW cars, we hope you enjoy your visit. Take a moment to introduce yourself and post a picture of your BMW for the rest of the community to see.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-12-2011, 10:10 AM
mkdx5 mkdx5 is offline
Registered User
Location: stoke on trent
 
Join Date: Oct 2011
Posts: 9
Mein Auto: bmw x5 3.0d msport
error code 5f12

im new to the site just wanted to hi to everyone
had new brakes replaced on my x5 3.0d msport 2008 model 6 weeks ago and keep getting error code brake pads need replacing had it checked out at the garage replaced the brake sensor and still keeps saying error code 5f12c replace brake pads front axle please can someone help thanks
Reply With Quote
Ads by Google
  #2  
Old 11-06-2011, 07:36 AM
nik_uk nik_uk is offline
Registered User
Location: UK
 
Join Date: Dec 2010
Posts: 3
Mein Auto: 645ci
Hi - did you ever resolve this issue? - just replaced the PADS on mine, and now i keep getting 5F12 code - thanks in advance
Reply With Quote
  #3  
Old 11-10-2011, 01:44 AM
mkdx5 mkdx5 is offline
Registered User
Location: stoke on trent
 
Join Date: Oct 2011
Posts: 9
Mein Auto: bmw x5 3.0d msport
problem still not resolved been to a couple of garages (owned by friends) tried resetting it but no joy
Reply With Quote
  #4  
Old 11-10-2011, 01:59 AM
nik_uk nik_uk is offline
Registered User
Location: UK
 
Join Date: Dec 2010
Posts: 3
Mein Auto: 645ci
I sorted mine - I followed: - Note it took 3 times - then it worked

1. Turn ignition to 'ON;' DO Not Start Engine

2. Press and hold the Instrument Cluster Set/Reset button
for 10 seconds.

3. The upper display in the Instrument Cluster will be
illuminated with a Service Item (example: An oil can is the
designation for Oil Service). The lower display in the
Instrument Cluster will indicate the remaining time or
mileage left for that Service Item (example: 14000).
Pressing the button repeatedly will allow the display to
scroll through all of the Condition Based Service Items.

4. Press and hold the Instrument Cluster Set/Reset button
again

5. Pressing the Instrument Cluster Set/Reset button again
will allow the "RESET" to appear in the lower window for
that service.

THIS IS IMPORTANT

Releasing and reapplying the button one more
time will reset the service displayed in the upper window
only. Repeat the procedure for any additional service reset
needs.

Good luck chap
Reply With Quote
  #5  
Old 11-11-2011, 04:08 AM
mkdx5 mkdx5 is offline
Registered User
Location: stoke on trent
 
Join Date: Oct 2011
Posts: 9
Mein Auto: bmw x5 3.0d msport
thankyou youre a star took a while but got there in the end.took 3 attemps to clear it but t was worth it no more annoying messages on he screen thanks again
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > Welcome to Bimmerfest > New Member Introductions
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms