Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-28-2011, 10:06 AM
bmw740gal bmw740gal is offline
Registered User
Location: kentucky
 
Join Date: Oct 2011
Posts: 6
Mein Auto: 2000 740IL
00 740iL - Brake, ABS, DSC lights on

Shortly after purchasing my 2000 740IL the DSC, Brake and ABS lights came on. They don't always come on, but are on most of the time. When cold outside they don't seem to come on as quickly or consistently. Nothing has been done to the car other then an oil change by a BMW service center, so don't understand why they started coming on. Any and all information is appreciated.
Reply With Quote
Ads by Google
  #2  
Old 10-28-2011, 11:03 AM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Everything that you need to know is here, on bluebee's post : http://www.bimmerfest.com/forums/sho...d.php?t=527750

Short tests: Odometer's working? Cruise control? Are the lights always ON? First thing that I would do is to clean and inspect all the sensors, after that test them as described above in the links, and later take the car somewhere to have the ABS/DSC module read .

Good Luck!
__________________
JOY = BMW
Reply With Quote
  #3  
Old 10-28-2011, 11:11 AM
bmw740gal bmw740gal is offline
Registered User
Location: kentucky
 
Join Date: Oct 2011
Posts: 6
Mein Auto: 2000 740IL
Thank you for your quick response. Odometers is working, cruise works, lights only on when I want them to be. It could be me, but the link no longer brings up a page.
Reply With Quote
  #4  
Old 10-28-2011, 12:24 PM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Yeah...it's not working for some reason.
try this one : http://www.bimmerfest.com/forums/sho...d.php?t=527750

It could be a easy fix (speed sensor) or more complicated (ABS module). Have a read at the thread provided and you might fix it yourself.
__________________
JOY = BMW
Reply With Quote
  #5  
Old 10-30-2011, 12:45 AM
Muhammad's 740i Muhammad's 740i is offline
Muhammad's 740i
Location: Petaluma CA
 
Join Date: Apr 2011
Posts: 19
Mein Auto: BMW 740i
I have the same problem. Took my car to bimmer specialist and he checked it, my (bosch 5.7) abs module is bad. Rebuilding it is cheaper than buying a new one. eBay got some good deals.
Reply With Quote
  #6  
Old 11-30-2011, 01:24 PM
bmw740gal bmw740gal is offline
Registered User
Location: kentucky
 
Join Date: Oct 2011
Posts: 6
Mein Auto: 2000 740IL
Weather has gotten colder where I live and I have noticed that these lights do not come on hardly if at all. Could this clue help zero in on the issue?
Reply With Quote
  #7  
Old 11-30-2011, 02:42 PM
joyism5's Avatar
joyism5 joyism5 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jan 2011
Posts: 1,270
Mein Auto: '99 740IL, K75RT
Quote:
Originally Posted by bmw740gal View Post
Weather has gotten colder where I live and I have noticed that these lights do not come on hardly if at all. Could this clue help zero in on the issue?
Without doing any diagnosis , just comparing your symptoms with the rest of the BMW owners, which reported about the BMW ABS lights coming ON ...You have the very common problem :ABS/DSC module started to go South.... What is happening is one of the silver wires is lifting off from the circuit board causing the miss communication between Module and Wheel Speed Sensors. The reason why sometimes is working or sometimes is not, or why is working when is cold outside but is coming ON after the engine arm up or the car has been start for the second time on the same day....is that temperature (outside and engine bay) will affect the conductivity of the culprit wire. For instance : cold weather will constrict the wire and will touch again the board, and hot weather will dilated the wire lifting it even more. Or viceversa, depending of the broken wire.
Some picture with this wire are explained here in post # 62 http://www.bimmerfest.com/forums/sho...=451633&page=3
__________________
JOY = BMW

Last edited by joyism5; 11-30-2011 at 02:43 PM.
Reply With Quote
  #8  
Old 12-01-2011, 04:29 PM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 21,106
Mein Auto: 02 BMW 525i M54 auto 130K
Quote:
Originally Posted by joyism5 View Post
You have the very common problem
Everything joyism5 said is right on the money!

It turns out almost every 5-series E39 has this problem of the silver-colored wire lifting off the gold bondpad in the Bosch 5.7 ABS control module so we're 'very' familiar with this problem.

While any of about 20 sensors (see the PDFs already mentioned in the references joyism5 provided above) 'could' be the culprit ... almost always ... it's either one (rarely, if ever more than one) wheel speed sensor ... or ... the ABS control module itself.

There are quick 10-minute tests for the wheel speed sensors (you can test all four with the wheels on the ground in about 10 minutes) - but the only iron-clad diagnostic test for the ABS control module is to open it up and look inside with a dental pick or (some say 'magnetized) needle to see if the silver-colored (some say they're steel) wire lifted off the gold bondpad.

If you really like to test things, there are six or seven (some comprehensive) tests you can run on the wheel speed sensors ... and ... of course ... you can test with the fancy schmancy BMW diagnostic tools (which, in this case, don't provide all that much value simply because they're not hooked up BETWEEN the sensors and the ABS control module).

There is so much information about this that joyism5 already pointed you to that I hesitate to add more links to your reading ... but perhaps these few are the best to start with (most, or even all of which are in the links he has already provided).

- How to diagnose the BMW amber ABS BRAKE DSC/ASC trifecta or bifecta (1) & what are all known options when your ABS control module is bad (1) & Quick99Si's explanation of why the 10-minute wheel speed sensor diode-action quick test doesn't always work, especially on brand new non-OEM wheel speed sensors (1) (2) & explanations by 540iman as to why the fancy diagnostic tools very often (extremely often, like almost all the time) fail to properly diagnose the trifecta or bifecta (1) (2) (3) (4) (5) (6) & where to get the fancy schmancy diagnostic tools for free once you're aware of these limitations (1)


Last edited by bluebee; 12-01-2011 at 04:37 PM. Reason: Added a picture for clarity ...
Reply With Quote
  #9  
Old 04-05-2013, 08:30 PM
hpipe hpipe is offline
Registered User
Location: PA
 
Join Date: Mar 2013
Posts: 1
Mein Auto: 740i
Hi -
Just curious - So how long did it take for the trifecta lights to go out after putting in the new/rebuilt abs module?

I've seen a few posts on drive cycle, but none of them said when that particular system gets checked.

My speedo is still out, and the three lights are still on after several days - not sure how many miles I've gone though ...for obvious reasons...and one of them is I can't even see those numbers even if it was working because the pixels or light is out in that section of the dash :-(
Reply With Quote
  #10  
Old 04-12-2013, 08:31 AM
Magnum Magnum is offline
Registered User
Location: Somewhere Between Here And There
 
Join Date: Jan 2006
Posts: 12
Mein Auto: 740
Quote:
Originally Posted by hpipe View Post
Hi -
Just curious - So how long did it take for the trifecta lights to go out after putting in the new/rebuilt abs module?

I've seen a few posts on drive cycle, but none of them said when that particular system gets checked.

My speedo is still out, and the three lights are still on after several days - not sure how many miles I've gone though ...for obvious reasons...and one of them is I can't even see those numbers even if it was working because the pixels or light is out in that section of the dash :-(
Well, I was able to clear mine immediately after installing the rebuilt unit by simply clearing out the codes, see below:

DCS / ABS Module - Clearing Codes
__________________

----------------------------------------------------------
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms