Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-31-2011, 11:42 PM
mkmichalek mkmichalek is offline
Registered User
Location: Marylang
 
Join Date: Apr 2011
Posts: 48
Mein Auto: 528i & 750i
P1189 Code fixed

Hi, Just a FYI post. I have a 2000 528i with 164,000 miles on it. I got a P1189 code. I have never changed the oil seperator and its associated hoses. The car didn't have any driveability issues or smoking issues. I figure with the high milage on the car I would just go ahead and replace the oil seperator and the hoses. Along with the repair I replaced the intake manifold gasket also. Hoping this would clear the code and it did. I really didn't examine the old hoses for any cracks. I wish I would of now. But apparently one of the hoses must of had a vacuum leak in it. Anyway I just wanted to post this maybe it might help someone down the road who gets this code.
Reply With Quote
Advertisement
  #2  
Old 11-01-2011, 04:12 AM
wolfen wolfen is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Jul 2007
Posts: 408
Mein Auto: 97 BMW 540i
Hmmm my 97 didn't throw a code for that. It just started smoking lol and limped home.
Reply With Quote
  #3  
Old 11-01-2011, 09:30 AM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 9,425
Mein Auto: '97 540i 6 speed
P1189 points to the pre-cat O2 sensor on the rear bank.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #4  
Old 11-01-2011, 04:10 PM
mkmichalek mkmichalek is offline
Registered User
Location: Marylang
 
Join Date: Apr 2011
Posts: 48
Mein Auto: 528i & 750i
The 02 sensors have their own code when they go bad. The P1188 & 1189 codes indicate a leak befor the 02 senors. Thats my understanding of it. When I first started researching the problem. I found that some people had replaced the 02 senors and some also replace the MAF sensor with no luck. Some reported it reset the code, but returned. Even as long as a week later. But thats just the nature of a vacuum leak (slight leak / temperture related). Wolfen I don't think my oil seperator was bad. Thats why my car didn't smoke, but one of the hoses that was associated with it was diffently bad which was causing the vacuum leak.

Last edited by mkmichalek; 11-01-2011 at 04:15 PM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms