Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-03-2013, 11:01 PM
qness335 qness335 is offline
Registered User
Location: rosemead
 
Join Date: Sep 2007
Posts: 44
Mein Auto: 535
Shifter Problem or Transmission??

Hi all,

Recently I experience problem when I shift to R to back up, Idrive displays "gear selector malfunction", it happens more often now, I don't think I shift it wrong in any way. The gear still works fine, but somehow screen displays that error. Sometimes it takes about two tries to have it shifted to R, first time no response, it works on 2nd try. I don't have any issue for "D", just "R"

my car is still CPO so i know the transmission is still covered, but i'm not sure on the shifter, any one have any idea?? my car has about 40k miles, 09 535.

Thank you for the input.
__________________
'09 535i Cobb'ed
Reply With Quote
Ads by Google
  #2  
Old 04-06-2013, 01:33 AM
MRV99 MRV99 is offline
Officially Welcomed to the 'Fest
Location: Chicago
 
Join Date: May 2007
Posts: 1,068
Mein Auto: 2011 M3 DCT
this is a shifter issue and not a trans issue. I had the same stuff happen to my e60.... some times it took me 5+ tries to get it into R. Take it in now
__________________
12 X5 50i Sport
11 M3 DCT
11 X5 50i (lemon)
-- SOLD --
08 550i M-Sport
04 BMW 545I sport
07 BMW X5 4.8I sport
02 BMW X5 4.4i sport
01 BMW 540I M/sport
00 SL500
97 SL500
Reply With Quote
  #3  
Old 04-06-2013, 02:07 PM
qness335 qness335 is offline
Registered User
Location: rosemead
 
Join Date: Sep 2007
Posts: 44
Mein Auto: 535
Thank you. I hope it's not expensive to fix it.
__________________
'09 535i Cobb'ed
Reply With Quote
  #4  
Old 04-06-2013, 02:23 PM
i545i i545i is offline
Registered User
Location: United States
 
Join Date: Mar 2013
Posts: 30
Mein Auto: 545i
had same issues... 2 things : there is a bolt at the end of the shifter ; some pennies and dimes were at the end of that bolt, not letting the gear engaged . Additionally , the rubber on the gear engaged on the transmission was worned out.
Reply With Quote
  #5  
Old 04-20-2013, 08:16 AM
qness335 qness335 is offline
Registered User
Location: rosemead
 
Join Date: Sep 2007
Posts: 44
Mein Auto: 535
Update:

dealer replaced the shifter plus the ribbon cable connected to the knob.
It was defective. This service is covered under CPO so no out of pocket pay, just $50 cpo deductible.

My car is now ready for Cobb. thanks all.
__________________
'09 535i Cobb'ed
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms