Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #26  
Old 07-28-2014, 05:22 PM
Waziri Bello Waziri Bello is offline
Registered User
 
Join Date: Jul 2014
Posts: 6
Mein Auto:
I have the exact issues on 745li 2003. Mine all started when we tried register a new batery I just replaced. Please send me message to my mail if u have resolved the issue. wzbello@icloud.com


Sent from BimmerApp mobile app
Reply With Quote
  #27  
Old 08-07-2014, 02:17 AM
W1P30U7 W1P30U7 is offline
Registered User
Location: USA
 
Join Date: Aug 2014
Posts: 6
Mein Auto: BMW E65
Talking Battery/Alternator

Had the same issue less than a month ago and it was the battery and alternator that went out at the same time. After replacing both, car seems ok.
Reply With Quote
  #28  
Old 11-25-2014, 07:13 PM
bpdover bpdover is offline
Registered User
Location: orlando, fl
 
Join Date: Apr 2012
Posts: 12
Mein Auto: 750li
Quote:
Originally Posted by Simplechris View Post
hi guys,
the RPM's don't move and I'm getting a ton of errors pop up such as:
Dynamic Drive inactive
Brake/Drive fault drive moderately
Parking brake malfunction
Transmission fault, Drive moderately
Servotronic malfunction - increase steering effort.
The gear display (R, N, D, P) is not even showing up. That spot is blank on the display.Any help would be greatly appreciated.
Simplechris
Hello,

Did you guys found out the issue with this? I'm having the same issue on mine now, got some water in the car and all the sudden all this errors showed up.

Thanks
Reply With Quote
  #29  
Old 11-25-2014, 08:27 PM
First_745Li's Avatar
First_745Li First_745Li is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Jun 2012
Posts: 2,433
Mein Auto: '03 745Li
That's the problem nobody ever comes back to update the thread with their fixes.
__________________


'11 328i
'07 Audi A8 (w/ 20,000 miles)
'03 745Li (sold)
'03 Acura TL-S
'02 Infiniti QX4 (sold )
Reply With Quote
  #30  
Old 11-26-2014, 08:01 PM
W1P30U7 W1P30U7 is offline
Registered User
Location: USA
 
Join Date: Aug 2014
Posts: 6
Mein Auto: BMW E65
Battery/Alternator or Transmission

Hi Simplechris,

When I had this same issue back in July 4, 2014 (Yay!) I originally thought it was only the battery. So I bought the battery from the dealer which came to about $350 dls for a 06 750i, installed it and next day car did the same! Then from previous experiences with BMWs I realized it was also in part because of the alternator. I charged the battery at local Autozone for free and installed back on car to be able to drive it to a local shop where indeed I was told the alternator was bad and would continue to drain the battery until replaced. Alternator then was refurbished/reconstructed for about $160 same day service (dealer wanted to do all for about $1,600 dls!!!) and placed back on car by local shop. I spent about $600 dls in all. $1,000 less than what the dealer wanted! That was my experience. Now it could also be the transmission which is a whole different story that I went through this same year! But hope yours is the battery only and cheaper.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms