Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E36 M3 (1995-1999)

E36 M3 (1995-1999)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-11-2011, 05:17 PM
ssyellow ssyellow is offline
Registered User
Location: Lapeer, Michigan
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 M3
E36 M3 1216 TPS code

Hello everyone I recently pulled up this code on my car. It comes on after about 3-4 minutes of driving but the engine still runs exactly the same. Weird thing is if I push in the gas pedal it goes away until I let off the gas again. Has anyone ever had this problem? Just wondering if there is a easy fix before I go and throw money at a new TPS sensor. Thanks for any help!
-Nate

1995 M3 all stock
Reply With Quote
Ads by Google
  #2  
Old 12-12-2011, 12:08 AM
ssyellow ssyellow is offline
Registered User
Location: Lapeer, Michigan
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 M3
Anyone?
Reply With Quote
  #3  
Old 12-14-2011, 11:03 AM
ssyellow ssyellow is offline
Registered User
Location: Lapeer, Michigan
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 M3
Bump.
Reply With Quote
  #4  
Old 12-17-2011, 06:55 AM
cities cities is offline
Registered User
Location: Norton
 
Join Date: Dec 2011
Posts: 2
Mein Auto: 94 318i
I am having the exact same problem with my 94 m42. I replaced the TPS, took the intake manifold off, cleaned everything including the Idle control valve and mass air sensor. Ran down every wire to look for bends cuts or whatever. I still does the same thing. If I run the car at a set speed for about 45 seconds the check light comes on and it throws a 1216 error. If I let off the gas or speed up the light goes off. I am stumped.
-Bill
Reply With Quote
  #5  
Old 12-17-2011, 01:35 PM
ssyellow ssyellow is offline
Registered User
Location: Lapeer, Michigan
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 M3
Nice to know I'm not alone. I'm almost positive its my TPS sensor now but I still have to test it for ohms when I get a chance. Feel free to check out my threads on other forums. Hopefully we can solve this problem together!

http://www.m3forum.net/m3forum/showthread.php?t=389330

http://forums.bimmerforums.com/forum....php?t=1756284
Reply With Quote
  #6  
Old 12-17-2011, 01:48 PM
cities cities is offline
Registered User
Location: Norton
 
Join Date: Dec 2011
Posts: 2
Mein Auto: 94 318i
I did replace the tps with a new one so I have this old tps which I am assuming is good. You can have this old one if you want to try a swap out before you shell out $60 for a new TPS. Since you are just in Mich. shipping from Ohio will be very little so I can send it for free. Even though Mich beat my buckeyes this year!

Bill
Reply With Quote
  #7  
Old 12-17-2011, 01:53 PM
ssyellow ssyellow is offline
Registered User
Location: Lapeer, Michigan
 
Join Date: Aug 2011
Posts: 5
Mein Auto: 1995 M3
That would be great if you could do that. If it ends up working out to be the problem I would be more than happy to give you some money in return. Lucky for you I like Michigan State! haha
Reply With Quote
  #8  
Old 12-17-2011, 08:41 PM
crisscross's Avatar
crisscross crisscross is offline
Just living MY dream
Location: Best country on Earth
 
Join Date: Mar 2009
Posts: 5,574
Mein Auto: 1995 M3 Boston Green
I had this happen once after a few hard pulls against a friend of mine. I ignored it, and it never returned. I'm interested to see what comes of the new sensor in your case....
__________________
-Alan


Member #2 of the Boston Green Mafia BMW-CCA #457574

1995 BG M3 2000 TiAg 4.4l X5

-I do the things today that others won't do, so I will have the things tomorrow that other won't have....
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E36 M3 (1995-1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms