Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #126  
Old 06-26-2013, 10:43 AM
Panochote Panochote is offline
Registered User
Location: Houston
 
Join Date: Jun 2013
Posts: 13
Mein Auto: 2004 545i
0491 and 0492

I have tried all myself and even a mechanic in Houston who did a decent job clearing lots of carbon out. My Increased Emissions light came back on two weeks later. I've done my research in my reading on this issue and I'm still a dead-end. Sad part is I love this car, the way it runs and the way looks. I kindly ask if any of you gentlemen have a place here in Houston that you would recommend that performs this pressure carbon cleaning. The mechanic I take it to just poured solution that sat and revved up the engine producing the dark smoke. I left the car there with him for about five days and he said a lot of smoke came out the exhaust. I was completely excited when the check engine light went out. But it came back on the this morning. My question again to you gentlemen, do you know anybody in Houston that can cure my ride. I do not mind paying. My cell number is 832-643-8915 and my name is Frank. Appreciate your time and help. fvasque4@comcast.net is my email.
Reply With Quote
  #127  
Old 06-26-2013, 11:08 AM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 225
Mein Auto: 2006 750i
Your may be ok.. You need to buy a cheap obd reader at amazon.com 20 bucks. Depending on the year, and the state that your in you may be ok to pass. Most states allow 1 ready monitor to not be ready. This is usually the secondary air or evap system. If your mechanic got some air going through to the exhaust tailpipe you may be ok. I would reset the codes and after about 500 miles check to see if the evap system is ready. If it is but the SAS isn't go down and get it inspected with 1 monitor out. What year is your car?
__________________

2006 750 I
Reply With Quote
  #128  
Old 06-27-2013, 06:43 AM
Busarider Busarider is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Jun 2010
Posts: 353
Mein Auto: 745LI
Check the codes first before u sink any more $$, could be the hose needs to be replaced, go back and ask the same mechanic to do a smoke test on the hose to look for any leaks.
Reply With Quote
  #129  
Old 06-27-2013, 07:19 AM
Panochote Panochote is offline
Registered User
Location: Houston
 
Join Date: Jun 2013
Posts: 13
Mein Auto: 2004 545i
Fratan and Busrider, Thanks for you replies. I Have the software, INPA, DIS, PROGMAN, NC EXPERT etc so I am able to check my codes and program (still learning believe me. I am a big time rookie). I have completed the smoke test, checked the secondary air pump and put new ccv's as well. I was able to speak to Steve, SVETT and strongly recommended AGA's kit. I will go that route next. BG makes some chemical agent as well that I have not tried but I am just gonna BLOW those ports clean first and go from there. I just wish I knew someone in Hotson that would do it for me. I work day and night man. I may just have to park it and do an hour at a time kind of thing. Thanks fellas and I will keep you posted.
Reply With Quote
  #130  
Old 06-27-2013, 07:58 AM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 225
Mein Auto: 2006 750i
That AGA kit is expensive and me and Robz_745 did the fix before AGA came out with it. They probably read our fix and decided to make a pipe to put into the SA chamber. You do need an air compressor and a wire. Go back in this thread or look up threads by Robz_745 and you'll see the fix. I would first by an Autel scan tool for 20 bucks on Amazon that allows you to read the ready monitors. What year is your car and does Texas allow 1 monitor to be not ready? If 1 monitors can be not ready then I would drive the car for about 500 miles and then check the monitors. Your evap should come on before the SA so then you can take it down before you check engine light comes on.
__________________

2006 750 I
Reply With Quote
  #131  
Old 06-27-2013, 08:21 AM
Panochote Panochote is offline
Registered User
Location: Houston
 
Join Date: Jun 2013
Posts: 13
Mein Auto: 2004 545i
I have a 2004 545i. I will continue ready in the forum for that article. I have to go back and play Probation Officer for a bit then a Real Estate Broker. I WILL find it and read it and try it too at this point. Thanks FRATAN . . .Frank
Reply With Quote
  #132  
Old 06-27-2013, 08:45 AM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 225
Mein Auto: 2006 750i
My wife has a 2004 745i which is the same engine as the 545, I believe. Her car had the dreaded 0491 and 0492 SAS code which is carbon build up in the heads. You should be able to pass inspection once you have a Autel code reader. The evap system will be ready before the SAS and that is when you take it to the inspection station. You should have a little window before the SAS light comes on.
__________________

2006 750 I
Reply With Quote
  #133  
Old 06-27-2013, 09:59 AM
Panochote Panochote is offline
Registered User
Location: Houston
 
Join Date: Jun 2013
Posts: 13
Mein Auto: 2004 545i
The good part is that I can get the inspection sticker. My bad part is that I want to fix it because I actually love this car. Sounds cheezy but this 52 old fart loves driving it especially when I go done the road with my "escort" k banding them buddies of mine.
Reply With Quote
  #134  
Old 06-27-2013, 11:19 AM
fratan fratan is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Jan 2012
Posts: 225
Mein Auto: 2006 750i
Pan,
If your using INPA just reset the SAS light when it comes on. The low flow for the secondary air doesn't affect the performance of the vehicle. It is only to heat up the cats when the car is cold and then the secondary air goes out. The only reason people need to fix this is for inspection stickers. Put your money into, fixing the 2 major coolant leaks, valleypan tube and coolant cover, the bridge seal adapter between the tranny and mechatronics and the seal underneath the alternator bracket. This is money well spent.
__________________

2006 750 I
Reply With Quote
  #135  
Old 07-19-2013, 03:12 PM
alpinaman24's Avatar
alpinaman24 alpinaman24 is offline
what amg?
Location: San fern valley
 
Join Date: Feb 2012
Posts: 398
Mein Auto: 07 B7,91 735i , 91e30sold
im in chatsworth

have the aga tool kit works amazing

before this kit i did what rob did basically but the kits awesome
Reply With Quote
  #136  
Old 07-19-2013, 03:13 PM
alpinaman24's Avatar
alpinaman24 alpinaman24 is offline
what amg?
Location: San fern valley
 
Join Date: Feb 2012
Posts: 398
Mein Auto: 07 B7,91 735i , 91e30sold
i had to have it cuz i work on em all day basically but if its a one time thing i dno not worth it i think
Reply With Quote
  #137  
Old 07-23-2013, 11:32 AM
Panochote Panochote is offline
Registered User
Location: Houston
 
Join Date: Jun 2013
Posts: 13
Mein Auto: 2004 545i
I will order the AGA when I ge the chance and time to do so. I am so busy day and night. I wish I knew someone in houston who would do it for me. I would pay without issues. I just can not stop being a probation officer during the day and a Real Estate Broker at night and weekends. Just freaking busy. I want it done so I can move on to my new tires, satellite hook up and better speakers. Thanks for all of your information here. Frank . . . AKA Pancho
Reply With Quote
  #138  
Old 09-02-2013, 09:12 AM
Busarider Busarider is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Jun 2010
Posts: 353
Mein Auto: 745LI
Hey Pancho, did you finally get this problem fixed?
Reply With Quote
  #139  
Old 09-02-2013, 12:04 PM
Panochote Panochote is offline
Registered User
Location: Houston
 
Join Date: Jun 2013
Posts: 13
Mein Auto: 2004 545i
Busrider, no I have not. I have been driving the heck out of it without issue . . .well I have to put oil every 5k miles. I will do it when it gets cooler down here. It is hot as hell down in Houston and My driveway has no shade. It is still hot with shade. I will order that AGA kit and get it done. I will post here when I do. Probably will not be until November.
Reply With Quote
  #140  
Old 09-03-2013, 12:21 PM
jssmi765 jssmi765 is offline
Jssmi765
Location: Las Vegas, NV
 
Join Date: Jan 2010
Posts: 30
Mein Auto: 2002 745i
It works it works it works!!!

Quote:
Originally Posted by Ricardo21 View Post
I had the same problem with my secondary air pump like a lot of these guys and some guy here experimented with something that dnt make sense but he said it worked so I went ahead and tried it and it worked my check engine light has .not come up since and its been 2 months since I did this and very happy so go to auto zone or orielys and purchase the Lucas or gumeout liquid for fuel injection cleaner for bout 8-10 bucks pour it in not on a full tank but when u have 20-30 miles before empty and pour in cleaner and fill with gas and clear code again and see wat happens I.did it this way and so far so good u have nothing to loose I mean 10 bucks its worth a try and my car has 115k miles on it running strong good luck
The dealership told me around $8,000 to fix the problem causing the p0491 fault, an indie I've used before said $5,000, my regular indie told me it had been $5,000 but they had figured out a way do do it for around $3,300. Taking Ricardo's advice, I figured "He's right, what's $10 if it doesn't work"

I picked up some Lucas fuel injector cleaner at Auto Zone, applied it to a mostly empty tank before fueling up, and then drove about 100 miles. I went into my indie and asked him to clear the codes for which I was charged $52.50, he did it reluctantly telling me all the reasons it wouldn't work and they needed to do a full diagnosis. It's been over a week now and the light has not come back on and I was able to pass the inspection so I could register my car.

THANK YOU THANK YOU THANK YOU RICARDO!!!
Reply With Quote
  #141  
Old 09-04-2013, 02:31 PM
7SeriesFilm 7SeriesFilm is offline
Registered User
Location: south
 
Join Date: Jun 2013
Posts: 35
Mein Auto: 745
Quote:
Originally Posted by jssmi765 View Post
The dealership told me around $8,000 to fix the problem causing the p0491 fault, an indie I've used before said $5,000, my regular indie told me it had been $5,000 but they had figured out a way do do it for around $3,300. Taking Ricardo's advice, I figured "He's right, what's $10 if it doesn't work"

I picked up some Lucas fuel injector cleaner at Auto Zone, applied it to a mostly empty tank before fueling up, and then drove about 100 miles. I went into my indie and asked him to clear the codes for which I was charged $52.50, he did it reluctantly telling me all the reasons it wouldn't work and they needed to do a full diagnosis. It's been over a week now and the light has not come back on and I was able to pass the inspection so I could register my car.

THANK YOU THANK YOU THANK YOU RICARDO!!!
im going to try this because im tired of the light on my dash
Reply With Quote
  #142  
Old 09-05-2013, 09:50 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,295
Mein Auto: 2004 545i
Quote:
Originally Posted by 745iguy View Post
Maka do you remember which file under the ek928 worked on yours? i been trying to do this FOREVER and i do not know which one is for the euro3 DME.. our vehicles are nearly identical but i havent facelifted anything on it besides the MMI for my ipod interface and my nav unit
Edit:
Also ive already wrote FA from GL63 to GL61 in CAS and LMA
And if you could provide what setting you have un/checked? etc..
This info would be greatly appreciated.
Is it the same change for the 5 series E60? I have the same issue.. and am looking to just get the damn light to go off at this point. I'll clean it out later.

It looks like the "Type code" on mine came from the factory as NB33, and NB31 would be the euro version. Thoughts?


Quote:
Originally Posted by MakaveliFaison View Post
Soon as I get home I'll give you the file name I used. While your doing that I'll give you the transmission module name took so you can add sports mode instead of l/d
Could you please share this info??

Quote:
Originally Posted by 745iguy View Post
Thank you, tried to PM you back but can't.
Could you please share this info as well? Thanks guys!

Last edited by schpenxel; 09-05-2013 at 10:11 AM.
Reply With Quote
  #143  
Old 09-08-2013, 02:56 PM
flash_n flash_n is online now
Registered User
Location: Connecticut
 
Join Date: May 2012
Posts: 84
Mein Auto: 745Li
This weekend I tried to tackle my P0492 error.
Sure hope the dreaded error won"t return anytime soon.

PS the question if you'd want to do the coolant pipe while you're in there makes more sense now than it did before.
__________________
Silver 2004 BMW E66 / 745Li (DIYs):
ASK, Logic 7, blower, battery, guibo joint, active stabilizer bar bushings, diff oil, tranny sw update, vacuum pump gasket, window lift, a/c compressor, washer fluid reservoir, belt tensioner and deflector, crankcase vacuum hoses, crankcase vents, solenoid gaskets, headlight overhaul, ISM, hood lifts, driver mirror, sway bar end links, rear fog lamps, headlight washer, headlight vertical aim, VCGs
next up: P0492
Reply With Quote
  #144  
Old 09-08-2013, 04:24 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,295
Mein Auto: 2004 545i
What did you end up doing to fix it?
Reply With Quote
  #145  
Old 09-08-2013, 06:32 PM
roadfrog's Avatar
roadfrog roadfrog is offline
Officially Welcomed to the 'Fest
Location: Chilliwack, BC Canada
 
Join Date: Oct 2009
Posts: 1,092
Mein Auto: 2003 745i
Quote:
depending on the year, and the state that your in you may be ok to pass. Most states allow 1 ready monitor to not be ready. This is usually the secondary air or evap system.
+1
__________________


2008 Lexus LS 460
20" TSW Strip Wheels on Staggered Falken FK452
Reply With Quote
  #146  
Old 09-08-2013, 06:36 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,295
Mein Auto: 2004 545i
Quote:
Originally Posted by roadfrog View Post
+1
I managed to pass last year for this very reason I do believe. CEL light came on the next time I started the car, lol
Reply With Quote
  #147  
Old 09-08-2013, 09:27 PM
roadfrog's Avatar
roadfrog roadfrog is offline
Officially Welcomed to the 'Fest
Location: Chilliwack, BC Canada
 
Join Date: Oct 2009
Posts: 1,092
Mein Auto: 2003 745i
Quote:
I managed to pass last year for this very reason I do believe. CEL light came on the next time I started the car, lol
Yep, that's the trick. Timing is everything.
__________________


2008 Lexus LS 460
20" TSW Strip Wheels on Staggered Falken FK452
Reply With Quote
  #148  
Old 09-09-2013, 07:34 AM
jssmi765 jssmi765 is offline
Jssmi765
Location: Las Vegas, NV
 
Join Date: Jan 2010
Posts: 30
Mein Auto: 2002 745i
Yeah, mine stayed off for a week but went back on yesterday. Oh well, at least I passed inspection!
Reply With Quote
  #149  
Old 10-02-2013, 04:51 PM
Iceman44 Iceman44 is offline
Registered User
Location: Houston, TX
 
Join Date: Oct 2013
Posts: 2
Mein Auto: '03 BMW 745i, '09 MB S63
Quote:
Originally Posted by jssmi765 View Post
The dealership told me around $8,000 to fix the problem causing the p0491 fault, an indie I've used before said $5,000, my regular indie told me it had been $5,000 but they had figured out a way do do it for around $3,300. Taking Ricardo's advice, I figured "He's right, what's $10 if it doesn't work"

I picked up some Lucas fuel injector cleaner at Auto Zone, applied it to a mostly empty tank before fueling up, and then drove about 100 miles. I went into my indie and asked him to clear the codes for which I was charged $52.50, he did it reluctantly telling me all the reasons it wouldn't work and they needed to do a full diagnosis. It's been over a week now and the light has not come back on and I was able to pass the inspection so I could register my car.

THANK YOU THANK YOU THANK YOU RICARDO!!!
I want to say thanks a million to you guys for this suggestion as I tried it on my '03 and had great success. I used the Seafoam first on yesterday (blew out a big cloud of smoke from the exhaust for about 10 minutes) and then later today tried the Gumout once my fuel light came on and then used my code reader. My car is idling so much better and running better as well. I had to erase the P0491 error and then had to drive two drive cycles while waiting for the systems to "ready"...had all but one (SAS), but just passed the State Inspection/Emmissions test. You are allowed one status not ready in Texas.
Reply With Quote
  #150  
Old 08-30-2014, 01:11 PM
mlmotorsport mlmotorsport is offline
Registered User
Location: Midwest
 
Join Date: Apr 2014
Posts: 15
Mein Auto: 2006 750Li 2005 645Ci
Question

Sorry to drag back an old thread but I am looking for somebody who can hook up remotely to do some updates on the 645. I have the DIS software and the cable so I'm able to diagnose and erase codes etc but don't have the know-how to go much further. I know this type of thing can be done, I'm just looking for someone who can do it. If you know of anyone let me know. Much appreciate any help!


Quote:
Originally Posted by Medic67 View Post
Well, since Makaveli's mia on this subject, and no one else seems to know.... Here's an update... Had a guy try to reprogram the FA string from GL61 to GL63 but received an error when trying to write it back using NCS Expert... HOWEVER, ever since doing that NO MORE P0491 / P0492 codes!!! Been 5 weeks now. For anyone in the Midwest, PM me and I'll give you the guys #... He also programmed up a bunch of other things like trunk close with fob, drl, etc.... And super cheap. He's outta Madison, but if you have a laptop, the cable and internet there should be no reason he can't do it remotely.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms