Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 12-28-2011, 02:24 PM
X3emist's Avatar
X3emist X3emist is offline
Officially Welcomed to the 'Fest
Location: NW Georgia USA
 
Join Date: Nov 2009
Posts: 1,308
Mein Auto: 06 X3 Sport
Anyones power steering pump squalling

Our power steering pump makes all kinds of noise. The more you turn it the more it makes. This is worse in the mornings but you can hear excessive noise all the time. The last time I had it in the dealer said they didn't notice anything out of the ordinary. They must be deaf.

This is on an 06 model. Does anyone else notice what you might deem as excessive noise?
__________________
2006 X3 Silver Grey/Black Lthr/Alum Trim/Sport Prem Pkg/Xenons/Servotronic/Prem Sound/Satellite Radio/Heated Seats/Carbon Fiber Pillars/Blue Tooth/Aux In/Cargo Net/Aluminum Pedals/V1 Hardwired
[SIGPIC]
Reply With Quote
Ads by Google
  #2  
Old 01-05-2012, 05:30 PM
Jbanks Jbanks is offline
Blue Beemers
Location: Tennessee
 
Join Date: Jan 2012
Posts: 9
Mein Auto: BMW X3 & BMW 530i
My 06 X3 seems to be making similar sounds when the steering wheel is turned completely. Especially when its lock to lock. Some professional advice would be helpful. Maybe it needs a grease job
Reply With Quote
  #3  
Old 01-11-2012, 08:07 PM
xbdrabbitx xbdrabbitx is offline
05 X3 3.0i Prem pkg
Location: philadeplhia
 
Join Date: Jan 2011
Posts: 36
Mein Auto: 05 x3 3.0i
Thumbs up

Having the same issue. It seems just abnormally loud. Definitely in the mornings and when you touch the wheel at all. I had the dealer check it out at the last service and they said all is well. I don't think so but no one has given me any answers. I don't feel like I'm driving a BMW with my power steering being that loud.
I need some help too!
Reply With Quote
  #4  
Old 01-11-2012, 09:20 PM
Jbanks Jbanks is offline
Blue Beemers
Location: Tennessee
 
Join Date: Jan 2012
Posts: 9
Mein Auto: BMW X3 & BMW 530i
Re:

My BMW advisor told me the same thing. "Your BMW seems to be good condition" I find it hard to believe that others out there have not experienced such an issue with there X3 SAV. Anyway, if anyone knows what could be to done to remedy it, please advice. Honestly, I was hoping for more an active dialog from this forum on such topics...

Last edited by Jbanks; 01-11-2012 at 09:21 PM.
Reply With Quote
  #5  
Old 01-11-2012, 10:27 PM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,082
Mein Auto: 2004 X3 2.5i
Quote:
Originally Posted by Jbanks View Post
Honestly, I was hoping for more an active dialog from this forum on such topics...
My take is that like most things BMW, if you experience the squealing PAS, it is not consistent, and can go away on its own.

Not in all cases evidently, but it's not something that has come up on this forum as a recurring issue.

In this instance, I can see why dealers may have difficulty in diagnosing a problem.

I noticed moderate squeals on full lock occasionally a few years ago, but not recently.

However, I did the turkey baster fluid renewal, just as preventive maintenance - I don't think that it was needed, but figured it would do no harm.

I recall there was a thread about what the one (or two?) marks on the PAS dipstick meant in terms of hot or cold fluid, and if the fluid level is all that critical.
As long as it's not too low of course.
If it's too full, I think the only risk is making a mess from overflow.
(Not a good thing with the alternator located just below!)

Don't know if there is any significance in BMW switching between systems that use ATF and those that use a specific Pentosin 'power steering fluid'.
Was that an LCI change for the X3?
Reply With Quote
  #6  
Old 01-12-2012, 08:26 AM
UncleJ UncleJ is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: May 2006
Posts: 6,526
Mein Auto: '06 X3
Not on an X3, but my wife's A4 had the same problem. Turned out the power steering fluid was low. Topped it up (with the ubiquitous turkey baster) and it was fine. Had to buy special Audi p/s fluid though.
Reply With Quote
  #7  
Old 01-12-2012, 11:47 AM
GTBecker GTBecker is offline
Registered User
Location: Cape Coral
 
Join Date: Jul 2011
Posts: 54
Mein Auto: 2013 X3
My '07 E83 steering pump also sings more than I'd like. It reminds me of my old Fords, notorious for it.
__________________
Tom
'97 528it, '99 X5, '03 X5, '04 528i, '05 X5, '05 330ci, '07 X5, '07 X3, '13 X3
Reply With Quote
  #8  
Old 01-13-2012, 10:35 AM
trader37 trader37 is offline
Registered User
Location: Vancouver, BC
 
Join Date: Jun 2009
Posts: 83
Mein Auto: 2004 BMW X3 2.5 MT
I have an 04 and it's squealing all the time... it's not bad turning the wheel but it's harder than it should be. I did a fluid change and it went away for about a month...fluid level seems fine but the squeal is back
Reply With Quote
  #9  
Old 01-13-2012, 10:41 AM
trader37 trader37 is offline
Registered User
Location: Vancouver, BC
 
Join Date: Jun 2009
Posts: 83
Mein Auto: 2004 BMW X3 2.5 MT
Would this be a pump issue or a rack issue if I want to replace something? Given that mine is a 2004 it's not under warranty and highly doubt there's a service bulletin about this issue...
Reply With Quote
  #10  
Old 01-14-2012, 07:35 AM
X3emist's Avatar
X3emist X3emist is offline
Officially Welcomed to the 'Fest
Location: NW Georgia USA
 
Join Date: Nov 2009
Posts: 1,308
Mein Auto: 06 X3 Sport
Problem is not intermittent

In response to an above post the problem is no intermittent, it is always there. It is worse in the morning and when it is colder out but it is always very very noticable, even in the summer. Way to much noise for a BMW. My CPO is running out in a few months, need to get this addressed.
__________________
2006 X3 Silver Grey/Black Lthr/Alum Trim/Sport Prem Pkg/Xenons/Servotronic/Prem Sound/Satellite Radio/Heated Seats/Carbon Fiber Pillars/Blue Tooth/Aux In/Cargo Net/Aluminum Pedals/V1 Hardwired
[SIGPIC]
Reply With Quote
  #11  
Old 01-14-2012, 07:19 PM
xbdrabbitx xbdrabbitx is offline
05 X3 3.0i Prem pkg
Location: philadeplhia
 
Join Date: Jan 2011
Posts: 36
Mein Auto: 05 x3 3.0i
We need some type of answer. My CPO ran out in August and I had them check but there was "no issue found". We need some help.
Reply With Quote
  #12  
Old 06-20-2012, 01:59 PM
HiYoSilver HiYoSilver is offline
Registered User
Location: AL
 
Join Date: Dec 2009
Posts: 11
Mein Auto: 06 X3
Same problem with my 06. Noisy PS pump. Worst when engine is cold. At least I'm not alone.
Reply With Quote
  #13  
Old 06-21-2012, 04:27 AM
brewder brewder is offline
Officially Welcomed to the 'Fest
Location: Allentown PA Area
 
Join Date: May 2010
Posts: 609
Mein Auto: 2011 328i xDrive
FWIW....


I performed the "poor mans" PS "flush" on my 328xi using the turkey baster method (around 80k miles) and my pump is still running great with 106k on the odo..

The key is to get a few cans of Pentosin, and do the remove/refill procedure 5-10 times after a short drive between each cycle.

It will cost you maybe $60 for two cans of Pentosin, but if it extends the life of your pump / rack, it's money well spent... and if not, it's not enough $$ to get upset about.

As my X3 approaches 70k on the odo, I'm ready to do the same thing with it...
__________________
//Brew...KCCO

('11 E92 328i xDrive - Deep Sea Blue | '07 E92 328xi - Space Gray)
Reply With Quote
  #14  
Old 06-28-2012, 10:28 PM
smashbeem smashbeem is offline
Registered User
Location: Australia, Brisbane
 
Join Date: Jun 2012
Posts: 42
Mein Auto: X3 3.0
i noticed in the 04 modle that i picked up last week. It felt like i was driving my ford car, used to do the same when steering wheel turned lock to lock..!!
Reply With Quote
  #15  
Old 06-29-2012, 05:06 AM
murderland murderland is offline
Officially Welcomed to the 'Fest
Location: s/s
 
Join Date: Jan 2011
Posts: 129
Mein Auto: x3
i think it's a common thing for our x3s, but no problems associated with it other than noise
Reply With Quote
  #16  
Old 07-15-2012, 02:08 PM
dkotanto dkotanto is offline
Officially Welcomed to the 'Fest
Location: Denver, CO
 
Join Date: Jan 2003
Posts: 543
Mein Auto: 2006 BMW 530i sport
I have the same issue. I've used a turkey baster to remove old PS fluid and added Pentosin ATF-1 4-5 times already. The noise is still there. I've ordered a new PS reservoir so I can use the new screen filter that is part of the reservoir, just in case the original one is clogged. As soon as I get someone to help me (it takes two to do a complete flush), I will change the reservoir and flush the fluid completely. I will let you know what the outcome is.
__________________
2007 530 xi
2004 X3 3.0i
2006 530i
Reply With Quote
  #17  
Old 07-21-2012, 07:45 AM
F10ster F10ster is offline
Officially Welcomed to the 'Fest
Location: GA
 
Join Date: Oct 2011
Posts: 123
Mein Auto: 528
Live with it!!

Sorry
Reply With Quote
  #18  
Old 07-21-2012, 12:05 PM
BMW FAN95 BMW FAN95 is offline
Registered User
Location: Chicago Illinois
 
Join Date: Nov 2010
Posts: 84
Mein Auto: 2006 BMW X3
I got it too,, squealing noise, it ticks my mom off.
Reply With Quote
  #19  
Old 07-28-2012, 01:40 PM
Shaggy474 Shaggy474 is offline
Registered User
Location: Columbia, Missouri
 
Join Date: Jun 2012
Posts: 6
Mein Auto: 2005 BMW X3 3.0i
Same issue with noisy Power steering pump

I have an 05 x3 that so far we are sorry we bought. But of the many issues the power steering pump is the loudest I have ever experienced. Works great and fluid level is right on. Dealer said they don't notice anything out of the ordinary. I also have put in an air conditioner, crank shaft sensor, window regulator and have an intermittent starting issue...less than 72,000 on it andn I have only put 2500 on it myself. So far the least realiable most expensive used car I have ever purchased. Did I mention the dealer said its quite routine to replace these items at this milage. I can only hope we run out of these issues soon or it will be up for trade shortly. When it works right I love the car but it certainly has been a big disapointment so far.
Reply With Quote
  #20  
Old 09-11-2012, 11:06 AM
kelly_cat kelly_cat is offline
Registered User
Location: Rowland heights
 
Join Date: Aug 2012
Posts: 8
Mein Auto: BMW 325i
Hi All,
This morning my power steering pump just went bad. The shop quoted me $500+ parts plus labor, I am gonna be out $700 for sure.

Unlike you guys, I am no where near fixing it myself , therefore, I will have to spend the money. YET, this the second time it happened to me. I had it replaced about 3 years ago in 2009 ( my car is 2003 325i), all original parts. Is it normal that it broke again so soon?

Is it the way I drive or just my luck?
Appreciate any feedbacks.

Kelly
Reply With Quote
  #21  
Old 09-11-2012, 01:13 PM
Dominic49's Avatar
Dominic49 Dominic49 is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Sep 2011
Posts: 245
Mein Auto: Bmw
Quote:
Originally Posted by kelly_cat View Post
Hi All,
This morning my power steering pump just went bad. The shop quoted me $500+ parts plus labor, I am gonna be out $700 for sure.

Unlike you guys, I am no where near fixing it myself , therefore, I will have to spend the money. YET, this the second time it happened to me. I had it replaced about 3 years ago in 2009 ( my car is 2003 325i), all original parts. Is it normal that it broke again so soon?

Is it the way I drive or just my luck?
Appreciate any feedbacks.

Kelly
Over the years I have owned over 20 bmws and never had a pump failure.

The sound you are hearing at full lock as well as in the cold sounds to be the fluid running past the pressure release valve and nothing to worry about as long as you have proper fluid levels.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms