Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 01-13-2012, 09:59 PM
Sandesh Sandesh is offline
Registered User
Location: Bahrain
 
Join Date: Dec 2009
Posts: 12
Mein Auto: 525i
Check Engine - BMW 525i 2004

This morning, when I started my BMW (525i - 2004) the check engine sign came on!! The car also started vibrating. The exhaust seems intermittent. The exact message is - Engine Check. Drive moderately. engine High load may damage catalytic convertor. Drive at reduced engine load. Any ideas what this might be? I am afraid to drive the car. Mechanic says it is fine to drive it to his garage - approx 10 kms...

The shaking is quite pronounced. any suggestions?
Edit/Delete Message
Reply With Quote
Ads by Google
  #2  
Old 01-14-2012, 05:46 AM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,287
Mein Auto: '06 530i, '07 C280, ML320
Without reading diagnostic codes, it'll just be a guessing game.

I'd guess one of the ignition coil is the culprit.
Reply With Quote
  #3  
Old 01-14-2012, 09:33 PM
hawk2100n's Avatar
hawk2100n hawk2100n is offline
Save the Males!
Location: South Cacalacky
 
Join Date: Sep 2005
Posts: 1,368
Mein Auto: Der Reihensechszylinder
Could be a Vanos problem where the valve timing is stuck all the way advanced or retarded. Gives the exact symptoms, rough idle, difficult starting, high fuel consumption, possible smokey exhaust. A quick scan from the loaner code reader at a local parts store will give you a much better idea of what is going on.
__________________
'06 530iA, iDrive/Nav
Dead: 92 325i
Dead: 97 528i
Reply With Quote
  #4  
Old 01-15-2012, 10:16 PM
Sandesh Sandesh is offline
Registered User
Location: Bahrain
 
Join Date: Dec 2009
Posts: 12
Mein Auto: 525i
Just got confirmation - It was a bad coil. Replaced, now all is well... Thanks
Reply With Quote
  #5  
Old 01-16-2012, 06:03 AM
pcy pcy is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Sep 2011
Posts: 1,287
Mein Auto: '06 530i, '07 C280, ML320
Glad to hear your car is fixed.
Thanks for posting the update.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms