Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #26  
Old 02-22-2012, 03:06 PM
vtq vtq is offline
Registered User
Location: ...
 
Join Date: Feb 2012
Posts: 5
Mein Auto: BMW E65
When you mean the "SOS call system failure" then I had to put "nicht_aktiv" to BACKUP_LOUDSPEAKER and BACKUP_ANTENNA in the TCU module but that's quite vehicle/equipment dependet and you should first check the modules error log to see where it leads you.
Reply With Quote
  #27  
Old 02-22-2012, 03:16 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: CALIFORNIA L.A.
 
Join Date: Jul 2009
Posts: 2,856
Mein Auto: 745LI
Thanks .
Ya I planned on checking the errors . He stated he was having the same issues as you , so I assumed he checked his errors

Sent from my GT-I9100 using Bimmer App
__________________

If you need a Custom 2014 DVD Navigation Map
East or West for your E65 E66 PM me for price .
Or if you Need an AUX Plug for your car hit me up
Reply With Quote
  #28  
Old 03-10-2012, 03:33 AM
hafrse hafrse is offline
Registered User
Location: Sweden
 
Join Date: Jul 2004
Posts: 10
Mein Auto: BMW
Quote:
Originally Posted by AceFX View Post
Hoping to do the Bluetooth by this weekend. Just been a bit busy with the wife in hospital
Hi,

Great to know that the new TCU worked for you!
I have a 745i 2004 with the FL MMI, navi03 and FL mp3 changer mounted , all working well together after coding with NCSExpert.
I have professional TCU with twin telephone sets fitted as original equipment, I bought a used TCU with bluetooth from a FL 2006 but did not get it work! the MOST bus goes to error state and no modules will work on that buss after I insert the FL TCU module.
I also tried other TCU modules with different Part number from FL models, same problem.
what is the part number of the TCU you used ? any other advice?

many thanks for any help!

kind regards,
George
Reply With Quote
  #29  
Old 07-14-2012, 06:57 AM
AceFX AceFX is offline
Banned
Location: I come from the land down under
 
Join Date: Mar 2011
Posts: 1,381
Mein Auto: BMW 760Li BMW X5 4.8iS
To do this facelift without having to do coding, you need to change the MMI, the ASK and the ANT Tuner....then everything works automatically....
Reply With Quote
  #30  
Old 07-14-2012, 12:36 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: CALIFORNIA L.A.
 
Join Date: Jul 2009
Posts: 2,856
Mein Auto: 745LI
Sorry Ace , but there is still some coding that needs to be done even if you change all those units at the same time .
We changed all those units in Rookies car & we still had to code it
To get everything working . Before we coded
There was no = Navigation options , phone options , Logic 7 options , Cd Changer options .
You can ask Rookie yourself . He was sitting in the car at the time & I showed him
All those options were missing from his screen . We also changed the VIN # to match his car on all the newer parts we changed.


FYI ( I assume the car he got the parts from did not have the options that we had to add , but I don't know that for a fact )
I just know we had to add them when we
Put everything in Rookies car .

Sent from my GT-N7000 using Bimmer App
__________________

If you need a Custom 2014 DVD Navigation Map
East or West for your E65 E66 PM me for price .
Or if you Need an AUX Plug for your car hit me up

Last edited by PAPER; 07-14-2012 at 12:44 PM.
Reply With Quote
  #31  
Old 07-14-2012, 04:21 PM
AceFX AceFX is offline
Banned
Location: I come from the land down under
 
Join Date: Mar 2011
Posts: 1,381
Mein Auto: BMW 760Li BMW X5 4.8iS
Hi PAPER, I know what you mean and I agree. What I was meaning, and I don't think I explained it properly, is that to get all the mode and AM/FM buttons on the ASK unit to work without coding those functions only....by replacing the ANT with the facelift ANT, it will talk to those three buttons without coding..... Sorry for my lazy reply before, it was late and I was tired.... Nearly finished the Comfort Access....
Reply With Quote
  #32  
Old 07-14-2012, 04:29 PM
PAPER's Avatar
PAPER PAPER is online now
CRISP & CLEAN
Location: CALIFORNIA L.A.
 
Join Date: Jul 2009
Posts: 2,856
Mein Auto: 745LI
Quote:
Originally Posted by AceFX View Post
Hi PAPER, I know what you mean and I agree. What I was meaning, and I don't think I explained it properly, is that to get all the mode and AM/FM buttons on the ASK unit to work without coding those functions only....by replacing the ANT with the facelift ANT, it will talk to those three buttons without coding..... Sorry for my lazy reply before, it was late and I was tired.... Nearly finished the Comfort Access....


Sent from my GT-N7000 using Bimmer App
__________________

If you need a Custom 2014 DVD Navigation Map
East or West for your E65 E66 PM me for price .
Or if you Need an AUX Plug for your car hit me up
Reply With Quote
  #33  
Old 02-20-2013, 05:26 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Sorry to bump this thread!

I just replaced my 2002 ASK unit with one from a 2007 car (my original unit was dying and I got the new one pretty cheap).

As this thread states, I cant use the radio anymore!

I am proficient with the BMW tools and can code / program, but I wanted to check exactly what it was you had to do to get the antenna working.

I took it that I need to Flash the new ask with the old ask software using winKFP?

I didn't realize you could flash the "wrong" firmware, or did ace just mean coding? (I'm aware ace is no longer here for various reasons but through maybe someone else could help).

At the bottom of the facelift trace file there is a coding option for the tuner module type, but I don't know what I could change that too, as my old ask didn't have that option in the trace.
Reply With Quote
  #34  
Old 02-20-2013, 06:10 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
UPDATE:

Fixed it.

The CODING option is called INST_ID_TUNER. It was at the bottom of my trace and set to tuner_ab_0905

After translating i found that ab means "from", and in NCS dummy there is also an option tuner_vor_0905.

vor means "before".

The 0905 must be the time stamp for when they updated the tuner!

Long story short, set INST_ID_TUNER to tuner_vor_0905 and it works fine

Just need to get the time now
Reply With Quote
  #35  
Old 03-11-2013, 04:24 PM
riff riff is online now
Registered User
Location: Portsmouth
 
Join Date: Oct 2009
Posts: 43
Mein Auto: 745i
Quote:
Originally Posted by Piers1989 View Post
UPDATE:

Fixed it.

The CODING option is called INST_ID_TUNER. It was at the bottom of my trace and set to tuner_ab_0905

After translating i found that ab means "from", and in NCS dummy there is also an option tuner_vor_0905.

vor means "before".

The 0905 must be the time stamp for when they updated the tuner!

Long story short, set INST_ID_TUNER to tuner_vor_0905 and it works fine

Just need to get the time now
Hi Piers1989

Same issue - cd works, radio finds stations but no sound.

I am updating my 2002 745i with an ASK unit from a 2006 760 (I also have replaced my MMI with an MMI from a 2008 760i). Unfortunately I got the following error:

Fehler in CABD! Siehe CABI.ERR und ERROR.LOG!

COAPI-1043: error during processing CBD-file ASK.C05

which I take to mean that NCSexpert just does not understand "tuner_vor_0905" to be a valid field identifier. I also tried "tuner_nach_0905" and that didn't work. I am using EDIABAS 6.4.3 and NCSExpert Coapi V3.5.1 B. NCS Dummy also did not like it and threw an error.

Are you using different versions? Did you encounter any errors that you had to work around to get valid results? etc.....

Thanks for your comments.

Riff
Reply With Quote
  #36  
Old 03-12-2013, 06:15 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Quote:
Originally Posted by riff View Post
Hi Piers1989

Same issue - cd works, radio finds stations but no sound.

I am updating my 2002 745i with an ASK unit from a 2006 760 (I also have replaced my MMI with an MMI from a 2008 760i). Unfortunately I got the following error:

Fehler in CABD! Siehe CABI.ERR und ERROR.LOG!

COAPI-1043: error during processing CBD-file ASK.C05

which I take to mean that NCSexpert just does not understand "tuner_vor_0905" to be a valid field identifier. I also tried "tuner_nach_0905" and that didn't work. I am using EDIABAS 6.4.3 and NCSExpert Coapi V3.5.1 B. NCS Dummy also did not like it and threw an error.

Are you using different versions? Did you encounter any errors that you had to work around to get valid results? etc.....

Thanks for your comments.

Riff
Maybe the ASK you got doesnt have that option on its software?

If you look at the options for the 5 different ASK files in NCS dummy I think only 1 or 2 of them actually had tuner_vor_0905 as an option.

Its possible that after a certain point they would never be fitting a new radio into the car with the old tuner and updated the software to remove a needless option.

If that's the case I would say you're going to have to either replace the antenna, or have a risky attempt at flashing the software from the model that had the option to use tuner_vor_0905, which (if it will let you flash) will quite possibly brick the module if the hardware was changed at all.

I'll download my trace when I get home from work and post it to you for reference.

Last edited by Piers1989; 03-12-2013 at 06:18 AM.
Reply With Quote
  #37  
Old 03-14-2013, 08:34 AM
riff riff is online now
Registered User
Location: Portsmouth
 
Join Date: Oct 2009
Posts: 43
Mein Auto: 745i
Did you get a chance to look at those files? I am thinking of putting my pre-facelift ASK back in place (the radio worked with that combination) and see if the AUX will work with the 2008 MMI and the pre-facelift ASK. I don't really need the buttons on the FL ASK and I don't see what else I get as a benefit with the upgrade - I am assuming that since the PF ASK has a port for the AUX that it will work.
Reply With Quote
  #38  
Old 03-14-2013, 09:07 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Hi, sorry I forgot about the trace! I'll have a look after work tonight (if I remember!). I do not think the pre facelift ASK can do AUX, but I'm not certain there.
Reply With Quote
  #39  
Old 03-14-2013, 11:23 AM
sirstopher's Avatar
sirstopher sirstopher is offline
bimmerfest Supporting Member
Location: Ok.
 
Join Date: Aug 2011
Posts: 1,102
Mein Auto: POS Honda
Quote:
Originally Posted by riff View Post
Did you get a chance to look at those files? I am thinking of putting my pre-facelift ASK back in place (the radio worked with that combination) and see if the AUX will work with the 2008 MMI and the pre-facelift ASK. I don't really need the buttons on the FL ASK and I don't see what else I get as a benefit with the upgrade - I am assuming that since the PF ASK has a port for the AUX that it will work.
Nope, you need an ask from 06/06 on to get the aux to work. The plug is there but will not program
__________________
97 740i e38 - SOLD
02 745i e65
03 Montero Limited

Reply With Quote
  #40  
Old 03-14-2013, 12:25 PM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Here is my working trace file.

I do NOT have Logic 7, but the car the ASK came from did, I changed some of the other lines to get the subs working for my HIFI system.

Quote:
BAUREIHE
e65
CODIERUNG_ERFOLGT
codierung_erfolgt
DELAY_LINES_BLOCK_1
e65
DELAY_LINES_BLOCK_2
e65
ABSENK_ENTERTAINMENT_PDC
standard
VOLUME_DELTA_PDC_ENTER
standard
KOMBINAT_AUDIO_SOURCES_1
e65
rr1
KOMBINAT_AUDIO_SOURCES_2
e65
rr1
GAE_BLOCK_1
e65
rr1
GAE_BLOCK_2
e65
rr1
GAE_BLOCK_3
e65
rr1
GAE_BLOCK_4
e65
rr1
GAE_BLOCK_5
e65
rr1
GAE_BLOCK_6
e65
rr1
GAE_BLOCK_7
e65
rr1
GAE_BLOCK_8
e65
rr1
GAE_BLOCK_9
e65
rr1
GAE_BLOCK_10
e65
rr1
GAE_BLOCK_11
e65
rr1
GAE_BLOCK_12
e65
rr1
GAE_BLOCK_13
e65
rr1
PRIO_AUDIO_SOURCES_1
e65
rr1
MUTE_ON_CRASH
aktiv
VOLUME_AUDIO_1
e65
rr1
VOLUME_MINIMUM_NAVI
standard
VOLUME_MINIMUM_TM
standard
VOLUME_MINIMUM_TEL
standard
min1
VOLUME_MAXIMUM_ON
standard
VOLUME_KLANG_1
e65_hifi
AUDIO_ENTERTAIN_1
e65
LOUDNESS
aktiv
KEY_MEMORY_ASK
aktiv
GAL_MAIN
aktiv
GAL_DEFAULT
e65
rr1
GAE_MAIN
aktiv
COMPRESSOR
e65
MUTEMIX_TIME
e65
TIMEOUT_INT
e65
rr1
VOLUME_DELTA_NAVI_ENTER
wert_top_hifi
VOLUME_DELTA_TEL_ENTER
standard
VOLUME_MINIMUM_SPEECH
standard
KLANG_OFFSET
standard
VOLUME_PDC
standard
DAUER
e65
rr1
ABSTAND_IDENT_PRIO
e65
rr1
NACHLAUF_INT
e65
rr1
VOLUME_SECUR_1
e65
rr1
KOMBINAT_AUDIO_SOURCES_3
e65
rr1
AUDIO_ENTERTAIN_2
rr1
VOLUME_MAXIMUM_TEL
everest_ec_sa633
us
FILTER_FZG_BLOCK_1
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_2
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_3
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_4
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_5
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_6
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_7
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_8
e65_top_hifi
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_9
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_10
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_11
e65_top_hifi_ab0509
FILTER_FZG_BLOCK_12
e65_stereo
e65_stereo_neu
e65_hifi
e65_top_hifi
e65_stereo_neu_ab0509
e65_hifi_ab0509
e65_top_hifi_ab0509
rr1
rr2
CROSS_OVER_1
e65_top_hifi
e65_top_hifi_ab0509
CROSS_OVER_2
e65_top_hifi
e65_top_hifi_ab0509
CROSS_OVER_3
e65_top_hifi
e65_top_hifi_ab0509
PHASE_BLOCK
e65_hifi
e65_top_hifi
e65_top_hifi_ab0509
START_V_CC
e65_top_hifi
START_V_CD
e65_top_hifi
OUTPUT_GAIN_SYSTEM
e65_hifi
AUDIO_SYSTEM
e65_hifi
OUTPUT_SIGNAL_TABLE_1
e65_ll_top_hifi
e65_rl_top_hifi
OUTPUT_SIGNAL_TABLE_2
e65_ll
e65_rl
OUTPUT_SIGNAL_TABLE_3
e65_ll
e65_rl
rr1_ll
rr1_rl
OUTPUT_SIGNAL_TABLE_4
e65_ll
e65_rl
rr1_ll
rr1_rl
GADR_MAIN
aktiv
GAL_INTER_1A
e65
rr1
GAL_INTER_1B
e65
rr1
GAL_INTER_2A
e65
rr1
GAL_INTER_2B
e65
rr1
GAL_INTER_3A
e65
rr1
GAL_INTER_3B
e65
rr1
GAL_INTER_4A
e65
rr1
GAL_INTER_4B
e65
rr1
GAL_INTER_5A
e65
rr1
GAL_INTER_5B
e65
rr1
GAL_INTER_6A
e65
rr1
GAL_INTER_6B
e65
rr1
KHI_OFFSET_ENABLE
nicht_aktiv
KHI_OFFSET_VALUE
e65_stereo
e65_hifi
e65_top_hifi
rr1
VOLUME_MAXIMUM_RING_TEL
standard
rr1
VOLUME_MINIMUM_RING_TEL
standard
rr1
ENABLE_TEL_RING
tel_ring_on
GAL_INTER_CODIERUNG
enable_rom
INST_ID_TUNER
tuner_vor_0905
Reply With Quote
  #41  
Old 03-14-2013, 01:30 PM
riff riff is online now
Registered User
Location: Portsmouth
 
Join Date: Oct 2009
Posts: 43
Mein Auto: 745i
Thanks. I'll pull the ASK out and check the date. It's a 2006 but probably too early - back to ebay.......

Thanks for the TRC.
Reply With Quote
  #42  
Old 03-14-2013, 05:14 PM
BSOD BSOD is offline
Registered User
Location: Uk
 
Join Date: Jul 2012
Posts: 75
Mein Auto: 2006 BMW 650i Sport
Quote:
Originally Posted by Piers1989 View Post
UPDATE:

Fixed it.

The CODING option is called INST_ID_TUNER. It was at the bottom of my trace and set to tuner_ab_0905

After translating i found that ab means "from", and in NCS dummy there is also an option tuner_vor_0905.

vor means "before".

The 0905 must be the time stamp for when they updated the tuner!

Long story short, set INST_ID_TUNER to tuner_vor_0905 and it works fine

Just need to get the time now
Nice one, just replaced my 03 ASK with one from a 2008 , have installed a BMW DAB module and voila I have retrofitted DAB (there's another thread on this i'll update in a min) Did notice the radio no longer works. Set ASK back to defaults with a blank ncsexpert .man file using the .C05 file which didn't make a difference. You just saved me trawling through and working out what the differences were between the original unit trace file and the new one. Remember seeing that ab0905 set as well and wondered what it meant.

Will sort that out in the morning.
Thanks again
Reply With Quote
  #43  
Old 03-14-2013, 05:39 PM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Quote:
Originally Posted by BSOD View Post
Nice one, just replaced my 03 ASK with one from a 2008 , have installed a BMW DAB module and voila I have retrofitted DAB (there's another thread on this i'll update in a min) Did notice the radio no longer works. Set ASK back to defaults with a blank ncsexpert .man file using the .C05 file which didn't make a difference. You just saved me trawling through and working out what the differences were between the original unit trace file and the new one. Remember seeing that ab0905 set as well and wondered what it meant.

Will sort that out in the morning.
Thanks again
Just a question - are you saying you retrofitted DAB to your pre facelift car just by replacing the ASK and adding a DAB module? Or have you replaced the MMI too?

Where do you connect the Ariel?
Reply With Quote
  #44  
Old 03-14-2013, 06:21 PM
BSOD BSOD is offline
Registered User
Location: Uk
 
Join Date: Jul 2012
Posts: 75
Mein Auto: 2006 BMW 650i Sport
Have just updated other thread.

You need to replace MMI and ASK with facelift versions and fit a DAB module, job done, have a look through the e65 e66 forum to find my lengthy blurb.

Reply With Quote
  #45  
Old 03-15-2013, 08:08 AM
riff riff is online now
Registered User
Location: Portsmouth
 
Join Date: Oct 2009
Posts: 43
Mein Auto: 745i
Apologies for the ignorance - what is a DAB?
Reply With Quote
  #46  
Old 03-15-2013, 08:15 AM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Quote:
Originally Posted by BSOD View Post
Have just updated other thread.

You need to replace MMI and ASK with facelift versions and fit a DAB module, job done, have a look through the e65 e66 forum to find my lengthy blurb.

I see your update, very useful, mind if I pm you for a little extra info about your car?
Reply With Quote
  #47  
Old 03-15-2013, 01:25 PM
BSOD BSOD is offline
Registered User
Location: Uk
 
Join Date: Jul 2012
Posts: 75
Mein Auto: 2006 BMW 650i Sport
No probs Piers

@Riff DAB is Digital Audio Broadcast its like digital TV but for radio. Its been around for since 1995. It means you get a crystal clear digital signal with high quality instead of an FM/AM radio. It also means you can tune into stations that are not available via analogue signal like Radio 1xtra and also get stations that are only on AM like radio 5 live without the crackles.

Last edited by BSOD; 03-15-2013 at 01:38 PM.
Reply With Quote
  #48  
Old 03-22-2013, 10:56 AM
JimmyW's Avatar
JimmyW JimmyW is offline
Officially Welcomed to the 'Fest
Location: Michigan
 
Join Date: Jan 2011
Posts: 165
Mein Auto: 2007 BMW X5;2002 BMW 745i
I want to post a warning to everyone doing this that if you have the cassette player ASK instead of the CD version you may have to switch. It appears the coding in the newer FL no longer supports "tape" as one of the options under "ASK_LAUFWERK". You can only put in cd or minidisk. If you try to code the option with tape it will give you a COAPI-1043 error. If anyone has tape player working with the new MMI please correct me!
Reply With Quote
  #49  
Old 03-22-2013, 11:00 AM
BSOD BSOD is offline
Registered User
Location: Uk
 
Join Date: Jul 2012
Posts: 75
Mein Auto: 2006 BMW 650i Sport
What is a TAPE player ?

Reply With Quote
  #50  
Old 03-22-2013, 12:31 PM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
Who would want a cassette deck??
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms