Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-08-2012, 12:17 AM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
E85 Z4 on the fritz

Today I started up my car as usual but something unusual happened. My seat belt chime went off but never turned off. No dash lights were on everthing was normal except for that annoying chime. I pulled the car over. Turned it off, step out and locked the doors, the chime was still going! I ended up unplugging my negative thermal and had a coffee. Reconnected the terminal and all was well. Has anyone experienced this before? Here's a short vid of what it was doing.

Reply With Quote
Ads by Google
  #2  
Old 02-08-2012, 07:30 AM
Wheaton2010 Wheaton2010 is offline
Have Fun... Life is short
Location: Wheaton, IL
 
Join Date: Mar 2011
Posts: 82
Mein Auto: 2006 BMW Z4 3.0si
Anything get wet? Do the seat belts work now? Any other issues?
Reply With Quote
  #3  
Old 02-08-2012, 07:53 AM
Wheaton2010 Wheaton2010 is offline
Have Fun... Life is short
Location: Wheaton, IL
 
Join Date: Mar 2011
Posts: 82
Mein Auto: 2006 BMW Z4 3.0si
Also, when is the last time you replaced your battery. Even if the battery life indicator is showing OK (green) these are not perfect. You can have all kinds of weird problems if the battery needs to be replaced. This happened to me on my Toyota Highlander. Four lights would intermittently light up on my dashboard showing all kinds of problems. They they would mysteriously go off. I thought it was because I moved some wires. Next couple of weeks it was fine. Then back on again. One of the Toyota discussion boards told me about replacing the battery. All OK now. Hope this helps.
Reply With Quote
  #4  
Old 02-08-2012, 08:42 AM
imz4n's Avatar
imz4n imz4n is offline
Z ENTHUSIAST
Location: OC, CA.
 
Join Date: Oct 2005
Posts: 692
Mein Auto: 06 3.0 si Z4R
You might want to try removing the neg terminal from the battery for 15 minutes then reconnect. This has cleared issues for me in the past, known as power reset.
__________________
Reply With Quote
  #5  
Old 02-08-2012, 08:58 AM
Cvaria's Avatar
Cvaria Cvaria is offline
Officially Welcomed to the 'Fest
Location: Tallahassee, Florida
 
Join Date: Sep 2011
Posts: 376
Mein Auto: 2003 Z4 ; 2002 Wrangler;
that beeping sound had you angry and driving like an animal... in the rain, DTC light flashing, with one hand on the wheel.

should have been blasting Judas Priest - "Breaking The Law"



Breaking the law
Breaking the law
Breaking the law
__________________
I like my 2003 Z4 2.5i... but love my smelly old 2002 Wrangler SE and evil 2007 HD Sportster 883/1200 conv!


Last edited by Cvaria; 02-08-2012 at 09:01 AM.
Reply With Quote
  #6  
Old 02-08-2012, 03:02 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Lmao. Yea I was pretty annoyed. My friend works at BMW and looked into it for me. Looks like its a fault in the software in the earlier models. BMW will fix the problem upon customer complaint. I'm complaining.
Reply With Quote
  #7  
Old 02-08-2012, 03:11 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
Never mind the last post I miss read the letter. BMW is not covering it. The problem is fixed with a new updated instrument cluster. That doesn't sound cheap.
Reply With Quote
  #8  
Old 02-08-2012, 03:32 PM
jmanscotch's Avatar
jmanscotch jmanscotch is offline
is a Texan
Location: Colorado Springs
 
Join Date: Aug 2009
Posts: 1,282
Mein Auto: '09 135 - 6MT - TwinTs
I'd just find a way to cut the wires to the speaker then!

....boy, I was annoyed within the first 10 seconds of the video, hehe!
__________________
-Jake

2004 325Ci - 5MT - SOLD & MISSED
2003 3.0 Z4 - 6MT - SOLD
1967 1602 - 4MT - STOLEN
2008 328XI - 6MT - EX STOLE
1995 325i - RUSTED AWAY
2009 135i - COPS IMPOUNDING
Reply With Quote
  #9  
Old 02-08-2012, 03:34 PM
Droptop85 Droptop85 is offline
Officially Welcomed to the 'Fest
Location: Fresno
 
Join Date: Oct 2011
Posts: 351
Mein Auto: 03 Z4 3.0i
I can't even watch the video. I Drove the car like that for 15 minutes. I need therapy now.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms