Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E23 / E32 (1977 - 1994)

7 Series - E23 / E32 (1977 - 1994)

View Poll Results: How much Does your 735i mean to you?
Its the biggest dissappointment! piece of S***! 1 20.00%
It's just another car.. 0 0%
I Enjoy it for the most part! 1 20.00%
I LOVE MY BIMMER! Always Satisfied & Happy With It!! 3 60.00%
Multiple Choice Poll. Voters: 5. You may not vote on this poll

Reply
 
Thread Tools Display Modes
  #1  
Old 02-11-2012, 12:34 AM
Jessecook92 Jessecook92 is offline
Registered User
Location: Modesto, CA
 
Join Date: Nov 2011
Posts: 14
Mein Auto: 1992 BMW 735i
Talking My E32's Mysterious Shifting Problem Solved!!!!

So I bought my 92 735i about 4 months ago from someone who nearly ruined the car! Its been sitting for two years. Since day 1 it has never shifted right. I knew he replaced the transmission but had no idea what suprises I was in for. Since the purchase I fixed my valve cover leak, just needed a gasket, cleaned and fixed my switches, climate control, shifter, fuses and speed sensors.
During all of this I found there to be a sparkplug wire just hanging out, not even connected, A corroded speed sensor, Leaking radiator hose, Multiple ground wires dissconnected!!!!! And a plug that goes into the fuel injector wire harness rail dissconnected. (since then my oil pressure sensor warning went off). Since fixing all of this, my rough idle has mostly cleared up, I think I just need a good tune up for it to be perfected.
I think someone had it out for the PO because Its been shot at with a bb gun, has been keyed, and some one cut the ABS wire on the driver side back wheel, (they probably thought it was a brake line!) Lol.

NOW THE TRANSMISSION!!

The transmisson never wanted to shift out of 1st gear, would just rev to 5k rpm then roughly shift and squeel into 2nd. I had no idea what was going on or how to fix it! I tried changing the filter and fluid, speed sensor in the transmission, cleaned the contacts on the wires, and just over all inspected every wire I could.
I noticed the Trans had been rebuilt and looks in amazing shape for a pick n pull Trans!! It just didnt shift! Stumped I decided to pull a new valve body from pick n pull. When I dropped the current one out I noticed the prongs on my current valve body connector had 8 pins and 5 solenoids and the one I pulled had 7 pins and 4 solenoids. so I put my original back in thinking it was the wrong one even though it came from the same 4hp22. So I grabbed another valve body since I couldnt find another 8 pin valve body I grabbed another one with 7 pins. Luckily I still have the original trans that the PO gave me and noticed it had 7 pins, 4 solenoids too! Then I did some research about the TCM n how other people (not just BMW) had the same exact problems with the high revs and no shifting n how when they replaced the TCM it solved the problem. Well I grabbed a new TCM from pick n pull and it changed nothing, my hopes were shot at that point.

BTW: The TCM was located in the kick panel on the passenger side behind the speaker, in a little hole up above where it is not visible, at first. will post pics tomorrow.

So I researched some more about one thing that my car never showed, the trans program warning. Matter of fact I had no codes at all! I remembered that when in failsafe the shift lock solenoid doesnt activate. Today I pulled off the wood trim over the shifter then pulled my car out and bam! it didnt activate! So as my last resort I swapped the valve bodys, reused the fluid by straining it with a paint filter cleaned her up and started the car. Look down and the solenoid activated!
I then took it for a drive and then bam! It shifted!! The revs were around 3k and was hessitant at first but after driving around it got smoother. I just need to drive it more then change the fluid and filter again and put in some good fluid instead of the cheap stuff.

Moral of the story is The TCM couldnt communicate with the transmission because it had one too many solenoids, 8 pin connector causing it to go into failsafe with no warning on the dash or anything. the shift lock was the only clue. So the PO either pulled this trans from a different model, or who ever got it rebuilt did something completely wrong or something. When you swap a transmission or valve body you have to make sure they are exactly the same as whats already in your car!!

This is my first car, not only that, it is the first car I have ever worked on. So as a beginner if I can figure that complicated problem out on my own and fix it, so can anybody!!
Now all I need is to replace my catalytic converter, spark plugs and wires, and change all fluids and filters!!

Im lucky to have bought the car for $500, and to get tons of new filters, rotars, hoses, trim, switches, handles, electronics, breaks, drivelines, two sets of rims, etc. HAha his loss, my gain!!
Please pitch in on similar problems, stories, pics, etc! I wanna hear from all you 735i owners!!
Attached Thumbnails
Click image for larger version

Name:	14.jpg
Views:	287
Size:	67.5 KB
ID:	311830   Click image for larger version

Name:	15.jpg
Views:	258
Size:	85.1 KB
ID:	311831   Click image for larger version

Name:	57.jpg
Views:	283
Size:	86.5 KB
ID:	311832   Click image for larger version

Name:	27.jpg
Views:	350
Size:	136.1 KB
ID:	311833   Click image for larger version

Name:	13.jpg
Views:	293
Size:	102.5 KB
ID:	311834  

Reply With Quote
Advertisement
Reply

Bookmarks

Tags
4hp22, 735i, failsafe, shifting problems, transmission problems


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E23 / E32 (1977 - 1994)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms