Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)

E63 / E64 6 Series (2003 - 2013)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-02-2012, 08:29 AM
Jtodd4594 Jtodd4594 is offline
Registered User
Location: Greenville sc
 
Join Date: Mar 2012
Posts: 6
Mein Auto: Bmw 650
Sos n radio no sound

Got SOS / symbol n radio want come on
Reply With Quote
Advertisement
  #2  
Old 03-02-2012, 07:13 PM
BADRIDES's Avatar
BADRIDES BADRIDES is offline
Officially Welcomed to the 'Fest
Location: NYC TO ORLANDO
 
Join Date: Apr 2009
Posts: 654
Mein Auto: BMW 650 I SPORT PKG
convertable ?
__________________
[/SIGPIC]BMW M6 Cabrio Alpine White with Indy Red interior
Mods
Rpi scoops and filters with block off plates
Vorsteiner carbon lip,Deck wing and Rear diffuser
Black mantle grill
H&R 15mm spacers for front and back Go Wide
Painted front and rear brake calibers with M logo
Exhuast rensinator delete with cats removed



Lexus L 460 touring package Family car
Svt mustang Cobra racer
Lexus Gs Modded Daily
Bmw 650i Cabrio Sold
Saleen s 351
Reply With Quote
  #3  
Old 03-02-2012, 07:21 PM
Jtodd4594 Jtodd4594 is offline
Registered User
Location: Greenville sc
 
Join Date: Mar 2012
Posts: 6
Mein Auto: Bmw 650
Yes
Reply With Quote
  #4  
Old 03-03-2012, 08:29 AM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,499
Mein Auto: '04 M3 / '06 650i Cab
Probably water in the trunk then. The drain tubes in the soft top storage compartment get plugged, then water leaks into the trunk (driver's side) which is where the amps and navigation electronics are located.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #5  
Old 03-03-2012, 06:17 PM
BADRIDES's Avatar
BADRIDES BADRIDES is offline
Officially Welcomed to the 'Fest
Location: NYC TO ORLANDO
 
Join Date: Apr 2009
Posts: 654
Mein Auto: BMW 650 I SPORT PKG
Quote:
Originally Posted by Yorgi View Post
Probably water in the trunk then. The drain tubes in the soft top storage compartment get plugged, then water leaks into the trunk (driver's side) which is where the amps and navigation electronics are located.
Yep thats what happend to me I hope you under warranty its a big job that why I asked if its a vert Yorgi your the man
__________________
[/SIGPIC]BMW M6 Cabrio Alpine White with Indy Red interior
Mods
Rpi scoops and filters with block off plates
Vorsteiner carbon lip,Deck wing and Rear diffuser
Black mantle grill
H&R 15mm spacers for front and back Go Wide
Painted front and rear brake calibers with M logo
Exhuast rensinator delete with cats removed



Lexus L 460 touring package Family car
Svt mustang Cobra racer
Lexus Gs Modded Daily
Bmw 650i Cabrio Sold
Saleen s 351
Reply With Quote
  #6  
Old 03-04-2012, 05:09 AM
BEBosworth BEBosworth is offline
Officially Welcomed to the 'Fest
Location: Northern New Jersey
 
Join Date: Nov 2011
Posts: 120
Mein Auto: 2008 650i Convertible
Where are these drain holes located by the way? I like being able to listen to the radio and will keep an eye on them if I know where to look.
Reply With Quote
  #7  
Old 03-04-2012, 07:39 AM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,499
Mein Auto: '04 M3 / '06 650i Cab
Quote:
Originally Posted by BEBosworth View Post
Where are these drain holes located by the way? I like being able to listen to the radio and will keep an eye on them if I know where to look.
There are 4 of them in the compartment where the top is stored. To get to the holes start opening the top and let go of the open-top button when the compartment lid is fully open. (release the button before the roof itself starts opening) You will see rubber grommets on the floor of the compartment, one in each corner. Use a thick weed whacker plastic cord to clean out the drain tubes.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #8  
Old 03-04-2012, 08:30 AM
EmM HoLLa's Avatar
EmM HoLLa EmM HoLLa is offline
Officially Welcomed to the 'Fest
Location: Northern, VA
 
Join Date: Jun 2010
Posts: 545
Mein Auto: BMW
I had this job done last year... If it is water damage BMW Warranty will not cover it... Your insurance company may cover it though if there was a big Storm that came through around the time you made the claim. I usually have them Unclog the drains when I get an oil change. They use an air compressor to blow the soot out of the clogs..
__________________
2012 650i
Reply With Quote
  #9  
Old 03-04-2012, 09:13 AM
BADRIDES's Avatar
BADRIDES BADRIDES is offline
Officially Welcomed to the 'Fest
Location: NYC TO ORLANDO
 
Join Date: Apr 2009
Posts: 654
Mein Auto: BMW 650 I SPORT PKG
Mine was under warranty over 10,000 worth of work not a dollart to me Hd radio ,Hardrive
__________________
[/SIGPIC]BMW M6 Cabrio Alpine White with Indy Red interior
Mods
Rpi scoops and filters with block off plates
Vorsteiner carbon lip,Deck wing and Rear diffuser
Black mantle grill
H&R 15mm spacers for front and back Go Wide
Painted front and rear brake calibers with M logo
Exhuast rensinator delete with cats removed



Lexus L 460 touring package Family car
Svt mustang Cobra racer
Lexus Gs Modded Daily
Bmw 650i Cabrio Sold
Saleen s 351
Reply With Quote
  #10  
Old 03-04-2012, 11:13 AM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,807
Mein Auto: 2006 650 convertible!!!
I have seen reports on the M board of folks getting this fix under warranty for M6 convertibles...same issue occurs.

But I believe this is all moot point, jtodd had posted before that he had to pay to fix a Camshaft Sensor failure, hence we can make the assumption he is not under warranty.

If the back amp rack was compromised because of water damage and it is on his dime then he would be best to try and replace the components himself. Others who have had this issue simply purchased the new component (amp/hd module/satellite module) used from a BMW parts salvager.
Reply With Quote
  #11  
Old 03-04-2012, 11:37 AM
EmM HoLLa's Avatar
EmM HoLLa EmM HoLLa is offline
Officially Welcomed to the 'Fest
Location: Northern, VA
 
Join Date: Jun 2010
Posts: 545
Mein Auto: BMW
Bad Rides 10k?.. Sheesh! Mine wasn't that much I think it was about 3k. My hard drive was fine though....

Mark you're right if you have to pay a Salvager is the best bet...
__________________
2012 650i
Reply With Quote
  #12  
Old 03-15-2012, 06:48 PM
BEBosworth BEBosworth is offline
Officially Welcomed to the 'Fest
Location: Northern New Jersey
 
Join Date: Nov 2011
Posts: 120
Mein Auto: 2008 650i Convertible
Quote:
Originally Posted by Yorgi View Post
There are 4 of them in the compartment where the top is stored. To get to the holes start opening the top and let go of the open-top button when the compartment lid is fully open. (release the button before the roof itself starts opening) You will see rubber grommets on the floor of the compartment, one in each corner. Use a thick weed whacker plastic cord to clean out the drain tubes.
Thanks Yorgi. Decided to clean them this past weekend and the two rear ones were clogged. Not that easy to clean as the drain does not run straight down, so you kind of have to snake a flexible piece through them (I used a long zip tie). You prevented me from having a large electrical mess.
Reply With Quote
  #13  
Old 04-08-2012, 11:22 AM
jaycomb jaycomb is offline
Registered User
Location: Montreal
 
Join Date: Apr 2012
Posts: 9
Mein Auto: 645ci convertible
Quote:
Originally Posted by Yorgi View Post
There are 4 of them in the compartment where the top is stored. To get to the holes start opening the top and let go of the open-top button when the compartment lid is fully open. (release the button before the roof itself starts opening) You will see rubber grommets on the floor of the compartment, one in each corner. Use a thick weed whacker plastic cord to clean out the drain tubes.
hi Yorgi, i have the same problem my cd changer and player works fine but there is no sound at all and on top of that my screen keeps running on and off every 10 mins how do i fix that without paying millions lol??? That will help me a lot cause man i can't drive without music! i have a 645ci convertible 04
Reply With Quote
  #14  
Old 04-09-2012, 06:29 PM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,499
Mein Auto: '04 M3 / '06 650i Cab
Sounds like it might be a loose connection or a power issue.

Do you get any sound from the radio? Does the CD player in the head unit work?

I would also try a head unit reboot. Hold down both eject buttons and press on the power-on/volume knob at the same time. If that does not work I would also pull the NAV DVD and see if that stops the screen from re-booting.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #15  
Old 04-10-2012, 01:48 PM
jaycomb jaycomb is offline
Registered User
Location: Montreal
 
Join Date: Apr 2012
Posts: 9
Mein Auto: 645ci convertible
I dont get any sound but everything works the radio is running but no sound i did the head reboot still no sound do u think the battery can cause that? Thanx Yorgi
Removed nav dvd still the same thing! Whatever advise it will much appreciate. Thanks

Last edited by jaycomb; 04-10-2012 at 02:49 PM.
Reply With Quote
  #16  
Old 04-11-2012, 03:18 AM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,499
Mein Auto: '04 M3 / '06 650i Cab
If it wasn't for your screen issues my guess would be the amp is dead - located in the trunk and a very common failure item.

When you say the screen goes off every 10 minutes, is it a flicker off/on, or does it seem like the system is re-booting every 10 min with the screen going blank for 30+ seconds then returning.

If you have NAVI running when the screen goes off, is NAVI still running after the screen resets or are you back at the iDrive menu?
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #17  
Old 04-11-2012, 04:55 AM
jaycomb jaycomb is offline
Registered User
Location: Montreal
 
Join Date: Apr 2012
Posts: 9
Mein Auto: 645ci convertible
It seems like the system is rebooting cause it goes off completely it comes back with the big BMW writing and then goes to idrive menu and lets say if i was using the nav it will ask me if i want to continue with adress i put for direction you know what i mean...

Last edited by jaycomb; 04-11-2012 at 05:04 AM.
Reply With Quote
  #18  
Old 04-11-2012, 06:52 PM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,499
Mein Auto: '04 M3 / '06 650i Cab
Do you get the SOS message mentioned in a few of the above posts?

Do you use a bluetooth phone to pair with the car? I would try disabling bluetooth on your phone for starters.

Then I would check your battery and alternator.

If none of that works I would try for a software upgrade at the dealer.

If you still have issues at this point it will probably start getting expensive. You likely have a bad TCU, amp, power module or even the CCC itself.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #19  
Old 04-15-2012, 08:01 AM
jaycomb jaycomb is offline
Registered User
Location: Montreal
 
Join Date: Apr 2012
Posts: 9
Mein Auto: 645ci convertible
I went to verified my battery and they said it's dead i need a new battery you think this is the problem? Do you think the battery can cause that? im going to check for the SOS message but i don't remember seing something like that!
Reply With Quote
  #20  
Old 04-15-2012, 09:40 AM
Yorgi's Avatar
Yorgi Yorgi is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,499
Mein Auto: '04 M3 / '06 650i Cab
Quote:
Originally Posted by jaycomb View Post
I went to verified my battery and they said it's dead i need a new battery you think this is the problem? Do you think the battery can cause that? im going to check for the SOS message but i don't remember seing something like that!
There is only one way to find out...replace the battery.

A weak battery can cause a multitude of errors, everything from transmission errors to engine misfire errors. Since you need a battery just do that for starters and see what happens.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater

Reply With Quote
  #21  
Old 04-16-2012, 12:02 PM
jaycomb jaycomb is offline
Registered User
Location: Montreal
 
Join Date: Apr 2012
Posts: 9
Mein Auto: 645ci convertible
Yorgi thanks man i will definetely do that! I hope it will come back when i replace it!
Reply With Quote
  #22  
Old 04-29-2012, 06:37 AM
BMW645 Germany BMW645 Germany is offline
Registered User
Location: Mobile, AL
 
Join Date: Oct 2011
Posts: 32
Mein Auto: BMW645 CI
I had the same ****, BMW 645ci 2005.
Before the rain was the car for a week at BMW, they don't care at all for a known problem.
Cost me until now $400, the amplifier is dead and the Sat Radio.
Exchange the amplifier with a used one from Ebay and the Sat Radio dont need in germany.
Cleaned up all hoses, pulled them out and found that the gap at the end where the water shall go out is to tight, there is a plastic cover to protect the body of the car.
After increasing the gap water can run out like crazy now.
When the Sat Radio is dead then the signals which going over the Sat Radio via light cable don't reach the CD Player in front.
So it looks the radio is working fine, but no sound plus because of the dead amplifier and Sat Radio is also dead so no communication to the CD Player.
If you don't want use the Sat Radio you can make a loop for the Light Cable to get the signals routed to the CD player.
So far I heard from BMW, it is not absolute necessary to register the new amplifier, means you don't depend on BMW, they want charge me $1200 just for the amp.
For the Sat Radio I did not ask.

By the way, In my case the change the alternator, because they saw some faults from there, but how shat the amp work under water?
The alternator was not the reason for the mess, they also want change the battery, but this was changed and registered already.
Unfortunately they only work according what there diagnose computer say, if it say. No repair shop just a exchange shop.
Reply With Quote
  #23  
Old 05-01-2012, 06:19 AM
BMW645 Germany BMW645 Germany is offline
Registered User
Location: Mobile, AL
 
Join Date: Oct 2011
Posts: 32
Mein Auto: BMW645 CI
Update for my amp,
it work again. Yesterday I cleaned the Platine and gave it a chance and suddenly I had sound again, even the Sat Radio did recover :-)
Reply With Quote
  #24  
Old 05-17-2012, 08:45 PM
jaycomb jaycomb is offline
Registered User
Location: Montreal
 
Join Date: Apr 2012
Posts: 9
Mein Auto: 645ci convertible
So tell me how do i do that? Mine the cd player everything works fine but no sound at all nothing i can see and hear the cd player running but nothing's coming out! it's driving me crazy so whatever you did tell me i will defenitely going to try that! Cause the other day i tried to open the trunk on the driver side there's i think it's the amp it is silver with a lot of wires? gimme the step bro please i need that music back on man!
Reply With Quote
  #25  
Old 05-19-2012, 12:18 PM
BMW645 Germany BMW645 Germany is offline
Registered User
Location: Mobile, AL
 
Join Date: Oct 2011
Posts: 32
Mein Auto: BMW645 CI
Hello jaycomb,

at first take the cable off from the amp and if u have the sat radio too. To remove the big cable connection from the amp u must move it sidewards , hold it and move the connection to the right, automatically the connector will get free. Sometimes it is a little tight, then on the left side behind is an other cable, be careful with it it is a fibre cable, just unclip it. From the sat radio is all easy to open.
Now open all bolds there to get it out, between the car housing and the amp are also 2 bolds, a little bit difficult to get.
When u have all out open the amp the are clips at the side and bolds which u have to remove, now u can see the effect which water have on el. parts.

Open carefully the clip for the fibre cable and take it out, remove the el. board to have also access to the bottom of the board

Buy a brush, small and soft Plastic, Copper,Steel, u get it in a auto zone, or other, carefully brush the board with the copper brush to remove all stain on the surface, of course it have to been drain out first, use a hair dryer.
After that brush it also carefully with the soft steel brush, and later with the plastic brush to clean it,
Check all again that it is clean also bottom.

Go to radio shack and buy thermal compound for the Transistors there inside, remove the old white thermal compound and apply a small amount.
When all is clean and no stain remain, bring all together again, make sure that u have brought the fibre cable complete into its position, or it will not work, it happen to me at first, it must be full in.

The same with the sat radio

When all is done, connect it in your car test wise again, the lights should go on, and when u are lucky u will hear first time the annoying sound for ur belt again.

If not, don't give up to early, then give it again more time to dry out, I had to wait 1 week, then all was ok again.

If also this fail, I have a working amp here in spare for sell, BMW want have $1500 for the job.

By the way, even all is disconnected u still can drive, will will not get additional warnings.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms