Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)

F10 / F11 (2011 - Current)
The new chapter in the highly successful story of the BMW 5 Series Sedan (F10) and wagon (F11)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-09-2012, 07:20 AM
yogi799 yogi799 is offline
Officially Welcomed to the 'Fest
Location: Ontario
 
Join Date: Sep 2008
Posts: 1,231
Mein Auto: '11 535i, '99 328i retd
Service due since 70000kms?

OK, time to tackle this one. I've been subconsciously ignoring this message on startup hoping to see a more accurate one, but it's time to attack it... Why on Earth am I seeing that since the 2nd month I own the car? It's been 7 months now (car has 12000 kms) and it stubbornly shows 70000kms overdue (that's like 40k miles!).

Just a glitch and service visit needed? Anyone seen that before?
__________________
2011 535i F10 delivered
1999 328i E46 retired



LOGMYMPG sponsored by ckvideo.ca
Reply With Quote
Advertisement
  #2  
Old 03-09-2012, 07:41 AM
bobblehead bobblehead is offline
Officially Welcomed to the 'Fest
Location: Toronto, On, Canada
 
Join Date: Feb 2011
Posts: 458
Mein Auto: v8 tt
Looks like a simple reset should do. It's just an inconvenient waste of your time.

My rear brakes say I am due for service in 4000km. Car has 25,000km. Stopped by @ my dealer last weekend and the tech quickly used a flashlight and saw I have at least 50% or 15,000km or so left on the pads. Tech says come back when the service indicator is on and he will reset. I said I can reset myself. Take less than 1 minute.

Last edited by bobblehead; 03-09-2012 at 07:43 AM.
Reply With Quote
  #3  
Old 03-09-2012, 08:10 AM
Raddius Raddius is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: May 2009
Posts: 274
Mein Auto: 2011 528i
The vehicle status calculations on this latest version of iDrive are suspect to me. Mine shows my rear breaks need replacing in 10k miles while the fronts are good for another 33k miles. I don't recall wildly off estimates with my E60 (I think it was v2 of iDrive?).
__________________
2013 335i Sport Line | Glacier Silver Metallic w/Black Leatherette & red highlight, Sport auto trans, Navi, Rear camera & PDC
2011 528i | Alpine White w/Black interior w/Anthracite, Sport Package, Premium Package 1, USB/iPod, Park Distance Control, Navigation
2008 535i (Buyback)
Reply With Quote
  #4  
Old 03-09-2012, 08:17 AM
Sophisto Sophisto is offline
Officially Welcomed to the 'Fest
Location: Netherlands
 
Join Date: Jan 2011
Posts: 2,069
Mein Auto: F11 530D
looks someone forgot something at delivery.
Normally first service is for oil, standard just under 30K kilometers.
After that is rear break pads, the indication on that one seems not acurate as well.

By pushing the odo button for 10 secs you enter in the menu.
Resetting is rather easy.
Do a search you will find more explicit instructions easily on this forum.
Reply With Quote
  #5  
Old 03-09-2012, 08:21 AM
yogi799 yogi799 is offline
Officially Welcomed to the 'Fest
Location: Ontario
 
Join Date: Sep 2008
Posts: 1,231
Mein Auto: '11 535i, '99 328i retd
I did a quick search on resetting and did not immediately find anything. Anyone kind enough to post the procedure? Thanks
Reply With Quote
  #6  
Old 03-09-2012, 08:28 AM
Sophisto Sophisto is offline
Officially Welcomed to the 'Fest
Location: Netherlands
 
Join Date: Jan 2011
Posts: 2,069
Mein Auto: F11 530D
google F10 service reset, you'll find something on youtube.

Last edited by Sophisto; 03-09-2012 at 08:31 AM.
Reply With Quote
  #7  
Old 03-09-2012, 08:38 AM
Alpine300ZHP Alpine300ZHP is offline
East Coast Commuter
Location: South Florida
 
Join Date: Jan 2007
Posts: 2,972
Mein Auto: 435/x3 35
Quote:
Originally Posted by Sophisto View Post
google F10 service reset, you'll find something on youtube.
Does not work. Can you provide step by step instructions? Is it the same as the steps for the E60? Nevermind...found it. Yes...much like the E60.
__________________
~ 14 435 (with MPPK) My daily beater
~ 14 x3 35i Hers
- Previous BMW's - Way too many to list here (17)

Last edited by Alpine300ZHP; 03-09-2012 at 08:40 AM.
Reply With Quote
  #8  
Old 03-09-2012, 08:41 AM
bobblehead bobblehead is offline
Officially Welcomed to the 'Fest
Location: Toronto, On, Canada
 
Join Date: Feb 2011
Posts: 458
Mein Auto: v8 tt
Reply With Quote
  #9  
Old 03-09-2012, 09:26 AM
Sophisto Sophisto is offline
Officially Welcomed to the 'Fest
Location: Netherlands
 
Join Date: Jan 2011
Posts: 2,069
Mein Auto: F11 530D
Bbb, thnx for putting in the link, I tried that too, but mine did not work, guess I need to RTFM on this forum.
Reply With Quote
  #10  
Old 03-09-2012, 09:45 AM
bobblehead bobblehead is offline
Officially Welcomed to the 'Fest
Location: Toronto, On, Canada
 
Join Date: Feb 2011
Posts: 458
Mein Auto: v8 tt
The important part is .. press & hold the left side of the button. If you press the middle part of the button, it will have a different menu.
Reply With Quote
  #11  
Old 03-09-2012, 06:53 PM
yogi799 yogi799 is offline
Officially Welcomed to the 'Fest
Location: Ontario
 
Join Date: Sep 2008
Posts: 1,231
Mein Auto: '11 535i, '99 328i retd
OK, it worked great... I think this 70000kms overdue on my oil change may have had something to do with my own oil change following break-in.... Some sensor got confused probably.
__________________
2011 535i F10 delivered
1999 328i E46 retired



LOGMYMPG sponsored by ckvideo.ca
Reply With Quote
  #12  
Old 03-12-2012, 12:12 PM
ruok303 ruok303 is offline
Registered User
Location: Fairhope, AL
 
Join Date: Aug 2010
Posts: 51
Mein Auto: 2012 528i
I was getting a "maintenance overdue" message right around 3,000 miles. I was pretty sure it only needed to be reset and I called my dealer. The SC recommended I bring the car in. Discovered the problem was a faulty oil condition sensor, which required replacement.
__________________
2012 528i Black Sapphire Metallic
2006 525xi Titanium (retired 10/11)
2003 325i Monaco Blue(retired)
1999 Z3 Graphite (retired)
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms