Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Classic Bimmers

Classic Bimmers
Discussions pertaining to vintage and classic BMW models here...

Reply
 
Thread Tools Display Modes
  #1  
Old 03-13-2012, 02:04 AM
brian edward fl brian edward fl is offline
Registered User
Location: thailand
 
Join Date: Oct 2011
Posts: 5
Mein Auto: 1970 bmw 2000
Thumbs down 1970 bmw 2000

--------------------------------------------------------------------------------

Hi guys thought I would try this thread for advice or be pointed in the right direction.

Recently my young mechanic suggested I fit discs to the rear of my classic BMW Ok all good except after a few brake applications pressure seems to build up and the pedal becomes fairly hard it seems the calipers (must be the rear as front fitted standard) are not returning the brake fluid and brakes not jamming but certainly on a little. It makes me think of the old days where a blocked compensating port gave you a hard pedal.

Would appreciate any thoughts or directions.
Reply With Quote
Ads by Google
  #2  
Old 05-21-2012, 01:22 AM
6point3 6point3 is offline
Registered User
Location: L. A.
 
Join Date: May 2012
Posts: 3
Mein Auto: 1967 BMW
Just a quick thought:
On a Mercedes in the mid 60ies, they also had the front disk, rear drum arrangement.

HOWEVER: Calipers and brake drum wheel cylinders I believe work on different tensions/pressure, and different release current (??).
There is a valve that regulates the rear pressure in the system, located (on the Mercedes's) under the rear center of the car before the lines splice to right or left.
I would bet something similar is built into the BMW system and this young Mechanic of yours, may have not have removed this, therefore the ...........

Just a wild guess.

It would be nice to hear back , right here, if that or any other cause was found and the issue was resolved !!

Last edited by 6point3; 05-21-2012 at 01:25 AM. Reason: not mid 20ies, but mid 60ies....lol
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Classic Bimmers
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms