Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-15-2012, 09:53 PM
Bowensamuel Bowensamuel is offline
Officially Welcomed to the 'Fest
Location: Tonopay ,nv
 
Join Date: May 2011
Posts: 106
Mein Auto: 1989 325is
1987 535is auto trans problem.

Ok so I just bought this car from a guy down the street and it has been sitting for 3-5 years. I drive it everyday and it is just shifting outrageously. It likes to shift down and put itself in like a netruel gear and rev up, then I finds a gear a slams into it turning my tranny light on. Then some times when I exit off the freeway it likes to start shaking as if all the tires are flat. The car seems to run fine but sometimes it will shut off randomly when in gear. Now I've heard abt these impulse senders being a problem but also abt tps and the angel sensor. Now does anyone know where I can start? I've already changed the tranny fluid an put additives into it, but it doesn't seem to fix this issue.
Reply With Quote
Ads by Google
  #2  
Old 03-15-2012, 09:55 PM
Bowensamuel Bowensamuel is offline
Officially Welcomed to the 'Fest
Location: Tonopay ,nv
 
Join Date: May 2011
Posts: 106
Mein Auto: 1989 325is
Oh and here is a photo of it as well I spent a $1000 on it.
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByBimmerApp1331873629.950446.jpg
Views:	76
Size:	119.4 KB
ID:	316817  
Reply With Quote
  #3  
Old 03-16-2012, 02:30 PM
catso's Avatar
catso catso is online now
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,904
Mein Auto: 2000 323i, 1988 528e
Identify specifically which trans version you have and do a search. Start by buying a Bentley manual and diagnosing the engine performance. Engine vacuum leaks, idle problems, electrical issues, etc. all affect the transmission's operation. Car's that sit for long periods without operating can develop lots of little problems that require alot of time and effort in diagnosing and correcting. Formulate a plan.
__________________
Don't be gormless; get some gorm!
![/I][/FONT]
Reply With Quote
  #4  
Old 03-16-2012, 04:40 PM
Bowensamuel Bowensamuel is offline
Officially Welcomed to the 'Fest
Location: Tonopay ,nv
 
Join Date: May 2011
Posts: 106
Mein Auto: 1989 325is
Well my tach don't work could this be part of the issue?
Reply With Quote
  #5  
Old 03-16-2012, 05:00 PM
catso's Avatar
catso catso is online now
catso
Location: Chicago
 
Join Date: Dec 2009
Posts: 2,904
Mein Auto: 2000 323i, 1988 528e
Quote:
Originally Posted by Bowensamuel View Post
Well my tach don't work could this be part of the issue?
Could be SI board related. Check the number 5 and 6 fuses. Research E28 SI boards on www.mye28.com and you'll find out lots of info. Electrical deterioration is probably this car's biggest enemy.
__________________
Don't be gormless; get some gorm!
![/I][/FONT]
Reply With Quote
  #6  
Old 03-16-2012, 05:13 PM
Bowensamuel Bowensamuel is offline
Officially Welcomed to the 'Fest
Location: Tonopay ,nv
 
Join Date: May 2011
Posts: 106
Mein Auto: 1989 325is
Thanks man u helped alot.
Reply With Quote
  #7  
Old 04-01-2012, 08:51 AM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
Did you replace the filter when you change the fluid? You probably have the 4HP-22EH tranny. As catso said get a Bentley as this is the maintenance bible for these cars. When I got my car almost nothing on the gauge cluster worked. I got a replacement board and that fixed all the issues. You seem to have a lot of electrical issues typical to car that has been sitting for a while. I would start by removing all fuses, cleaning all the tabs and re-installing new fuses. Also, clean all battery connections and the engine ground points (there are several).
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 08:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms