Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Reply
 
Thread Tools Display Modes
  #1  
Old 04-07-2012, 01:02 PM
mattprune mattprune is offline
Registered User
Location: Gloucester
 
Join Date: Apr 2012
Posts: 7
Mein Auto: Z4m
Z4 Handling issues after wheel alignment

Hey All,

Just done 32k miles in the past year with my Z4 and had to have the back tyres replaced and due to the one tyre having significant wear on the inside it was recommended to have wheel alignment which I had no objection to.

However, getting straight onto the motorway to cover a couple of thousand miles, the car suddenly seemed quite boat like, feeling very top heavy, the steering uber sensitive, and when turning suddenly seemed to have some body roll.

Trying to work out the problem, I thought it could either be the wrong back tyres, the wheel alignment is out or the suspension has gone out....I checked the paperwork and BMW apparantly also check the height of the suspension when they do their wheel alignment.

Trying to get BMW to redo the work in Blackpool they refused as it was done in Cotswolds BMW and I have been advised I will have to pay another 160.00 for the work

Any idea what the cause is as it does not feel safe to drive, and I do not want to pay another 160.00 for nothing. Times like this makes me hate BMW and my normally much loved Z4!

Help pls!!!
Reply With Quote
Advertisement
  #2  
Old 04-07-2012, 01:39 PM
Glen E Glen E is offline
Retired
Location: SE USA
 
Join Date: Jan 2011
Posts: 334
Mein Auto: 12 z & 09 Accord Coupe
why hate BMW? They did not mis -align it, the dealer did, but not the mfr....it's out of alignment. it takes skill to work the new machines...I saw a alignment last week where they used the wrong program model year and it aligned wrong. Go back and demand they make it right. See the general manager. Why was not a test drive done when Cotswold finished with it?
__________________
'12 Z4 2.8 - Melbourne Red
'09 Accord Coupe LX-S - Red/black

RTOM.....
Reply With Quote
  #3  
Old 04-07-2012, 02:32 PM
mattprune mattprune is offline
Registered User
Location: Gloucester
 
Join Date: Apr 2012
Posts: 7
Mein Auto: Z4m
I hate BMW for charging so much and for having independant dealerships :-)

Interesting comments re using the wrong model year, as I had described to BMW Blackpool that the car suddenly felt like I was driving the old Z4 (After owning the previous model for a number of years) which used to tramline.......could that be the cause of the problem: the car has been mis-programmed...?!

Have you dealt with customer services in the UK? Clearly not.....customers are never right here, and the managers normally don't care. But will try my luck on Tuesday!
Reply With Quote
  #4  
Old 04-07-2012, 02:39 PM
Glen E Glen E is offline
Retired
Location: SE USA
 
Join Date: Jan 2011
Posts: 334
Mein Auto: 12 z & 09 Accord Coupe
Quote:
Originally Posted by mattprune View Post
I hate BMW for charging so much and for having independant dealerships :-)
Yeah I hate democracy too....LOL





alignment machines require you to input the model, type and year - it then aligns per the specs in the program. It is Just like using excel, word or anything else. It requires the right input to work...

just a possibility...could be shoddy work too....

again....Why was not a test drive done when Cotswold finished with it?
__________________
'12 Z4 2.8 - Melbourne Red
'09 Accord Coupe LX-S - Red/black

RTOM.....
Reply With Quote
  #5  
Old 04-07-2012, 02:49 PM
mattprune mattprune is offline
Registered User
Location: Gloucester
 
Join Date: Apr 2012
Posts: 7
Mein Auto: Z4m
Haha!

So, how much manual work is done if there are so many machines involved? What was wrong with the old fashioned way of alignment? :-)

Have you see how to do the alignment, I want to know how it works @ BMW....

Yes, well, you would have thought a Test drive was done. But the handling issue is more noticable at speeds of 70 mph and apparantly they cannot test over 70 mph....but I think that is just an excuse as I see how those "FFF'ers" drive :-)

The funny thing is that when I took the car to Blackpool they refused to drive the car as they were concerned with Health and Safety....and they therefore could only put the car back through realignment. Oh, the mind boggles with the way things are done in this country.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 08:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms