Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)

X3 F25 (2011 - current)
The latest X3 brings some added style and some new features to the BMW SUV family. Talk about the new F25 now!

Reply
 
Thread Tools Display Modes
  #51  
Old 08-03-2012, 02:50 PM
boostedX5SAV boostedX5SAV is offline
Officially Welcomed to the 'Fest
Location: New York City
 
Join Date: Jan 2012
Posts: 271
Mein Auto: 2012 X5 35i
Does the update apply to the X5 as well? Also, for those who got the update, did your dealer give you a loaner car when you left the car there overnight?

Also, for those that had their cars coded, did the update reset the coding?

Thanks.
__________________

Last edited by boostedX5SAV; 08-03-2012 at 02:51 PM.
Reply With Quote
  #52  
Old 08-04-2012, 05:26 AM
Doug in NC Doug in NC is offline
Officially Welcomed to the 'Fest
Location: Rutherfordton NC
 
Join Date: Jun 2005
Posts: 151
Mein Auto: 2011 x3 28i
Quote:
Originally Posted by boostedX5SAV View Post
Also, for those who got the update, did your dealer give you a loaner car when you left the car there overnight?

Thanks.
I waited on mine, the update took about 3 hours. Longer than I expected being at the dealer but not too bad of a wait.
Reply With Quote
  #53  
Old 08-04-2012, 09:02 AM
TJPark01's Avatar
TJPark01 TJPark01 is offline
Officially Welcomed to the 'Fest
Location: Hollywood, CA
 
Join Date: Oct 2009
Posts: 3,162
Mein Auto: E92 335i
Quote:
Originally Posted by boostedX5SAV View Post
Does the update apply to the X5 as well? Also, for those who got the update, did your dealer give you a loaner car when you left the car there overnight?
Yes, certain models
E70, E71 with the N55 engine and 8HP45 transmission from 4/1/2010 to 1/16/2012

Quote:
Originally Posted by Doug in NC View Post
I waited on mine, the update took about 3 hours. Longer than I expected being at the dealer but not too bad of a wait.
It should have taken much longer than that, typically a whole day and potentially an overnight stay. look on your receipt to see if the SIB 24 02 12 is listed on the repair.
__________________
Reply With Quote
  #54  
Old 08-04-2012, 01:28 PM
Want the Thrill Want the Thrill is offline
Officially Welcomed to the 'Fest
Location: Michigan
 
Join Date: Sep 2009
Posts: 1,011
Mein Auto: 2011 X3 35i
I dropped mine off at 8:30 am and it was done at 4:30pm. They gave me a loaner while it was being done. My dealer will give you a loaner anytime they do work as long as you tell them you need one when setting up the appointment.
Reply With Quote
  #55  
Old 08-04-2012, 05:38 PM
Doug in NC Doug in NC is offline
Officially Welcomed to the 'Fest
Location: Rutherfordton NC
 
Join Date: Jun 2005
Posts: 151
Mein Auto: 2011 x3 28i
Quote:
Originally Posted by TJPark01 View Post

It should have taken much longer than that, typically a whole day and potentially an overnight stay. look on your receipt to see if the SIB 24 02 12 is listed on the repair.
Yes, that's what is on the receipt. I spoke with the service rep several times during the process. There is no doubt they did the update. Not to mention many of my personal setting that were reset to factory default.

Last edited by Doug in NC; 08-04-2012 at 05:41 PM.
Reply With Quote
  #56  
Old 09-04-2012, 02:27 PM
jiggabelly jiggabelly is offline
Registered User
Location: Atlanta
 
Join Date: Sep 2012
Posts: 3
Mein Auto: 2012 X3 35i
I wish it were that easy...

I bought my 2012 X3 April 21, 2012. I noticed the throttle lag during the test ride but bought the car anyway. Loved it, except for the lag.

It kept on stalling and I took it in for a fix in May 2012...they kept it 2 days and gave it back. Nothing changed. Almost got hit once when it would not respond to the throttle...it just sat there for a couple of seconds. Not good.

I took it back in July and they said they had a "fix" and applied the "fix". It seemed better for a while...then it came back after a few weeks. While waiting to turn left across oncoming traffic I heard and saw Jeep coming at me from behind at speed and was going to hit me so I floored it...nothing...it just sat there and then crawled a few feet. The jeep turned at the last minute.

That's when I told the dealer that I loved the car but do not want to die in it. The shop foreman and I spent time driving around and finally the car replicated the issue. He said it is the engine not the transmission...ok fine...fix it. They have had it 14 days not fixed it yet...they ordered a new DME to see if that does it...if it doesn't we're gonna fight.
Reply With Quote
  #57  
Old 11-06-2014, 01:04 PM
ill740 ill740 is offline
Registered User
Location: florida
 
Join Date: Nov 2014
Posts: 1
Mein Auto: 2001 BMW 740IL
Hey guys ....I've been a lurker for years and always benefitted from the wealth of knowledge and experience on this forum....so I'd like to say that first....secondly I'm having the same problem with my 2001 740il....it will start and run fine for a while then all of a sudden boom... engine failsafe across my pixels and the delayed throttle response sometimes it will surge with no throttle response at all do you think this software update is needed to correct the problem ? I've changed everything but the dme ...it's been to shops and no one has been able to accurately diagnose the problem...do you all think that bad engine mounts could be the culprit ? I haven't quite isolated the set of the conditions that cause this problem but it seems like it does it only when the car is at n.o.t. and has gone through its cooling cycle a time or two ...hard accel. Hitting a really big bump ....any insight would sure help
Reply With Quote
  #58  
Old 11-06-2014, 05:00 PM
Want the Thrill Want the Thrill is offline
Officially Welcomed to the 'Fest
Location: Michigan
 
Join Date: Sep 2009
Posts: 1,011
Mein Auto: 2011 X3 35i
ill740 you will probably get a better response to your question over on the 7 series board and for your model year here: http://www.bimmerfest.com/forums/forumdisplay.php?f=156

This is the current generation X3 forum which is greatly different from the 2001 7 series. Hope that helps!
Reply With Quote
  #59  
Old 11-07-2014, 11:36 AM
lbjgh's Avatar
lbjgh lbjgh is online now
Officially Welcomed to the 'Fest
Location: North of Toronto
 
Join Date: Dec 2011
Posts: 753
Mein Auto: 2013 X3 M-Sport
It sounds like throttle delay was a fairly common problem on BMW's prior to 2013.

I actually found this third party option when researching the problem before I bought a MY2013 X3... the 2012 N52 X3 induced whiplash when I test drove it.

check out this product: http://www.bimmian.com/65/SPB/


Quote:
Originally Posted by ill740 View Post
Hey guys ....I've been a lurker for years and always benefitted from the wealth of knowledge and experience on this forum....so I'd like to say that first....secondly I'm having the same problem with my 2001 740il....it will start and run fine for a while then all of a sudden boom... engine failsafe across my pixels and the delayed throttle response sometimes it will surge with no throttle response at all do you think this software update is needed to correct the problem ? I've changed everything but the dme ...it's been to shops and no one has been able to accurately diagnose the problem...do you all think that bad engine mounts could be the culprit ? I haven't quite isolated the set of the conditions that cause this problem but it seems like it does it only when the car is at n.o.t. and has gone through its cooling cycle a time or two ...hard accel. Hitting a really big bump ....any insight would sure help

Last edited by lbjgh; 11-07-2014 at 11:37 AM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms