Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-02-2015, 08:13 AM
Blueeagle Blueeagle is offline
Registered User
 
Join Date: Jan 2015
Posts: 2
Mein Auto:
85 325e odometer and gas gauge issue

I was wondering what could be the issue with my odometer and gas gauge in my 325e. If anyone has any knowledge of the possibilities of this issue I would be greatful for the information and any info on how to repair it.
Reply With Quote
Advertisement
  #2  
Old 02-02-2015, 08:19 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 7,350
Mein Auto: 2012 hypermotard 796
being that its the odometer and gas, you could have broken odo gears (common), bad SI batteries (also common), bad connection, and/or bad fuel level sensor.

my first move would be to pull the cluster and check the si batteries. and while its out, you could look to see if you have broken teeth in the odo.
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
  #3  
Old 02-02-2015, 09:18 PM
Blueeagle Blueeagle is offline
Registered User
 
Join Date: Jan 2015
Posts: 2
Mein Auto:
Quote:
Originally Posted by downhiller View Post
being that its the odometer and gas, you could have broken odo gears (common), bad SI batteries (also common), bad connection, and/or bad fuel level sensor.

my first move would be to pull the cluster and check the si batteries. and while its out, you could look to see if you have broken teeth in the odo.
Thanks a ton. I'll do that.
Reply With Quote
  #4  
Old 02-03-2015, 02:09 AM
cmac2012's Avatar
cmac2012 cmac2012 is offline
Renaissance Dude
Location: Berkeley, CA
 
Join Date: Nov 2005
Posts: 4,911
Mein Auto: Two 1987 325i, 418K, 211K
This thread has a lot of info about the odometer gears. A sponsor here - garagistic- makes first rate replacement gears for $15 to $30 depending on which of the two manufacturers of instrument clusters is in your car. A garagistic rep can be contacted - info on the thread:

http://www.bimmerfest.com/forums/sho...light=odometer
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms