Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series DIY

7 Series DIY
Do It Yourself forum dedicated for 7 Series BMW Owners

Reply
 
Thread Tools Display Modes
  #1  
Old 05-17-2014, 11:04 AM
rhaprds rhaprds is offline
rhaprds
Location: CT
 
Join Date: May 2014
Posts: 1
Mein Auto: 740iL 635csi
New Speedometor stopped working?

I replaced my instrument cluster about 3,000 miles ago at a dealership$$$ and it has been working well. The other day I got my emissions checked and it passed fine BUT now the Speedometer and vacuum gauge that give you estimated gas mileage have stopped working. Of course the emissions guys say it was just a coincidence and to take it back to the dealer. Has anyone ever heard of this happening?
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series DIY
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 01:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms