Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series DIY

7 Series DIY
Do It Yourself forum dedicated for 7 Series BMW Owners

Reply
 
Thread Tools Display Modes
  #1  
Old 06-09-2015, 03:41 PM
joshgeake joshgeake is offline
Registered User
Location: Bristol, UK
 
Join Date: Jun 2015
Posts: 3
Mein Auto: e65 730i
Smile e65 wih dead ABS, SIM/SGM all fixed via DIY :)

Dear all,

I just wanted to share my thanks with all those that contribute here as well as those that have contribted in the past to BMW Land before its sad current state.

Basically, my dash started giving me parking brake faults and ever so often display "Brake/Drive fault" with all the ABS associated warning lights going off. INPA showed a bunch of errors including speed sensors, ABS communication faults and plenty of "unknown errors". BMW gave a hilarious quote for a replacement ABS module (well over 1500 plus labour and VAT because they apparently couldn't supply it without the pump) so I sent off the old module for repair (240 max, no fix no fee).

The result was that it was unrepairable but clearly faulty. So, I went on eBay and bought a brand new Bosch ABS module from a company in Berlin for 280 delivered. It arrived within 4 days. I fitted it, cleared all faults and that was that, no coding required. Well over 1000 saved.

Secondly, I had an airbag light and restraint light on with "Safety System" warnings going off. Plenty of bongs when I put the key in the ignition! The code was 93F9 and a suitably vague "undervoltage" fault. Nothing online really suggested a fix. BMW suggested a new SIM/SGM module but didn't guarantee it fixing anything...for 1000 plus VAT.

So, I bought a second hand SIM/SGM on eBay for 100, fitted it (once I worked out it was behind the dash) and then started to read through all the gumph online about coding. Basically, you just need to fit it, flash it using WINFKP with your car's VIN and the latest SP-Daten, use NCS-Expert to reset it to default factory settings and then use Tool32 to re-sync the time.

It took a while to work it all out but I did both of the above jobs on a sunny Sunday afternoon. Cleared the faults and they've not come back. No warning lights at all. BMW quoted 2500+ and I spent less than 400! Everything now works and I'm a very happy chappie!

Now, the faulty passive go on the driver's side and the weird climate control faults to go...
Reply With Quote
Advertisement
Reply

Bookmarks

Tags
93f9, abs, sgm, sim


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series DIY
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 10:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms