Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)

E63 / E64 6 Series (2003 - 2013)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-07-2012, 11:34 AM
Kevin Bowen Kevin Bowen is offline
Registered User
Location: Tampa
 
Join Date: Sep 2011
Posts: 39
Mein Auto: 2001 E39 & 2005 645 ci
2005 645ci Transmission error / limp mode

hi guys. I just picked up a used 2005 645ci a week ago. A red gear sybol appeared along with the message "Transmission Malfunction car will have reduced accelleration, take to dealer blah balh...". It stays in one gear and tachs at 4,000 at 60 MPH.

It did this twice before. I turned off the car , waited a minute, then re-started and it was fine. Now it stays theat way I described above. Even after sitting overnight. This seems to be a common issue from what I have researched. The car only has 38k miles. Recommendations please.
P.S. I removed the heat shields and no leaks.
Reply With Quote
Advertisement
  #2  
Old 05-07-2012, 12:15 PM
645/333's Avatar
645/333 645/333 is offline
Michael
Location: uk
 
Join Date: Jun 2010
Posts: 1,160
Mein Auto: Black Sapphire BMW Z4 3L
You could try a transmission reset, never hurts to try!!! Once done it will relearn your driving style and may remove the fault!!
__________________

Does my bum look good in this !
Reply With Quote
  #3  
Old 05-07-2012, 01:32 PM
Kevin Bowen Kevin Bowen is offline
Registered User
Location: Tampa
 
Join Date: Sep 2011
Posts: 39
Mein Auto: 2001 E39 & 2005 645 ci
Transmission re-set

How do I do the Transmission reset. No SMG auto Tranny.
Reply With Quote
  #4  
Old 05-07-2012, 02:12 PM
645/333's Avatar
645/333 645/333 is offline
Michael
Location: uk
 
Join Date: Jun 2010
Posts: 1,160
Mein Auto: Black Sapphire BMW Z4 3L
Hi there are some threads, but basically depress your accelerator to the floor and switch on the ignition but don't start the engine, hold this position for a min 45sec and then start the engine. this is how you reset it....... it really does work!!!!!!
__________________

Does my bum look good in this !
Reply With Quote
  #5  
Old 05-08-2012, 06:47 AM
Kevin Bowen Kevin Bowen is offline
Registered User
Location: Tampa
 
Join Date: Sep 2011
Posts: 39
Mein Auto: 2001 E39 & 2005 645 ci
Thanks Michael. That cleared the code. I will let you know how long it lasts.
Reply With Quote
  #6  
Old 05-08-2012, 07:04 AM
rutdarmz rutdarmz is offline
Registered User
Location: Upstate SC
 
Join Date: May 2012
Posts: 2
Mein Auto: 2004 BMW 525i
Quote:
Originally Posted by 645/333 View Post
Hi there are some threads, but basically depress your accelerator to the floor and switch on the ignition but don't start the engine, hold this position for a min 45sec and then start the engine. this is how you reset it....... it really does work!!!!!!
wow thats huge information!! The problem I have is the same as his but my car when I need to really get some where quick usually can't keep uo and before you know it I'm in limp mode. Car should be able to handle what I'm asking from it. It really isn't that much. I've had to switch to the Toyaota and ley me wife drive the BMW. To me thats kinda sad.
Reply With Quote
  #7  
Old 05-08-2012, 11:33 AM
Kevin Bowen Kevin Bowen is offline
Registered User
Location: Tampa
 
Join Date: Sep 2011
Posts: 39
Mein Auto: 2001 E39 & 2005 645 ci
Yes mine happened while accellerating onto an entrance ramp. No t pushing it at all, just moderate accelleration.
Reply With Quote
  #8  
Old 05-08-2012, 11:34 AM
Kevin Bowen Kevin Bowen is offline
Registered User
Location: Tampa
 
Join Date: Sep 2011
Posts: 39
Mein Auto: 2001 E39 & 2005 645 ci
How have you re-set yours out of limp mode ?
Reply With Quote
  #9  
Old 07-16-2012, 08:51 AM
MajorFinesse MajorFinesse is offline
Registered User
Location: Wichita Falls TX
 
Join Date: Jun 2012
Posts: 13
Mein Auto: E63/2007 650i Cabrio SMG
Ok this issue just happened to me this weekend. The dealer told me that my SMG hydraulic pump is getting to hot and is going bad. The Transmission just shuts off.
__________________
"One Road, Many Paths"
Reply With Quote
  #10  
Old 07-16-2012, 12:02 PM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,807
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by rutdarmz View Post
wow thats huge information!! The problem I have is the same as his but my car when I need to really get some where quick usually can't keep uo and before you know it I'm in limp mode. Car should be able to handle what I'm asking from it. It really isn't that much. I've had to switch to the Toyaota and ley me wife drive the BMW. To me thats kinda sad.
That is odd, it is not normal behavior. I floor my car everywhere I go, I drive in Sport Mode along with the tranny shift lever in DS mode. Sometimes I shift manually but mostly just let it do it's thing. That coupled with the DSC being partially off allows me to put it to the cars drivetrain in a real aggressive fashion! Not one fault yet...
Reply With Quote
  #11  
Old 07-16-2012, 12:09 PM
pablo645's Avatar
pablo645 pablo645 is offline
Officially Welcomed to the 'Fest
Location: NY
 
Join Date: Feb 2009
Posts: 1,896
Mein Auto: 650i Convertible
I floor mine every time I drive it.....Ooops forgot I have a manual . I went through that limp mode nonsense with my 540 and vow never again to get another automatic BMW. Sometimes the reset will work but the issue maybe in the valve body of the tranny. Had to replace mine then and after looking at the plastic parts that made it up, I realise that it wasn't made to last too long.
__________________
2012 650-xDrive Convertible. Titanium Silver Metallic - M Package - Driver assist package- Cold weather package - luxury seating package - Bang & Oulfsen system.

Previous Cars:
2008 650 Convertible 6 speed manual
2004 645 Convertible 6 speed manual
1994 540 6 speed manual
Reply With Quote
  #12  
Old 07-16-2012, 01:39 PM
MajorFinesse MajorFinesse is offline
Registered User
Location: Wichita Falls TX
 
Join Date: Jun 2012
Posts: 13
Mein Auto: E63/2007 650i Cabrio SMG
SMG HYDRAULIC PUMP and RELAY: Transmission Failure

So I just got off the phone with the shop and they put it on the computer to find the fault...4F6F....I must admit when I first bought my car, I was told this could happen. I let it sit, and cool off for a while. It was so embrassing to push my car off the street and sit at an intersection with other BMW drivers looking at you with your hood up, when you car is clean and killing theirs!

AHHHH!!!! I was sweatin and hot!!!!! In a suite!

So the shop says its the SMG Hydraulic Pump and Relay. Considering all the driven of 52k maybe it was time to replace it. So they are going to fix it and be ready by thrus....$800 plus I told him to give me and oil change.

What a moment for a my bimmer to crash!
__________________
"One Road, Many Paths"
Reply With Quote
  #13  
Old 07-16-2012, 02:27 PM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,807
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by pablo645 View Post
Had to replace mine then and after looking at the plastic parts that made it up, I realise that it wasn't made to last too long.
I am beginning to wonder what in this car is built to last!!!!
Reply With Quote
  #14  
Old 07-19-2012, 03:58 AM
mfelsoci mfelsoci is offline
Registered User
Location: cleveland ohio
 
Join Date: May 2012
Posts: 90
Mein Auto: 2004 645ci
I had the same exact issues two weeks ago. I turned to the forum for answers and they all sound like the same information that I recieved. I took the car to the dealer and for 1400.00 dollars the trans is now working good and no faults. The reset and other recomendations are only short term fixes for something that is wrong. I did not want to jeopardize the tranny so I had it repaired. Hopefully I made the right decision.
__________________

CURRENT:
BMW 323i
BMW 645ci
Lexus SC 300
Ford F150
Dodge Ram
Reply With Quote
  #15  
Old 07-19-2012, 05:52 AM
pablo645's Avatar
pablo645 pablo645 is offline
Officially Welcomed to the 'Fest
Location: NY
 
Join Date: Feb 2009
Posts: 1,896
Mein Auto: 650i Convertible
Quote:
Originally Posted by mfelsoci View Post
I had the same exact issues two weeks ago. I turned to the forum for answers and they all sound like the same information that I recieved. I took the car to the dealer and for 1400.00 dollars the trans is now working good and no faults. The reset and other recomendations are only short term fixes for something that is wrong. I did not want to jeopardize the tranny so I had it repaired. Hopefully I made the right decision.
You made the right decision. Once you start getting faults that is a sign that something is going wrong and atleast with BMW's, they let you know things are going wrong ahead of time. Having the tranny go into limp mode is a safety feature that even though it's annoying, it's designed to save your tranny. Remember this is a high performance car and you could destroy the tranny easily with all that power. That is why MajorFinesse ended up paying $800 and not 4 grand.
__________________
2012 650-xDrive Convertible. Titanium Silver Metallic - M Package - Driver assist package- Cold weather package - luxury seating package - Bang & Oulfsen system.

Previous Cars:
2008 650 Convertible 6 speed manual
2004 645 Convertible 6 speed manual
1994 540 6 speed manual
Reply With Quote
  #16  
Old 07-01-2013, 04:59 PM
BeemerLVR619 BeemerLVR619 is offline
Registered User
Location: San Diego
 
Join Date: Jul 2013
Posts: 2
Mein Auto: 325IX
Where do I go

Quote:
Originally Posted by mfelsoci View Post
I had the same exact issues two weeks ago. I turned to the forum for answers and they all sound like the same information that I recieved. I took the car to the dealer and for 1400.00 dollars the trans is now working good and no faults. The reset and other recomendations are only short term fixes for something that is wrong. I did not want to jeopardize the tranny so I had it repaired. Hopefully I made the right decision.


What state or what city can I get my 645CI fixed for that price SD BMW quoted me way more to fix the same problem
Reply With Quote
  #17  
Old 07-01-2013, 05:01 PM
BeemerLVR619 BeemerLVR619 is offline
Registered User
Location: San Diego
 
Join Date: Jul 2013
Posts: 2
Mein Auto: 325IX
Where to go

Quote:
Originally Posted by MajorFinesse View Post
So I just got off the phone with the shop and they put it on the computer to find the fault...4F6F....I must admit when I first bought my car, I was told this could happen. I let it sit, and cool off for a while. It was so embrassing to push my car off the street and sit at an intersection with other BMW drivers looking at you with your hood up, when you car is clean and killing theirs!

AHHHH!!!! I was sweatin and hot!!!!! In a suite!

So the shop says its the SMG Hydraulic Pump and Relay. Considering all the driven of 52k maybe it was time to replace it. So they are going to fix it and be ready by thrus....$800 plus I told him to give me and oil change.

What a moment for a my bimmer to crash!
I would like to pay $800 happily to get the same code and problem fixed on my SMG 645CI
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms