Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Welcome to Bimmerfest > New Member Introductions

New Member Introductions
Welcome to Bimmerfest! Whether you are a current BMW owner or just interested in BMW cars, we hope you enjoy your visit. Take a moment to introduce yourself and post a picture of your BMW for the rest of the community to see.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-13-2012, 09:18 AM
sdcolon sdcolon is offline
Registered User
Location: Puerto Rico
 
Join Date: May 2012
Posts: 7
Mein Auto: 2003 325i
Smile Hi..P0171 P0174 codes

This is a very informative forum reason just joined ..2 months ago purch a 2003 325i Bmw...after first 90 miles check engine came on...read at Advance store, P0171 P0174 codes...Oxigen sensors changed...codes erased..after 90 miles codes came again. any suggestions what to check next?? MAF, air leaks..need to know what to look for since Ima DIY guy

thanks
sdcolon
Reply With Quote
Ads by Google
  #2  
Old 05-27-2012, 12:37 PM
hugh.r.smith hugh.r.smith is offline
Hugh47
Location: North Carolina
 
Join Date: Nov 2009
Posts: 1
Mein Auto: 2002 BMW Z3 3.0i Roadstr
There are several good threads on these codes that I used to diagnose a similar condition on my 2002 Z3. In short, I cleaned the MAF sensor, cleaned the K&N Air Filter, replace the inlet boot assembly (which was badly cracked) and then I reset the codes. After three drive cycles all all on-board diagnostic tests were complete and there were no new pending codes. Parts and cleaner kits were less than $80 US. After the repair the idle speed was slightly lower and the gas mileage was a little better.

Hugh47
Reply With Quote
  #3  
Old 06-01-2012, 10:00 AM
sdcolon sdcolon is offline
Registered User
Location: Puerto Rico
 
Join Date: May 2012
Posts: 7
Mein Auto: 2003 325i
sdcolon

HI,

Thanks for the info. will do a quick check around the hoses and vacuum areas to see if there are any leaks...Service Engine keeps coming back after 90 to 100 miles....BMW is running fine and Gas mileage its ok

Reply With Quote
  #4  
Old 09-04-2012, 11:47 AM
justmjpete justmjpete is offline
Registered User
Location: vernon NJ
 
Join Date: Dec 2011
Posts: 3
Mein Auto: bmw330cic
I had same codes on my 2004 330ci The problem is a air leak after the maf in my case the disa was leaking vacuum at the diaphram
Reply With Quote
  #5  
Old 10-17-2012, 05:09 AM
sdcolon sdcolon is offline
Registered User
Location: Puerto Rico
 
Join Date: May 2012
Posts: 7
Mein Auto: 2003 325i
HI...By any chance anybody has photos of those items mentioned, MAF sensor, Air Filter, inlet boot assembly .Im a DIY guy but need some guidance...where is the MAF? Those codes are not an easy fix..they now come back after after 30-40 miles. P0174 / P0171..
Reply With Quote
  #6  
Old 10-17-2012, 10:53 AM
Fast Bob's Avatar
Fast Bob Fast Bob is online now
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,043
Mein Auto: 2004 330Ci ZHP 3 pedals
Quote:
Originally Posted by sdcolon View Post
HI...By any chance anybody has photos of those items mentioned, MAF sensor, Air Filter, inlet boot assembly .Im a DIY guy but need some guidance...where is the MAF? Those codes are not an easy fix..they now come back after after 30-40 miles. P0174 / P0171..
You`re in the right Church, but the wrong pew....you need to sign onto the E46 Forum, which is where you should be posting your questions. Great bunch of DIYers over there.
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > Welcome to Bimmerfest > New Member Introductions
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms