Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-19-2012, 08:11 PM
Nick_M3 Nick_M3 is offline
Registered User
Location: Spokane WA
 
Join Date: May 2012
Posts: 4
Mein Auto: E46 328
EML & traction control lights. Error codes:P1189 P0601 P1542 P1477 P1188 P1250 P0150

I bought my 99 328 in September right before winter came as my only form of transportation at the time was my gsxr600. Bought from original owner. 129,XXX curently. MN. Had it inspected at Camp BMW they came back saying all it needed was coolant & brake flush as well as new tires. Did see on the Carfax that it failed emissions and then passed some time later when re-tested. In December I started my car and the EML and traction control lights came on turned the car off let it sit a few minutes turned it on lights were gone and all was good. Then in March it happened again, and again, and again. I checked the codes today and had the following:
P1189
P0601
P1542
P1477
P1188
P1250
P0150

I've done some reading through forums and have already cleaned my MAF and all connections as well as checked the oil separator to dipstick hose and it seems to be good. For all I know that might have fixed the problem as the lights come on only when starting and very intermittently sometimes same day some times weeks. Im trying to sell for something newer so I can use all the help I can get. I have attached pics to help. Probably too much info but I figured the more the better. last seven of vin#KG08559



















Reply With Quote
Advertisement
  #2  
Old 05-20-2012, 05:06 AM
mawana's Avatar
mawana mawana is offline
Officially Welcomed to the 'Fest
Location: DFW, TX
 
Join Date: Nov 2006
Posts: 2,028
Mein Auto: e46 ZHP, e90 M3
You are looking at at something that affects fuel delivery to both banks and that brings both the fuel filter and pump into the discussion. Start by performing a fuel pressure test or just ahead and change the fuel and air filters.

I don't know how to test for 02 sensors but since you engine has over 100k miles, you might as well change the pre-cat ones first. BMW recommends changing them at 100k anyway!

Seems you also have a dme error/faulty, but I think resetting adaptation values after replacing the fuel filter and clearing all codes should set it right...

g/l
__________________
"Common sense is the collection of prejudices acquired by age 18." ~ Albert Einstein
BMWCCA 405578
Reply With Quote
  #3  
Old 05-20-2012, 07:40 AM
CDaySunday CDaySunday is offline
Registered User
Location: North Carolina
 
Join Date: May 2012
Posts: 1
Mein Auto: 2004 M3
I had something similar happen to my 323Ci back in December. I reset so many things and started to guess at what it would be. I replaced the throttle body and then eventually replaced the engine wiring harness. However, my car went into limp mode whenever these lights came on.
Reply With Quote
Reply

Bookmarks

Tags
eml, error code p1189, limp mode, traction control


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms