Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)

E63 / E64 6 Series (2003 - 2013)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-22-2012, 05:24 PM
lancelira lancelira is offline
Registered User
Location: San Antonio, Texas
 
Join Date: May 2012
Posts: 8
Mein Auto: 2005 645ci
Unhappy Idrive sudden shut off on 2005 645ci

Hello, I recently purchased a 2005 645ci. I had the car fully inspected by Auto PI in San Antonio. Everything worked fine for the first 5 days. Suddenly today, after turning off the engine for about 10 minutes, when I started the vehicle, the IDrive screen showed white for an instant, then went to black. Every so often, there is a flash of white on the screen for an instant, then back to black. The IDrive control wheel has no resistance and just spins freely. There are no other problems that I am seeing other than the adaptive headlights showing a malfunction, but this was there prior to the IDrive shut off. Any help anyone could offer with troubleshooting would be really appreciated. I am praying I did not buy a lemon, but everything else was really clean on the vehicle.

Thanks for your time!
Reply With Quote
Advertisement
  #2  
Old 05-22-2012, 08:17 PM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,904
Mein Auto: 2006 650 convertible!!!
Make sure your battery and alternator are OK, probably a good idea to have them tested. Just a guess and it may not be a good one, but these cars have a history of acting crazy when the electrical system is low...
Reply With Quote
  #3  
Old 05-22-2012, 08:20 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
this sometimes occurs on my 05 645ci too. i hate it. not sure what it can be. my battery is fine tho.
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
  #4  
Old 05-22-2012, 08:26 PM
lancelira lancelira is offline
Registered User
Location: San Antonio, Texas
 
Join Date: May 2012
Posts: 8
Mein Auto: 2005 645ci
Follow Up

Just a quick update...after letting the car sit for about an hour I went out and turned it on and the IDrive came right up...no issues at all. Not sure if this helps in the diagnosis...just thought I would add.

Thank you for the ideas/thoughts so far!
Reply With Quote
  #5  
Old 05-22-2012, 08:30 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Quote:
Originally Posted by lancelira View Post
Just a quick update...after letting the car sit for about an hour I went out and turned it on and the IDrive came right up...no issues at all. Not sure if this helps in the diagnosis...just thought I would add.

Thank you for the ideas/thoughts so far!
yeah after leaving the car off for a little, itd be fine. but its still annoying to turn your car on to a nonworking idrive
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
  #6  
Old 05-22-2012, 09:28 PM
lancelira lancelira is offline
Registered User
Location: San Antonio, Texas
 
Join Date: May 2012
Posts: 8
Mein Auto: 2005 645ci
Quote:
Originally Posted by CJ645Bern View Post
yeah after leaving the car off for a little, itd be fine. but its still annoying to turn your car on to a nonworking idrive
Man that is no lie! I LOVE driving this car...the way it handles...I am just terrified to already have things going wrong.

Extended warranty, HERE I COME!!!! lol
Reply With Quote
  #7  
Old 05-22-2012, 09:48 PM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,904
Mein Auto: 2006 650 convertible!!!
Next time it does this try rebooting the I drive. Press the volume button along with the cd and dvd eject buttons all simultaneously.

Sent from my SCH-I510 using Bimmer App
Reply With Quote
  #8  
Old 05-22-2012, 10:02 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Quote:
Originally Posted by tampamark View Post
Next time it does this try rebooting the I drive. Press the volume button along with the cd and dvd eject buttons all simultaneously.

Sent from my SCH-I510 using Bimmer App
oh AND the volume button?! Sheesh I thought it was just both eject buttons. No wonder nothing happened when I did this.

Sent from my HTC Glacier using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)

Last edited by CJ645Bern; 05-22-2012 at 10:04 PM.
Reply With Quote
  #9  
Old 05-23-2012, 06:52 AM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,904
Mein Auto: 2006 650 convertible!!!
The engineers must have been inspired by the microsoft ctrl-alt-del

Sent from my SCH-I510 using Bimmer App
Reply With Quote
  #10  
Old 05-23-2012, 10:24 AM
lancelira lancelira is offline
Registered User
Location: San Antonio, Texas
 
Join Date: May 2012
Posts: 8
Mein Auto: 2005 645ci
Thanks for that heads up....I will definitelly try that IF (not when!!) it happens again. Positive thoughts...positive thoughts...positive thoughts...

Last edited by lancelira; 05-23-2012 at 10:44 AM.
Reply With Quote
  #11  
Old 05-23-2012, 03:31 PM
TxTaz's Avatar
TxTaz TxTaz is offline
Officially Welcomed to the 'Fest
Location: San Antonio, TX
 
Join Date: Jan 2011
Posts: 724
Mein Auto: 2010 650i Coupe
WooooHoooo another SA 6er on the board.
Welcome to a great forum.
I would do a iDrive reboot anyway. Since it's based on programming, this will reset it.
Let me know if you need help.
__________________
Taz...
2010 E63 Black sapphire metallic
“Speed has never killed anyone. Suddenly becoming stationary, that's what gets you.”
Reply With Quote
  #12  
Old 05-23-2012, 04:27 PM
Momo645 Momo645 is offline
Registered User
Location: Montreal
 
Join Date: Sep 2011
Posts: 26
Mein Auto: Bmw645ci
When i bought the car the module of the headlight wasnt good and idrive didnt work so they changed the qhile headlight a reprogrammed the whole car and it work great..plus during last 5 weeks i had my car throwing a bunch of error code and the idrivre was going off and finaly it was the alternator fixed it and now no more problem!
Reply With Quote
  #13  
Old 05-24-2012, 10:20 AM
lancelira lancelira is offline
Registered User
Location: San Antonio, Texas
 
Join Date: May 2012
Posts: 8
Mein Auto: 2005 645ci
Thanks for all the responses...I haven't had another issue as of yet, so I am keeping my fingers crossed!
Reply With Quote
  #14  
Old 06-22-2012, 07:54 PM
Mannyrakh Mannyrakh is offline
DO1N 1T
Location: Troy
 
Join Date: May 2012
Posts: 14
Mein Auto: 2011 M3
Having same exact problem and its driving me nuts someone please assist me nonidea what to do. HELP
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms