Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #26  
Old 06-14-2012, 07:44 AM
JEG23 JEG23 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jun 2011
Posts: 314
Mein Auto: 550i
Quote:
Originally Posted by miotoo View Post
Did everybody check this value in ICM ? 2VB is the SA code for Tire Pressure Monitor.

@shawnsheridan,

Did you check this value quoted earlier by Miotoo ? In my car it is set to verbaut.

JEG23
__________________
2011 550i
Space Gray /Black Nappa, Dark Wood
ZAV, ZCV, ZCW, ZDA, ZP2, 4NB, 5DF, 610, 2VH, 465, 6UK, 5DL, 6NR
Reply With Quote
  #27  
Old 06-14-2012, 08:18 AM
DreamCar's Avatar
DreamCar DreamCar is offline
Moderator
Location: Planet Earth
 
Join Date: Sep 2010
Posts: 2,474
Mein Auto: F10 M5
-
Reply With Quote
  #28  
Old 06-14-2012, 04:54 PM
aosman aosman is offline
Registered User
Location: Houston, TX
 
Join Date: May 2012
Posts: 19
Mein Auto: 2012 F10 550i
Quote:
Originally Posted by shawnsheridan View Post
I know this is a long shot, but I am going to ask anyway. For those without working TPMS, is your car also equipped with Active Steering?
No AS on mine
__________________
2012 550i M Sport
Reply With Quote
  #29  
Old 06-14-2012, 05:06 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by DreamCar View Post
If Alex also has active steering then you may be on to something as stealth also has active steering.

Edit: Just checked he doesnt have active steering... But i am curious why did you think active steering is the cause?
Only because I coded a car last night with IAS, and TPMS did not work, and I noticed the Tire Chain mode in the CIC to switch off IAS, so I thought there may be some connection. Obviously that is not the case.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #30  
Old 06-14-2012, 05:11 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by JEG23 View Post
@shawnsheridan,

Did you check this value quoted earlier by Miotoo ? In my car it is set to verbaut.

JEG23
No, not specifically. As I previously wrote, 2VB is standard equipment in the US. Thus 2VB should be on the VO, and in turn CAF / 3000 / IcmKod_B_SA2VB should by default be set to verbaut (installed).

I would also think if this was turned off, TPMS would not work at all as opposed to working, albeit without PSI and Temp.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #31  
Old 06-14-2012, 09:13 PM
mjgood mjgood is offline
Officially Welcomed to the 'Fest
Location: Houston, Texas
 
Join Date: Apr 2006
Posts: 120
Mein Auto: 2011 550i M-Sport
kind of a tangent on this subject....

If the tires are rotated how does the car know which is which.... are the sensors coded specifically and have to be removed and relocated, or is there a proximity receiver near each tire?
__________________

2011 550i M-Sport
2011 Countryman S
Bell 407
Reply With Quote
  #32  
Old 06-14-2012, 11:15 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by mjgood View Post
kind of a tangent on this subject....
If the tires are rotated how does the car know which is which.... are the sensors coded specifically and have to be removed and relocated, or is there a proximity receiver near each tire?
I am pretty sure BMW uses a High Line Direct TPMS, which has an LF Antenna in each wheel well that reads the RF signal transmitted from each tire sensor, which includes an identification signal for localization (wheel location).
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #33  
Old 06-15-2012, 06:39 AM
mjgood mjgood is offline
Officially Welcomed to the 'Fest
Location: Houston, Texas
 
Join Date: Apr 2006
Posts: 120
Mein Auto: 2011 550i M-Sport
Quote:
Originally Posted by shawnsheridan View Post
I am pretty sure BMW uses a High Line Direct TPMS, which has an LF Antenna in each wheel well that reads the RF signal transmitted from each tire sensor, which includes an identification signal for localization (wheel location).
Thanks Shawn...
__________________

2011 550i M-Sport
2011 Countryman S
Bell 407
Reply With Quote
  #34  
Old 06-15-2012, 05:47 PM
FastMarkA FastMarkA is online now
Officially Welcomed to the 'Fest
Location: Chicago
 
Join Date: Apr 2008
Posts: 1,589
Mein Auto: 2011 535xi
Model: 535 xDrive w/ Sport Package (not M-Sport)
Build Date: 03/2011
Delivery Date: 04/2011 (Munich); 05/2011 (Chicago)
Status: Working
Did you ever change the wheels and/or tires: Had the crappy All-Seasons replaced w/ Dunlop Summers
TPMS Type: Metal Caps
Tires: Dunlop Sport Maxx 19s
Air/Nitrogen/Other: Pretty sure it's plain ole air
__________________

2008 535xi 6-sp - Blk Sph, Blk Dkta,---2011 535xi - Jet Blk, Blk Dkta, Alum----2014 535xi - Jet Blk, Blk Dkta, Alum Hex
Bamboo | Prem | Cold | Sprt Pkg | Nav -Prem | Prem 2 | Cold | Sport | SAT ---- Cold | DA & DA+ | LED | M-Sprt | SAT | Multi
iPod/USB | Sat | Fld Dwn Seats --- ----Fld Dwn Seats | Side/Top Cameras -- ---HK Audio
Htd Rear Seats | PDC | 18" | Logic7 -- ---
(Good riddance!)
Reply With Quote
  #35  
Old 06-18-2012, 05:35 PM
dmunz dmunz is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Apr 2012
Posts: 234
Mein Auto: 535i GT
pzdata version compatability?

Here's a new thought on this - could it be linked to the version of pzdata we are using? Shawn coded mine with 46.3 (I think) and mine does not work. 1StBimmer, who also has an F07, coded his with 45.X (again, I think) and his works.

I don't know what the difference in the files is, but if you have not been able to get pressure and temp data, which version of the pzdata files are you using?

FWIW
DLM
__________________
"...hovering like a fly waiting for a windshield on the freeway..." p.g.
Reply With Quote
  #36  
Old 06-18-2012, 05:49 PM
grilodan grilodan is offline
Officially Welcomed to the 'Fest
Location: Chicago, IL
 
Join Date: Nov 2010
Posts: 243
Mein Auto: E70 X5 35i Sport Activity
Mine is 46.3. Doesn't work.
__________________


- 2013 X5 35i Sport Activity (Born 08/12) - Titanium Silver /Oyster Nevada /Dark Bamboo - ZCV /ZCW /ZPS /Sport Package /Adaptive Drive /Soft-Close Doors/Running Boards /HUD /Shift Paddles /Comfort Seats /6NR /6NF
- 2011 535i (Born 08/10) - Titanium Silver /Black Dakota /Anthracite - ZCV /ZCW /ZPP /ZP2 /6FL /6NF (Sold 08/12)
- 2010 335i (Born 02/10) - Titanium Silver /Black Dakota - ZCW /ZPP /6FL (Sold 09/10)
- 2007 328i (Born 07/07) - Jet Black /Black Dakota - ZSP /ZPP /6FL (Sold 04/10)
Reply With Quote
  #37  
Old 06-18-2012, 05:52 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by dmunz View Post
Here's a new thought on this - could it be linked to the version of pzdata we are using? Shawn coded mine with 46.3 (I think) and mine does not work. 1StBimmer, who also has an F07, coded his with 45.X (again, I think) and his works.

I don't know what the difference in the files is, but if you have not been able to get pressure and temp data, which version of the pzdata files are you using?

FWIW
DLM
I don't think the PSDZdata version matters, as when FDL Coding, it does not apply that Integration Level to the module. While you are using the latest ISTA/P files, you are still only changing a parameter on the existing module's software. If it is a software issue and not hardware related, what is more likely is that the issue is what software level is the actual module on based on when it's firmware was last flashed. Since I have successfully coded some cars with v46.3, v46.3 by itself simply can't be the issue.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #38  
Old 06-18-2012, 06:42 PM
DreamCar's Avatar
DreamCar DreamCar is offline
Moderator
Location: Planet Earth
 
Join Date: Sep 2010
Posts: 2,474
Mein Auto: F10 M5
Quote:
Originally Posted by dmunz View Post
Here's a new thought on this - could it be linked to the version of pzdata we are using? Shawn coded mine with 46.3 (I think) and mine does not work. 1StBimmer, who also has an F07, coded his with 45.X (again, I think) and his works.

I don't know what the difference in the files is, but if you have not been able to get pressure and temp data, which version of the pzdata files are you using?

FWIW
DLM
I think i coded around 14 cars with 46.3 data files and only one car had problem... Worked fine in all the other cars
Reply With Quote
  #39  
Old 06-18-2012, 07:51 PM
dmunz dmunz is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Apr 2012
Posts: 234
Mein Auto: 535i GT
Quote:
Originally Posted by DreamCar View Post
I think i coded around 14 cars with 46.3 data files and only one car had problem... Worked fine in all the other cars
I knew it was a longshot. I'm just frustrated that it doesn't work for me. This, the sport display and the folding mirrors were the big things on my "why I want to code" list.

FWIW
DLM
__________________
"...hovering like a fly waiting for a windshield on the freeway..." p.g.
Reply With Quote
  #40  
Old 06-18-2012, 07:53 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by dmunz View Post
I knew it was a longshot. I'm just frustrated that it doesn't work for me. This, the sport display and the folding mirrors were the big things on my "why I want to code" list.

FWIW
DLM
I know, it's frustrating to me too. I need someone who has a car like yours not working, then have the dealer bring the vehicle software current, and the try coding it again to see if it is the ISTA/P version on the car.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #41  
Old 06-20-2012, 01:38 PM
dmunz dmunz is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Apr 2012
Posts: 234
Mein Auto: 535i GT
Quote:
Originally Posted by miotoo View Post
Did everybody check this value in ICM ? 2VB is the SA code for Tire Pressure Monitor.
On a lark I changed this to nikt today at lunch to see if it would make a difference. I'm still not getting temp or pressure numbers. I do get the green highlites on the tires but I don't get the TMP Active text at the bottom of the display.

I'll go turn it on later today and see if it rests anything.

FWIW
DLM
__________________
"...hovering like a fly waiting for a windshield on the freeway..." p.g.
Reply With Quote
  #42  
Old 06-22-2012, 09:09 AM
chinese_food chinese_food is offline
Registered User
Location: Michigan
 
Join Date: Jun 2012
Posts: 11
Mein Auto: F10
Model:528i
Build Date: july 2011
Delivery Date: september 2011
Status: Working
Did you ever change the wheels and/or tires: no
TPMS Type:?
Tires: 275/55R17
Air/Nitrogen/Other: Nitrogen
Reply With Quote
  #43  
Old 06-26-2012, 08:52 PM
grilodan grilodan is offline
Officially Welcomed to the 'Fest
Location: Chicago, IL
 
Join Date: Nov 2010
Posts: 243
Mein Auto: E70 X5 35i Sport Activity
Hey guys ... anyone out there still trying to figure this out? I've tried all I could, but nothing yet.
__________________


- 2013 X5 35i Sport Activity (Born 08/12) - Titanium Silver /Oyster Nevada /Dark Bamboo - ZCV /ZCW /ZPS /Sport Package /Adaptive Drive /Soft-Close Doors/Running Boards /HUD /Shift Paddles /Comfort Seats /6NR /6NF
- 2011 535i (Born 08/10) - Titanium Silver /Black Dakota /Anthracite - ZCV /ZCW /ZPP /ZP2 /6FL /6NF (Sold 08/12)
- 2010 335i (Born 02/10) - Titanium Silver /Black Dakota - ZCW /ZPP /6FL (Sold 09/10)
- 2007 328i (Born 07/07) - Jet Black /Black Dakota - ZSP /ZPP /6FL (Sold 04/10)
Reply With Quote
  #44  
Old 06-26-2012, 10:48 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by grilodan View Post
Hey guys ... anyone out there still trying to figure this out? I've tried all I could, but nothing yet.
What ISTA/P version is on your car?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #45  
Old 06-27-2012, 01:27 PM
grilodan grilodan is offline
Officially Welcomed to the 'Fest
Location: Chicago, IL
 
Join Date: Nov 2010
Posts: 243
Mein Auto: E70 X5 35i Sport Activity
Here it is.
Attached Thumbnails
Click image for larger version

Name:	ImageUploadedByBimmerApp1340825214.162845.jpg
Views:	135
Size:	86.0 KB
ID:	330837  
__________________


- 2013 X5 35i Sport Activity (Born 08/12) - Titanium Silver /Oyster Nevada /Dark Bamboo - ZCV /ZCW /ZPS /Sport Package /Adaptive Drive /Soft-Close Doors/Running Boards /HUD /Shift Paddles /Comfort Seats /6NR /6NF
- 2011 535i (Born 08/10) - Titanium Silver /Black Dakota /Anthracite - ZCV /ZCW /ZPP /ZP2 /6FL /6NF (Sold 08/12)
- 2010 335i (Born 02/10) - Titanium Silver /Black Dakota - ZCW /ZPP /6FL (Sold 09/10)
- 2007 328i (Born 07/07) - Jet Black /Black Dakota - ZSP /ZPP /6FL (Sold 04/10)
Reply With Quote
  #46  
Old 06-27-2012, 02:44 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by grilodan View Post
Here it is.
Ok...seeing you have have the latest software, there goes my "Old ISTA/P" theory. I'm at a total loss as to why.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #47  
Old 06-27-2012, 03:55 PM
grilodan grilodan is offline
Officially Welcomed to the 'Fest
Location: Chicago, IL
 
Join Date: Nov 2010
Posts: 243
Mein Auto: E70 X5 35i Sport Activity
Had a feeling you'd say that. I wonder if lack of Sport Auto or Sport Package have anything to do with it. Or maybe it's just definitely a pre 09/10 thing. I can't imagine that BMW would have different TPM sensors between non-sport and sport, but who knows?
__________________


- 2013 X5 35i Sport Activity (Born 08/12) - Titanium Silver /Oyster Nevada /Dark Bamboo - ZCV /ZCW /ZPS /Sport Package /Adaptive Drive /Soft-Close Doors/Running Boards /HUD /Shift Paddles /Comfort Seats /6NR /6NF
- 2011 535i (Born 08/10) - Titanium Silver /Black Dakota /Anthracite - ZCV /ZCW /ZPP /ZP2 /6FL /6NF (Sold 08/12)
- 2010 335i (Born 02/10) - Titanium Silver /Black Dakota - ZCW /ZPP /6FL (Sold 09/10)
- 2007 328i (Born 07/07) - Jet Black /Black Dakota - ZSP /ZPP /6FL (Sold 04/10)
Reply With Quote
  #48  
Old 06-27-2012, 04:18 PM
Stealth.Pilot's Avatar
Stealth.Pilot Stealth.Pilot is offline
The Driver
Location: Florida
 
Join Date: Jul 2009
Posts: 4,577
Mein Auto: 2014 M5
Quote:
Originally Posted by grilodan View Post
Had a feeling you'd say that. I wonder if lack of Sport Auto or Sport Package have anything to do with it. Or maybe it's just definitely a pre 09/10 thing. I can't imagine that BMW would have different TPM sensors between non-sport and sport, but who knows?
It's not that. DC and I both have M Sports with Sport Auto.
__________________

2014 BMW///M5 Individual
Frozen Grey, Silverstone Full Merino, Piano Black, Exec Pkg, Drivers assistance pkg, LED Package, Bang and Olufsen, 20" Forged wheels
2015 Jaguar F-Type R Coupe
Reply With Quote
  #49  
Old 06-27-2012, 04:19 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 13,071
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by grilodan View Post
Had a feeling you'd say that. I wonder if lack of Sport Auto or Sport Package have anything to do with it. Or maybe it's just definitely a pre 09/10 thing. I can't imagine that BMW would have different TPM sensors between non-sport and sport, but who knows?
If I am not mistaken, the problem has randomly affected both pre and post 09/10 builds and Sport/Non-Sport models. There has been no identifiable common denominator for the problem.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #50  
Old 06-27-2012, 04:41 PM
wchjr56 wchjr56 is offline
Registered User
Location: Cleveland
 
Join Date: Apr 2012
Posts: 6
Mein Auto: 535ix
Model:535i
Build Date: May 2012
Delivery Date: May 2012
Status: Working
Did you ever change the wheels and/or tires: no
TPMS Type:?
Tires: RF All seasons
Air/Nitrogen/Other: Assumed Air
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms